1,105,232 Community Members

How do I stop keychain while using safari?

Member Avatar
sam11
Newbie Poster
7 posts since Oct 2004
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
1
 

Every 2-3 pages I open, Keychain opens up asking for a password saying that safari wants to use keychain.

It slows my work considerably.

Any clues?

Member Avatar
kc0arf
Posting Virtuoso
1,913 posts since Mar 2004
Reputation Points: 53 [?]
Q&As Helped to Solve: 66 [?]
Skill Endorsements: 0 [?]
Team Colleague
 
0
 

Hello,

In my humble opinion, the Keychain is a pain in the ###, and bad security management. In the ideal world, your passwords for things are all different, and not stored in some location. AutoLogin would be disabled, so that you have to authenticate everything. Granted, general users may scream at too much to remember, but who in non-cyber life has only one Key on their keychain? You have a house key, a car key, a trunk key, maybe one for the office, another for your locker at the gym....

Anyways, the Keychain control panel is in the SYSTEM VOLUME --> Applications --> Utilities --> Keychain Access. Mine is completely blank -- I refuse to keep anything in there, and thus am not prompted for anything. You may want to consider deleting anything in yours... but beware that it might break something, or you may need to start remembering all your special places again. Use at your own risk... I have never done this, because i have never had any in there to begin with.

Let us know,

Christian

Member Avatar
sam11
Newbie Poster
7 posts since Oct 2004
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Hey
I gave it a shot from what you said and keychain access is empty. Still keychain asks for my password every 3 or 4 webpages I open.
I would think that b/c it has no login's it wouldn't appear anymore but it annoyingly does.

Any other ideas?

Thanks
sam

Hello,

In my humble opinion, the Keychain is a pain in the ###, and bad security management. In the ideal world, your passwords for things are all different, and not stored in some location. AutoLogin would be disabled, so that you have to authenticate everything. Granted, general users may scream at too much to remember, but who in non-cyber life has only one Key on their keychain? You have a house key, a car key, a trunk key, maybe one for the office, another for your locker at the gym....

Anyways, the Keychain control panel is in the SYSTEM VOLUME --> Applications --> Utilities --> Keychain Access. Mine is completely blank -- I refuse to keep anything in there, and thus am not prompted for anything. You may want to consider deleting anything in yours... but beware that it might break something, or you may need to start remembering all your special places again. Use at your own risk... I have never done this, because i have never had any in there to begin with.

Let us know,

Christian

Member Avatar
kc0arf
Posting Virtuoso
1,913 posts since Mar 2004
Reputation Points: 53 [?]
Q&As Helped to Solve: 66 [?]
Skill Endorsements: 0 [?]
Team Colleague
 
0
 

Hmmmm.

I wonder if you would give it a password, if the problem would go away. Without seeing it, I am unable to really explore deeper.

Try Mozilla Firefox as a browser instead: http://www.mozilla.org and perhaps that will allow you to browse in happiness. Do not delete safari, as there might be an incompatable page here and there that Mozilla will barfup. Rare though.

Christian

Member Avatar
mmason
Newbie Poster
2 posts since Nov 2004
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I had the same problem; this was an ibook that for a faculty member here on our campus. I installed the OS 9 updates, then did a clean install of OS 10.3. I don't know what password it was asking for, because the only one I'd entered was "education" and that didn't work. I even went in as root, but the Keychain Utility was of little use, other than a message regarding System>Library>Keychains. I went into that folder, and copied the two files in there to Documents (in case what I was about to do didn't work), then I deleted the two files from the System Keychain folder. Everything worked fine after that, and the prompt didn't reappear.
I agree; the keychain deal is bogus.

Member Avatar
Transient
Newbie Poster
20 posts since Oct 2004
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I like the keychain myself, guess it tales all types :). Two things spring to mind.

1) In the latest version of keychain access on 10.3 there is a keychain repair tool, under the window menu. You can verify and / or repair your keychain if needed. You can also create a new 'factory settings' keychain using the options button.

2) Keychains can be set to lock after periods of inactivity which would cause you to be prompted for the keychain password next time an application, such as mail, tried to use it. Look at edit:change settings for details.

Member Avatar
mmason
Newbie Poster
2 posts since Nov 2004
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Thanks, Transient. As it turned out, deleting the two files in the System>Library>Keychain folder eliminated the keychain password prompt I was getting in Safari, but it was still there in IE.

So I did go to Applications>Utilities>Keychain, but the repair didn't work, because it prompted for the keychain password which of course I didn't know.
But choosing Window>Keychain First Aid, then Options, Reset my Keychain (back to factory) seems to have worked and I'm not getting the prompt in IE. If it comes back, I'll post a message. Thanks.

Member Avatar
rsoellner
Newbie Poster
1 post since Jul 2007
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I tried, windows>keychain first aid, then options, reset my keychain. Pop-up window still appears.

You
This article has been dead for over three months: Start a new discussion instead
Post:
Start New Discussion
Tags Related to this Article