1,105,281 Community Members

Hard disk not showing in finder but mounted in disk utility

Member Avatar
Josiah_1
Newbie Poster
1 post since Sep 2013
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
1
 

I had a interal disk that wouldn't show in the finder at all but was showing as mounted on disk utility. I could get to the disk through a file alias so I know the disk was there and working.

I tried numious posts including this one (http://www.daniweb.com/hardware-and-software/apple/mac-os-x/threads/94420/hard-drive-not-visible-mac-osx) with not luck.

I figured it must be a permissions problem, so I ran the termal command to show all hidden files (without the brackets):
(defaults write com.apple.Finder AppleShowAllFiles YES)
(killall Finder)

And Behold the HD was there as a hiddden file.

Then I found another termail command that makes hidden files not hidden:
chflags nohidden /path/to/the/file/to/change

and now my HD is back to normal - yay

Then made all hidden files back to hidden:
(defaults write com.apple.Finder AppleShowAllFiles NO)
(killall Finder)

Hope this helps someone

Member Avatar
tompatrick
Light Poster
46 posts since Apr 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 1 [?]
Skill Endorsements: 0 [?]
 
0
 

This is a similar experince that I had when Finder won't list my drives. But I found a way by Force Quit the finder & bang, all drive icons were back. May be this can also help to someone.

You
Post:
Start New Discussion
View similar articles that have also been tagged: