1,105,281 Community Members

403 Forbidden You don't have permission to access /index.htm on this server.

Member Avatar
hdmk
Newbie Poster
1 post since Apr 2005
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I am an Apache/linux newbie. (Trying to learn this technology...)

I setup a Mandrake 10.1 server, and am trying to setup virtual hosting.

I created a user and a www folder. Set the www folder permission to 777.
I created a virtual server as follows:

<VirtualHost *>
DocumentRoot "/home/domain/www"
ServerName *.domain.com
<Directory "/home/domain/www">
allow from all
Options +Indexes
DirectoryIndex index.html index.htm default.htm
</Directory>
</VirtualHost>

I added the DirctoryIndex line, but get the same error with or without that line.

If I try to browse any file including the root site, I get the following error message:

Forbidden
You don't have permission to access / on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

I'm assuming that this is a permission based issue, however I have 777 permissions set, so it should work. Any help would be appreciated!

Thanks!

Member Avatar
mediaphyte
Newbie Poster
19 posts since Apr 2005
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

check your permissions... is /home/domain/www readable by apache? Also, is the server & virtHost name really wild-carded? This may be a problem... I usually specify (e.g. for domains I use locally <VitualHost 127.0.0.1:80> (also match <NameVitualHost 127.0.0.1:80> ) ...blah blah.. ServerName mydom.dom

Also, if you're using symbolic links, you my need that option used here

Member Avatar
blud
Linux Reject
706 posts since Apr 2004
Reputation Points: 82 [?]
Q&As Helped to Solve: 41 [?]
Skill Endorsements: 3 [?]
Moderator
 
0
 

The previous post was pretty much head on, one thing that I noticed is that if the /home directory does not have the +x flag to everyone, then it may not be able to go into your directory, may want to do chmod +x /home

Member Avatar
SuperFlyHost
Newbie Poster
13 posts since Apr 2005
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Good Answer to his question, I was going to say as well if you are creating a Web server to host people on or even your own stuff.

Please make sure you have Firewall, IPTables, and GRSecurity.

I am hoping you understand what I mean.

Thankx,
Michael :cheesy:

Member Avatar
hari100
Newbie Poster
1 post since May 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

change the file permission of index.html to 644
chmod 644 home/domain/www/index.html

Member Avatar
kmohanshetty
Newbie Poster
1 post since Dec 2011
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Thanks for the information, it was useful.

You
This article has been dead for over three months: Start a new discussion instead
Post:
Start New Discussion
View similar articles that have also been tagged: