1,105,333 Community Members

Unbuntu wireless

Member Avatar
fish234
Newbie Poster
10 posts since Feb 2011
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Does anyone know if unbuntu can connect to the internet wirelessly, it's not picking up the wireless card in the computer so I was wondering if you had to do something particular to get it to work.

Any help would be great.
thanks

Member Avatar
orwell84
Junior Poster
100 posts since Nov 2008
Reputation Points: 7 [?]
Q&As Helped to Solve: 5 [?]
Skill Endorsements: 0 [?]
 
0
 

Wireless Internet is always a pain to get right. Look at tech specs for your computer and find out what kind of wireless card it has, then search Google for how to get it working with your card (you might be able to just search for how to get wireless with your computer name) You'll probably have to install a driver, and maybe use ndiswrapper.
But yes, Ubuntu can connect to the Internet wirelessly.

Member Avatar
jackmaverick1
Posting Whiz in Training
228 posts since May 2010
Reputation Points: -4 [?]
Q&As Helped to Solve: 12 [?]
Skill Endorsements: 0 [?]
 
0
 

I had the same problem but the additional drivers app had the driver ready for my use...

Maybe that helps

Member Avatar
Reverend Jim
Noli mentula
5,444 posts since Aug 2010
Reputation Points: 746 [?]
Q&As Helped to Solve: 653 [?]
Skill Endorsements: 51 [?]
Moderator
Featured
 
0
 

I had the same problem with Ubuntu Studio. I don't have the installation handy so I will be guessing at the name here but I think you have to cable up then install a package called (I think) widi. My problem was that every time I tried to enable the wireless connection by setting the authentication type and access key, the setting were discarded. After I installed widi I was able to set and save. My Ubuntu is on an external drive (I boot to USB when required) and I do not have the drive here right now. If I am incorrect about the package name I will correct it shortly.

By the way, this fix was difficult to identify and in my opinion, should have been included with the default install. But then again, I am a Linux noob so the fault may be entirely mine.

Member Avatar
b1izzard
Junior Poster
118 posts since Jun 2009
Reputation Points: 0 [?]
Q&As Helped to Solve: 14 [?]
Skill Endorsements: 0 [?]
 
0
 

Try this,

In Terminal enter

[B] >lsusb[/B]
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
[B]Bus 003 Device 002: ID 12d1:1010 Huawei Technologies Co., Ltd. [/B]
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[B] >sudo gedit /etc/rc.local[/B]

Add the line

[B]sudo modprobe usbserial vendor=0x12d1 product=0x1010[/B]

before exit 0 and restart.

Member Avatar
Reverend Jim
Noli mentula
5,444 posts since Aug 2010
Reputation Points: 746 [?]
Q&As Helped to Solve: 653 [?]
Skill Endorsements: 51 [?]
Moderator
Featured
 
0
 

My mistake. The package you want to install is "wicd" and is described in Synaptic Package Manager as:

Wicd is a general-purpose network configuration server which aims
to provide a simple but flexible interface for connecting to networks.
Its features include:
wide variety of settings.
* ability to connect to (and maintain profiles for) both wired and
wireless networks;
* support for many encryption schemes, including WEP, WPA, WPA2 and
custom schemes;
* wireless-tools compatibility;
* tray icon showing network activity and signal strength;
* lack of GNOME dependencies (although it does require GTK+), making it
easy to use in Xfce, Fluxbox, Openbox, Enlightenment, etc.

This is a metapackage, it allows installation of all the components of
Wicd, including one of the clients, which must be manually chosen.

Member Avatar
jwiere03
Newbie Poster
4 posts since Feb 2011
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

When I installed Ubuntu it automatically found my wireless network. I just had to enter my password and I was on. I had looked up how to connect a head of time and watched a video on Youtube because I had some previous Linux experience at a different house and didn't think that Ubuntu would find and connect like this.

However keeping it up and running is another matter. Worked fine for the first 5 months or so. Over the last 4 or 5 I have had about 10 times where all the Windows computers in the house could connect but my Ubuntu couldn't and had to restart my router to get it too work. Other then this simple but annoying issue no problems.

Member Avatar
jbennet
Moderator
17,127 posts since Apr 2005
Reputation Points: 1,618 [?]
Q&As Helped to Solve: 736 [?]
Skill Endorsements: 38 [?]
Team Colleague
Featured
 
0
 

Its really easy, if your driver is supported. Ubuntu is a lot better than the others.

My Intel 3945 works great, but Broadcom cards need a proprietary driver to work. They are a pain, but the "hardware/restricted drivers" applet should be able to get them for you.

Member Avatar
khakilang
Posting Pro in Training
468 posts since Jul 2009
Reputation Points: 0 [?]
Q&As Helped to Solve: 44 [?]
Skill Endorsements: 0 [?]
 
0
 

Normally for I would install Ubuntu restricted extra first after a fresh install and than I will check for driver with "Additional driver" to install any driver that has not been install. I do this with cable plug in and after everything has been isntall than only I will use the wifi connection. So having a network cable around is handy.

You
This article has been dead for over three months: Start a new discussion instead
Post:
Start New Discussion
View similar articles that have also been tagged: