1,105,633 Community Members

sound problem

daniello
Newbie Poster
1 post since Dec 2012
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
Unverified Member
 
0
 

i just installed linux mint isadora on my dell inspiron n5110 but the sound does not play out. i can be watchinng movie or playing music and yet still the sound doesnt come out

Member Avatar
Octet
Posting Pro
579 posts since Nov 2011
Reputation Points: 45 [?]
Q&As Helped to Solve: 53 [?]
Skill Endorsements: 16 [?]
Featured
Sponsor
 
0
 

Hello Daniello,

Make sure you go through the basics, when installing a new OS then you shall also need to install the drivers for the sound card and make sure it is being detected.

Once the drivers are installed from the manufacturers website then you shouldn't have any further issues. Failing that, check that you have everything hooked up such as your speakers connected properly and they are on... sounds obvious but it happens to the best of us :D

Good luck!

Member Avatar
JasonHippy
Practically a Posting Shark
898 posts since Jan 2009
Reputation Points: 648 [?]
Q&As Helped to Solve: 164 [?]
Skill Endorsements: 8 [?]
 
0
 

It might be worth opening whatever sound-mixer software ships with that version of Mint (I'm not a Mint user myself, so I'm not sure what programs ship in the default install), but open the default, system sound mixer program and check that all relevant channels are enabled, are not muted and are turned up.

In the past I have seen cases where on first boot, the mixer has either started with the master channel muted, or has the master volume up and has the volumes for one or more of the other audio channels muted, or turned right down to zero.

You can usually access the full mixer by clicking or right-clicking on the volume/speaker icon in the notification area of the system tray and selecting an option (usually something like 'open mixer'), then there is usually something in the options which allows you to show/hide the sliders for the different channels. Show/Enable all of the sliders and check their settings (you can hide any irrelevant sliders again once you've checked them all)

It could also be that the device settings in the mixer are incorrect. So take a look at those. (e.g. In the mixer programs options, you might need to ensure that the 'OSS mixer' option is selected in the analogue devices section)

If none of the above works, what output do the following commands give you?
lspci | grep -i audio - should list any bits of audio related hardware it finds
lsmod | grep -i snd - should list any loaded kernel modules related to sound.

Those commands should enable us to see if the sound card is detected and whether there are appropriate drivers loaded for your sound card. If the correct drivers aren't installed/loaded, you'll need to track down the appropriate Linux drivers for your hardware and install them. A quick apt-cache search {insert soundcard model/manufacturer here} should allow you to determine if there are any drivers in the mint repos and you can use apt-get to install them. Otherwise you'll have to take a look at the hardware manufacturers website and search for appropriate drivers.

But if all of the mixer settings are correct, the soundcard is detected and appropriate drivers are loaded; the only other thing I can think of is that it could be some conflict between the various sound related frameworks (Pulseaudio, ALSA and OSS). So you might want to try killing pulseaudio to see if that makes a difference.

Other than that, I'm pretty much out of ideas for now. Try those suggestions out and see what happens. If you have no luck, post the output of the lspci and lsmod commands listed above and somebody may be able to offer some more advice!

You
This article has been dead for over three months: Start a new discussion instead
Post:
Start New Discussion
Tags Related to this Article