1,105,594 Community Members

HDMI cable to connect my ubuntu 12.04 lappy to samsung tv

Member Avatar
Violet_82
Veteran Poster
1,002 posts since Jan 2010
Reputation Points: 14 [?]
Q&As Helped to Solve: 6 [?]
Skill Endorsements: 8 [?]
 
0
 

Hi all, I am having serious troubles connecting my laptop to the tv. I can do that with windows ok, but not in the linux. Somebody suggested to install bumblebee http://eternalvoid.net/tutorials/linux-optimus-gt650m/, which I seem to have successfully done. I think the reason was because my laptop had the nvidia drives and they were causing troubles etc etc. Still I get a no signal message on the tv. I have tried the fn keys as I would in windows but nothing. I have tried under monitor no joy either. Is there any command I have to issue to get tv to pick up my laptop or something else? Is there anything else I should check on my laptop, like right drives being loaded or whatever?

Member Avatar
rubberman
Senior Poster
3,997 posts since Mar 2010
Reputation Points: 513 [?]
Q&As Helped to Solve: 501 [?]
Skill Endorsements: 87 [?]
 
0
 
  1. (with laptop shut down) connect hdmi cable to TV.
  2. Boot laptop.
  3. If TV still shows "no signal", go into nvidia x-server settings and set the system to use the hdmi monitor.

If #3 doesn't work... I'm at a loss. :-( Try it, in any case. Often, booting with the device attached will let the system "see" it and enable it on boot.

Member Avatar
Violet_82
Veteran Poster
1,002 posts since Jan 2010
Reputation Points: 14 [?]
Q&As Helped to Solve: 6 [?]
Skill Endorsements: 8 [?]
 
0
 

I tried already to boot up with the cable connected to it, and it didn't work, how fo I go to the invidia settings and how do I set the system to use the monitor?
thanks

Member Avatar
rubberman
Senior Poster
3,997 posts since Mar 2010
Reputation Points: 513 [?]
Q&As Helped to Solve: 501 [?]
Skill Endorsements: 87 [?]
 
0
 

Do you have the default nouveau driver installed, or the proprietary nVidia driver? You REALLY need the proprietary one, and that requires blacklisting the nouveau driver so it doesn't get loaded at boot time.

Once you have the proprietary driver installed, you will see in the System->Preferences menu the entry "Nvidia X Server Settings". To install it, download the nVidia*.run file, and then edit the file /etc/modprobe.d/blacklist.conf, adding the entry "blacklist nouveau". Next, switch to non-gui mode. You should be able to do that with the command "telinit 3" which will set you to console mode (at least for Red Hat distributions - not sure about Ubuntu, but there is something similar for that". Then, you can install the proprietary nVidia driver. Once that is successfully done (don't use the drivers in the Ubuntu package managers...), then you can reboot, and you should be able to configure your displays with the nVidia X server settings.

Member Avatar
Violet_82
Veteran Poster
1,002 posts since Jan 2010
Reputation Points: 14 [?]
Q&As Helped to Solve: 6 [?]
Skill Endorsements: 8 [?]
 
0
 

well I am not sure anymore what driver I have to be honest, I have tampered so much with that...Let's start from the beginning, how do I find out wha driver I have, is there a command for that?

Member Avatar
aVar++
Posting Whiz
360 posts since Dec 2012
Reputation Points: 14 [?]
Q&As Helped to Solve: 33 [?]
Skill Endorsements: 0 [?]
 
0
 

Try pressing one of these when it's connected to the external monitor: Fn + F3, F4, F5, F8, or F9.

Member Avatar
Violet_82
Veteran Poster
1,002 posts since Jan 2010
Reputation Points: 14 [?]
Q&As Helped to Solve: 6 [?]
Skill Endorsements: 8 [?]
 
0
 

Done that already mat1998x

You
This article has been dead for over three months: Start a new discussion instead
Post:
Start New Discussion
Tags Related to this Article