1,105,581 Community Members

Unable to open JPG files on desktop with Windows Picture and Fax Viewer

Member Avatar
hanchiu
Newbie Poster
4 posts since Mar 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I've been following another thread, which was marked solved for this problem, but the solution described was not explained well enough for me to understand and implement it.

Basically when you double click on a jpg file on the desktop the Windows Picture and Fax Viewer will open briefly and preview and then close. If you move the file to a regular folder it will then open properly with a double click. If you right click on the file and pick open with windows picture and fax viewer it will open. If you then choose choose programs you can even click to say that you want it always to use thie program, however, oddly enough when you go back to double click nothing happens. If you right click and then pick the properties menu and then choose change program you find that open with windows picture viewer is high lighted and there is a check box in use this program always. It is greyed out so it can not be changed.

Anyone have any solutions, please copy han@cmxcpital.com

Member Avatar
caperjack
I hate 20 Questions
13,851 posts since Aug 2003
Reputation Points: 875 [?]
Q&As Helped to Solve: 902 [?]
Skill Endorsements: 69 [?]
Team Colleague
 
0
 

if it were mine i would download ccleaner and clean out windows of un-necessary files and also use the registry cleaner as well ,might just be a mixup in the registry .
soor you will have to check back here as i do not email out help ,sorry .
www.ccleaner.com.

Member Avatar
Eagleizer
Newbie Poster
6 posts since Jun 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I had same problem and found that Windows picture and fax viewer does not
allow you to have a shortcut to the desktop itself, on the desktop. Crappy soft!
Solution: Remove desktop icon from desktop...

Hope this helps someone :)

Member Avatar
caperjack
I hate 20 Questions
13,851 posts since Aug 2003
Reputation Points: 875 [?]
Q&As Helped to Solve: 902 [?]
Skill Endorsements: 69 [?]
Team Colleague
 
0
 

I had same problem and found that Windows picture and fax viewer does not
allow you to have a shortcut to the desktop itself, on the desktop. Crappy soft!
Solution: Remove desktop icon from desktop...

Hope this helps someone :)

hello,the original post is talking about having a .jpeg file on the desktop ,not a picture and fax viewer program shourt cut

Member Avatar
Eagleizer
Newbie Poster
6 posts since Jun 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

hello,the original post is talking about having a .jpeg file on the desktop ,not a picture and fax viewer program shourt cut

Have you been drinking???

Cut from First post:
Unable to open JPG files on desktop with Windows Picture and Fax Viewer

To make this understandable for everybody:
If you can not open .jpg-files from your desktop, WITH "Windows Picture and Fax Viewer",
it might be that you have a shortcut to the desktop itself, ON the desktop. If so, remove the
"desktop-shortcut" from youre desktop, and youre problem should be gone.

If you dont understand this, youre problem is probably related to something else...

Reg Eagleizer

Member Avatar
caperjack
I hate 20 Questions
13,851 posts since Aug 2003
Reputation Points: 875 [?]
Q&As Helped to Solve: 902 [?]
Skill Endorsements: 69 [?]
Team Colleague
 
0
 

Have you been drinking???

Cut from First post:

no i think maybe you have .lol
taken from the first post

Basically when you double click on a jpg file on the desktop the Windows Picture and Fax Viewer will open briefly and preview and then close

It reads == Unable to open JPG files on desktop, with Windows Picture and Fax Viewer.
read it again, the jpg file's are on the desktop ,they double click on them and the viewer opens briefly but closes ,they then take them from the desktop and put them in a folder elsewhere, and they will open . good day

Member Avatar
Eagleizer
Newbie Poster
6 posts since Jun 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

no i think maybe you have .lol
taken from the first post


It reads == Unable to open JPG files on desktop, with Windows Picture and Fax Viewer.
read it again, the jpg file's are on the desktop ,they double click on them and the viewer opens briefly but closes ,they then take them from the desktop and put them in a folder elsewhere, and they will open . good day

Hehe . You ar funny!
Try this:
Go to youre desktop-folder and make a shortcut to it.
Place the shortcut on youre desktop.
Change the look of youre icon. (Right-click youre icon and choose "Change icon")
Place a .jpg file on youre desktop.
Dubleclick the .jpg file, or rightclick an choose "Open with" - Windows Picture and Fax Viewer.

Let me know what happens... ;)

Member Avatar
Eagleizer
Newbie Poster
6 posts since Jun 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

BTW caperjack:

I have never metioned anything about a
shortcut to Windows Picture and Fax
Viewer, as you are applaying in post #4...

It is the changeing of the ICON of the
shortcut to DESKTOP-folder, if it is located
on youre desktop, that makes the problem
with Windows Picture and Fax Viewer. Got
it? :)

You are only making people with this problem, confused...

Have a nice day ;)

Member Avatar
caperjack
I hate 20 Questions
13,851 posts since Aug 2003
Reputation Points: 875 [?]
Q&As Helped to Solve: 902 [?]
Skill Endorsements: 69 [?]
Team Colleague
 
0
 


You are only making people with this problem, confused...

Have a nice day ;)

lol, im confused so everyone else should be confused too.LOL
tell me this and i will say no more ,you post #3 you made this statement because ! i thought you were telling the orignal post how to fix his problem ,but now i think you were just sharing your problem ,correct ,because the 2 problems are not the same,,post one mentions nothing about having a desktop folder shortcut on the desktop ,that i can see

Member Avatar
Eagleizer
Newbie Poster
6 posts since Jun 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

:)
I understand that this can be a never ending story...
My problem was EXACTLY the same. And it took me weeks
to solve the problem.

But If you read my first post (#3), you will see that I point
out that having a DESKTOP-shortcut on youre desktop,
MIGHT be causing the problem described in the first post
by hanchiu.

If hanchiu don`t know what is causing the problem, why
would he describe what kind of shotcuts he has on his desktop.
He does not say that he DON`T have a shortcut on his desktop.
Who could ever guess that a shortcut would cause problems
in programs it`s not related to? That was the reason for my post!

Youre lost! :) Case closed...

If any of this helped anyone, please let us know.. :)

Have a nice summer everybody!

PS. I have recreated the problem with DESKTOP-shortcut in both
XP 32 and 64 bit...

Member Avatar
caperjack
I hate 20 Questions
13,851 posts since Aug 2003
Reputation Points: 875 [?]
Q&As Helped to Solve: 902 [?]
Skill Endorsements: 69 [?]
Team Colleague
 
0
 

ok, I lost again !
A shortcut to the desktop folder on the desktop !pointless

Member Avatar
gerbil
Industrious Poster
4,623 posts since May 2005
Reputation Points: 190 [?]
Q&As Helped to Solve: 338 [?]
Skill Endorsements: 5 [?]
 
0
 

I must admit it never occurred to me to put a shortcut to my desktop on my desktop.
I most likely will not. It sounds like something Mobius would do.
Edit: Oops!... there is the icone in my quicklaunch bar which I use... forgot that one... but anyway it's a command, not a true shortcut.

Member Avatar
caperjack
I hate 20 Questions
13,851 posts since Aug 2003
Reputation Points: 875 [?]
Q&As Helped to Solve: 902 [?]
Skill Endorsements: 69 [?]
Team Colleague
 
0
 

since my last post i created a shortcut to my desktop folder, on my desktop ,and i must say it never affected my ability to open jpeg file with picture and fan viewer from my desktop .

Member Avatar
tjperez927
Newbie Poster
1 post since Jun 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I think the solutions involving a "Desktop Shortcut" is for an unrelated problem from what is being discussed here. I have the exact same issue, IDENTICAL to the description in the initial post. I can not directly view jpeg files when they are on the desktop. The Windows Picture and Fax Viewer opens but then closes immediately. However, if I create a folder on the desktop and put the jpeg in it, I can then open the picture when I double-click.

I have NO SHORTCUTS to the DESKTOP anywhere on my desktop. I even cleaned off my desktop of everything except the default icons (and a couple of picture files) and the problem still persists.

This is an annoying inconvenience because pictures I download, copy, etc. go to my desktop first. It would be nice to double-click and view it from my desktop so I know what folder to put it in permanently. Meanwhile, I have to remember to right-click/open.

Member Avatar
caperjack
I hate 20 Questions
13,851 posts since Aug 2003
Reputation Points: 875 [?]
Q&As Helped to Solve: 902 [?]
Skill Endorsements: 69 [?]
Team Colleague
 
0
 

I think the solutions involving a "Desktop Shortcut" is for an unrelated problem from what is being discussed here. I have the exact same issue, IDENTICAL to the description in the initial post. I can not directly view jpeg files when they are on the desktop. The Windows Picture and Fax Viewer opens but then closes immediately. However, if I create a folder on the desktop and put the jpeg in it, I can then open the picture when I double-click.

I have NO SHORTCUTS to the DESKTOP anywhere on my desktop. I even cleaned off my desktop of everything except the default icons (and a couple of picture files) and the problem still persists.

This is an annoying inconvenience because pictures I download, copy, etc. go to my desktop first. It would be nice to double-click and view it from my desktop so I know what folder to put it in permanently. Meanwhile, I have to remember to right-click/open.

interesting ,it works for me ,what i would try if i had this problem is create a new user via the users in control panel,and download jpg to its new desktop and see what happens

Member Avatar
Eagleizer
Newbie Poster
6 posts since Jun 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

since my last post i created a shortcut to my desktop folder, on my desktop ,and i must say it never affected my ability to open jpeg file with picture and fan viewer from my desktop .

Well.. As I said:
The problem does not occur until you change the ICON.
And yes: the jpeg will still open if you place it in a folder...

And for those of you who wonder why I ever had a shortcut to the desktop, on my desktop:

I always download to my desktop, and since I`m using 2x22" screens, it could be messy.
To quickly access search to find things on my desktop, I could just right-click the desktop-icon, and choose SEARCH, to just search the desktop.. OK? :)

Have a nice summer ;)

Member Avatar
henryd
Newbie Poster
1 post since May 2009
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I also had the same problem with Windows Picture and Fax Viewer not displaying when clicking a JPG on the desktop but working normally everywhere else. When choosing Open With it would open but show only an error message No Preview Available.
Sure enough, there was a shortcut to the Desktop folder sitting on the desktop. Removing it fixed the problem. Did not do anything to the shortcut other than remove it.

Member Avatar
FlamingClaw
Posting Pro
559 posts since Feb 2009
Reputation Points: 98 [?]
Q&As Helped to Solve: 138 [?]
Skill Endorsements: 0 [?]
 
0
 

By default, Windows XP opens all picture files (gif,jpg,...) with the included Windows Picture and Fax Viewer no matter what other picture viewers you have installed. To disable the Windows Picture and Fax Viewer, unregister shimgvw.dll. This can be done from command prompt:
regsvr32 /u shimgvw.dll

(Additional note: unregistering shimgvw.dll will also disable thumbnail view in Explorer and may cause problems changing user account and desktop background pictures. To reenable Picture and Fax viewer again type: regsvr32 shimgvw.dll

Member Avatar
safa.khan
Newbie Poster
2 posts since May 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

hey i have the same problem
any guidance ..
i normali do trouble shootin on ma own but this prob duzent seem to vanish :S
plz ..do repli if any of u can guide.
on desktop jpeg'z duzent open.it shows as it is opening fax n picture viewer then it duzent while in any othr folder it goes fine..

Member Avatar
scsawyer
Newbie Poster
2 posts since Jun 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

ok if you ask me i think it is a corupt profile, log in under a different user name then back up everything from my docs, desktop, favorites, and any other folders in the profile. then right click on my computer go to properites, then advance, setting under user profiles, highlight and delete your profile, then log back in with your user name and password, let it rebuild your profile then restore your files and doc and favorite. this should fix the problem.

You
This article has been dead for over three months: Start a new discussion instead
Post:
Start New Discussion
Tags Related to this Article