1,105,456 Community Members

Toshiba T115D-S1120 XP drivers

Member Avatar
BTCG07
Newbie Poster
14 posts since May 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I decided to set off on the long adventure of downgrading a laptop shipped with Windows 7 to XP(pro). I have got to the point where only two drivers are missing in device manager and after 3 straight days of research I have decided to ask for help.

The two devices missing drivers are listed as:
High Definition Audio Bus
SM Bus Controller

The audio device comes down to I simply could not find a driver that would install and solve this missing driver issue. The win7 driver listed for it is Conexant Audio Driver (Conexant Pebble High Definition SmartAudio) and the win7 driver version number is listed as 4.98.16.61. If anyone could point me in the right direction for the XP driver it would be much appreciated.

The SM Bus Controller is a little harder of an issues. I believe I have tracked it to the chipset drivers which in this case is for an AMD M780G/ATI Mobility HD 3200. Now I was able to install the recommended Catalyst suit and display driver from the AMD support site how ever this left the SM Bus Controller untouched. After extensive research it seems that this chipset driver was supposed to be included in the Catalyst suit I installed. Is there anyway to solve this issue?

Detailed Spec Sheet: (direct link did not work, select the "Detailed Specs" tab)
http://www.csd.toshiba.com/cgi-bin/tais/support/jsp/modelContent.jsp?ct=DL&os=&category=&moid=2523316&rpn=PST1LU&modelFilter=T115D-S1120&selCategory=2756709&selFamily=1073768663

Thank you for any help and direction yall can provide.

Member Avatar
rch1231
Veteran Poster
1,187 posts since Sep 2009
Reputation Points: 131 [?]
Q&As Helped to Solve: 194 [?]
Skill Endorsements: 13 [?]
 
0
 

I have come accross this a couple of times. What you need are the chipset drivers for the AMD motherboarde. Once you have those the others will be useable. See if there is a listed chipset in the windows 7 drivers list and go to the homepage for the Mother Board MFG and see if they have a XP driver. From the specs at the site you listed you need the AMD M780G Chipset driver from AMD. And the Conexant Audio Driver for Windows XP from another Toshiba or from the Conexant site.

Member Avatar
hispeedprc
Newbie Poster
5 posts since Nov 2011
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

which version of the catalyst driver did you get to work? I've tried several different ones trying to get the video working on my T115D-S1120 with no luck.

Member Avatar
BTCG07
Newbie Poster
14 posts since May 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

For the display driver and HDMI audio you will first have to do all the XP updates otherwise the driver installer will not detect the hardware. Then I downloaded the the recent ATI HD 3200 XP drivers from ATI's support page and used Mobility Modder before installing them on the Toshiba. Also .NET 2.0 framework is required for CCC. The Catalyst suit version i ended up using was 11.9

This did give me CCC and solved the missing display driver and HDMI audio however this does not solve the SM Bus Controller and through my research it seems AMD bundles their chipset driver with their display drivers since its the same chip. Still trying to solve this.

Mobility Modder and a brief tutorial:
http://www.hardwareheaven.com/modtool.php
http://laptop-driver.blogspot.com/2009/11/ati-mobility-radeon-hd3200-xp-driver.html

Supposedly you do not need to mobilize the xp driver found here: http://support.amd.com/us/psearch/Pages/psearch.aspx?type=2.7&product=2.7.4.3.3.3.1&contentType=Tech+Download+Chipset+Motherboard&ostype=&keywords=&items=20

I will be trying this instead of the one I used later today to see if it fixes the Bus Controller.

Member Avatar
hispeedprc
Newbie Poster
5 posts since Nov 2011
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Okay I'll try that. I had no problem getting the chipset driver just cant remember where I got it from. If I can get it trust me it's not hard to do....

Member Avatar
hispeedprc
Newbie Poster
5 posts since Nov 2011
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Mobility Modder worked beautifully-have the 3200 driver thanks for that. Just need audio....

Member Avatar
BTCG07
Newbie Poster
14 posts since May 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Finally found the right SM Bus Controller driver, it was in the 9-7 AMD South Bridge Drivers. I have attached a zip file for help with future inquiries.

Only thing left is the audio, so far have tried forcing the win7x86 for T115D-S1120, the VistaX86 drivers for a similar Toshiba model and XP drivers for an HP with a previous generation audio card. Will keep trying and will post results.

Attachments SM_Bus.zip (44.46KB)
Member Avatar
hispeedprc
Newbie Poster
5 posts since Nov 2011
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Thanks for that. Although I have the video driver I dont have any control of the screen brightness plus I get an error message on rebooting if the ac adapter is not connected. Have you been able to resolve these issues? Seems to be related to not having CCC installed...

Member Avatar
BTCG07
Newbie Poster
14 posts since May 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I do not get said error message when booting w/out AC adapter. As for the screen brightness, I have heard this is fixed with the function keys.

I ran across this fix several times now, I'm combing through my history to find it again, Ill post a link as soon as I locate it again. Essentially its the fix need for the Toshiba function keys, if you just want to change the brightness once you can change the color settings in CCC as well.

Member Avatar
BTCG07
Newbie Poster
14 posts since May 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Its funny, when I didn't need the fn key fix it kept coming up and ever since I posted to look for I have not seen it once... go figure lol.

As for this adventure into XP downgrading after two weeks I have finally restored back to windows 7. While on paper I had more resources available I was unable to smoothly run applications that worked just fine on my XP desktop and when the laptop was win 7. Not sure if this was just due to my experience and the driver I used or if its just that the computer is optimized for windows 7.

For those interested in attempting this, it was not easy and there did not seem to be any performance boost in fact it seemed to run choppy at best. I was working off my limited knowledge and hours of google searches so someone more experienced will most likely have better success.

Member Avatar
hispeedprc
Newbie Poster
5 posts since Nov 2011
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I also gave up. Not worth the time and aggravation. You'll see my toshiba on ebay since I cant stand how slow it is with windows 7 and a single core chip...

You
This article has been dead for over three months: Start a new discussion instead
Post:
Start New Discussion
View similar articles that have also been tagged: