1,105,263 Community Members

USB keyboard not working

Member Avatar
nickyt8
Newbie Poster
15 posts since Oct 2004
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Hi,

For some reason my usb keyboard and mouse has stopped working within windows. I have tried going in through safe mode with the same problem the wierd thing is the keyboard works in BIOS. Any of you guys had the same problem or have any ideas on how to solve the problem?
any help is appreciated.

Member Avatar
mechbas
Practically a Master Poster
607 posts since Jan 2007
Reputation Points: -5 [?]
Q&As Helped to Solve: 27 [?]
Skill Endorsements: 0 [?]
 
0
 

the kbd. & mouse gets it's support in the BIOS, just because one of them works there doesn't = the fact that either is enabled which is required for the OS to make use of either. if it's been a while you might check the CMOS batt. for depletion.

Member Avatar
jbennet
Moderator
17,127 posts since Apr 2005
Reputation Points: 1,618 [?]
Q&As Helped to Solve: 736 [?]
Skill Endorsements: 38 [?]
Team Colleague
Featured
 
0
 

Its windows fault. I know that if i plug either my mouse or keyboard into a new USB port then i have to leave it for ages (sometimes up to 45 mins), but that usuallly fixes it - until someone uplugs it again :(

Member Avatar
nickyt8
Newbie Poster
15 posts since Oct 2004
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

the kbd. & mouse gets it's support in the BIOS, just because one of them works there doesn't = the fact that either is enabled which is required for the OS to make use of either. if it's been a while you might check the CMOS batt. for depletion.

i replaced the battery and the problem persists, also i installed windows on another partition and the keyboard and mouse works ok. Im thinking its a windows problem, does anyody know how i can reinstall the keyboard drivers bearing in mind the keyboard and mouse dont work in safe mode?
also is there any way i can use system restore through the repair console?

Member Avatar
digitalocksmith
Posting Whiz in Training
257 posts since Aug 2006
Reputation Points: 52 [?]
Q&As Helped to Solve: 27 [?]
Skill Endorsements: 0 [?]
 
0
 

Sounds as though you have either a driver issue, or device conflict issue with that particular install of windows, which i will assume is XP!
Have a check in 'device manager', and see if there are any yellow exclamation marks or red crosses next to the device in question!
Having used Vista since its early development, i forget the exact path in XP, but i think you can access device manager from start>control panel>administrative tools>computer management, open DM from the left tree pane and then click on the little plus (+) signs next to 'keyboard' and 'mice and other pointing devices'.
If you dont see any colored symbols, right click the listed devices in question and select 'properties' then the 'driver' tab at the top!

From here you should see the currently installed driver version, date and supplier.
You can also update( which is the option you should choose), roll back and uninstall the current drivers!

Installing the current driver versions for your devices is not a bad idea, and these can be usually obtained from the device manufacturers website if windows doesnt find them on the update!

Good Luck :cool:

Member Avatar
nickyt8
Newbie Poster
15 posts since Oct 2004
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

If i could get to device manager that would be great , but both my keyboard and mouse arent working in windows or safe mode.

Member Avatar
digitalocksmith
Posting Whiz in Training
257 posts since Aug 2006
Reputation Points: 52 [?]
Q&As Helped to Solve: 27 [?]
Skill Endorsements: 0 [?]
 
0
 

oops.....sorry nickyt8, you did mention that!
my oversight....doh!

Can you get your hands on the old ps2 connecting keyboard and mouse?
These should operate straight of the bat and allow you to enter your system and check for problems and reinstall the necessary drivers!

Regards.....

Member Avatar
nickyt8
Newbie Poster
15 posts since Oct 2004
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

ok.... i finally got windows to recognise there is a mouse plugged in, however when the hardware wizard comes to install i get the error "an error occurred during the installation of the device the required selection was not found in the INF". anybody seen that error before?

also i will try with a ps2 connector and see if that brings any joy, thanks for the help.

Member Avatar
digitalocksmith
Posting Whiz in Training
257 posts since Aug 2006
Reputation Points: 52 [?]
Q&As Helped to Solve: 27 [?]
Skill Endorsements: 0 [?]
 
1
 

I have seen that error message before when installing a scanner on windows 2k!

Sadly, you can end up troubleshooting it for hours or days on end as it seems to be a problem with some sort of registry corruption i believe.
The problem was corrected quickly and efficiently with a format of that partition and a clean install of windows.
Its probably not what you wanted to hear but i bet it works a treat!
Your call...

Good Luck! :cool:

Member Avatar
cyglenn
Newbie Poster
1 post since Feb 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I am having the same problem. It all started when a user (using a Dell Optiplex 745) was having registry and system problems so I ran the Windows XP repair and during install the keyboard and mouse stopped working. I checked the settings in BIOS and USB is turned on. When we purchase our computers from Dell we always included the PS/2 serial port adapter so I was able to use a PS2 keyboard and mouse to finish the install.

I can now log in using the PS2 devices or remotely with no problems. When I go into device manager it shows that the USB keyboard and mouse had problems during install. I was able to use them on another computer and she is currently using them on the computer so I know it isn't the input devices. I also was able to use other USB devices like my USB drive in the same USB ports so it doesn't seem to be the ports. I have reinstalled all the drivers that came with the Dell computer as well as all the updates on their web site.

I have set the user up using PS2\USB adapters for her USB keyboard and mouse, but still need to find out why they will not work without the adapters. I have had this problem before, but a repartition, reformat and clean install will usually fix this, but since it is someone elses computer I don't have that option. Seems like there is a problem with Windows repair that causes problems with the USB keyboard and mouse.

Member Avatar
kiasta
Newbie Poster
1 post since Aug 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I have had this problem just now actually, what you do is use the TAB key to get to the Start menu and keep using TAB til you can select Control Panel. Than open up System > Hardware > Device Drivers (using TAB of course) and look for ANY USB Human Interface Device Drivers that you see (most likely 2 since both your mouse and keyboard are not working) and uninstall them. Than unplug the keyboard and mouse from the USB slots and plug them back in. It should re-install the drivers and work. If not well it may be some form of malware/virus messing up your drivers ability to function.

Member Avatar
joeyc6401
Newbie Poster
1 post since May 2009
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Ok guys here is the fix. If your keyboard can get you into bios set your machine to boot from cd. Pop in an xp cd and choose to install xp. After, it has you hit f8 it will bring to a screen and show the current install you have highlighted. It will ask if you want to do a clean install or type R to repair your current install. Type R to repair the install. You may need an XP key, google it and you will find it or download xp key torrent file. This will fix that usb driver issue. I was trying to find a fix all day then tried that which I usually do in way worse situations but I figured there was a good chance it would do the job and it worked like a charm.

Member Avatar
Jupiter 2
Posting Whiz
372 posts since May 2009
Reputation Points: 0 [?]
Q&As Helped to Solve: 27 [?]
Skill Endorsements: 0 [?]
 
0
 

Are you using a wireless adapter. Sometimes the line of sight may be blocked on startup. Not always a problem because my keyboard/mouse adapter is under the table.

You may need to update the drivers specific to your keyboard and mouse (not usually required for Windows XP or later.)

On occasion I have had to press my connection button again for keyboard. I actually don't use the wireless mouse. I found that the wheel didn't like to scroll in webpages. The wireless keyboard is a glory because I can just throw it anywhere at tea break time. The keyboard uses one AA battery. Perhaps the battery is flat.

Does your mouse have those extra side buttons? If yes, throw it away and get a regular usb mouse.

If this doesn't resolve the problem, that's okay because I have other solutions (I just haven't thought of them yet!).

You
This article has been dead for over three months: Start a new discussion instead
Post:
Start New Discussion
Tags Related to this Article