1,105,281 Community Members

Can't telnet to port 25

Member Avatar
troverman
Junior Poster in Training
80 posts since Feb 2008
Reputation Points: 5 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I'm running exchange 2003 on Server 2003. From my workstation's command prompt, if I enter "telnet (myserver.domain.local) 25" the screen hangs for a second and then reverts back to the original prompt screen. I can't even do "telnet localhost 25" from the exchange server itself.

Now keep in mind, everyone's e-mail is working (we use Outlook 2003-2010) and there are no issues with this. However, I need a 3rd-party program to connect to my exchange server and send e-mail for paperless invoicing.

When setting up that program, the connection never can be made and the error is simply that the server could not connect. I suspect it can't connect for the same reason I can't telnet to port 25! This program is also trying to send SMTP over 25.

Any help is appreciated!

Member Avatar
swifttech
Light Poster
27 posts since Jan 2012
Reputation Points: 0 [?]
Q&As Helped to Solve: 4 [?]
Skill Endorsements: 0 [?]
 
0
 

you can setup a email connector in exchange system manager. then specify the ip address of the system with the 3rd party app as trusted. i suspect the issue might be related to relaying mail. we've had to do this a lot for 3rd party apps, scanners that email out directly, and that type of thing.

Member Avatar
troverman
Junior Poster in Training
80 posts since Feb 2008
Reputation Points: 5 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Do I set the IP address of the server with the app installed in the "forward all mail through this connector to the following smart hosts" box?

Member Avatar
swifttech
Light Poster
27 posts since Jan 2012
Reputation Points: 0 [?]
Q&As Helped to Solve: 4 [?]
Skill Endorsements: 0 [?]
 
0
 

no , use dns to route to each address space on this connector. was there already another smtp connector there or is this the first one ?

Member Avatar
troverman
Junior Poster in Training
80 posts since Feb 2008
Reputation Points: 5 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

This is the only connector. I guess Exchange 2003 can handle most things on its own.

Member Avatar
troverman
Junior Poster in Training
80 posts since Feb 2008
Reputation Points: 5 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Where do I add the IP address in brackets?

Member Avatar
swifttech
Light Poster
27 posts since Jan 2012
Reputation Points: 0 [?]
Q&As Helped to Solve: 4 [?]
Skill Endorsements: 0 [?]
 
0
 

actually just add the smtp connector , don't add the ip address for the machine in this area, its not needed. in 2007 and 2010 you have to add it in the connector but not 2003. you probably couldn't telnet to 25 because there werent any smtp connectors.

does your 3rd party app have a section for username and password to smtp server? unless you have your server configured for anon access (if it is it shouldn't be) it will need those credentials.

Member Avatar
troverman
Junior Poster in Training
80 posts since Feb 2008
Reputation Points: 5 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Yeah, it does have a place for credentials. I'll try just adding the plain old connector.

Thanks

Member Avatar
swifttech
Light Poster
27 posts since Jan 2012
Reputation Points: 0 [?]
Q&As Helped to Solve: 4 [?]
Skill Endorsements: 0 [?]
 
0
 

yez that should do it. just with the credentials watch the syntax as well. i know some apps want you to do domain\user some domainfqdn\user some user@domainfqdn.

as well once you get your smtp connector going check the services.msc concole and make sure the service is started. sometimes its set to disabled or manual if there isn't a connector setup. this should be set to automatic using local system logon.

Member Avatar
troverman
Junior Poster in Training
80 posts since Feb 2008
Reputation Points: 5 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

So far its not working; I can't telnet to 25 still. I did restart routing engine and SMTP service first. Is there a specific connector service? I'll check

Member Avatar
troverman
Junior Poster in Training
80 posts since Feb 2008
Reputation Points: 5 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I did notice the telnet service was disabled on my exchange server. But, enabling and starting it did not allow me to telnet to port 25 anyway.

I think if I can't telnet to port 25 then there's no point in trying different logon credentials in the 3rd-party program. There has got to be some reason I can't telnet to it! I'm trying from a workstation on the same network as the exchange server; I've tried from other workstations on this network as well...same result.

Member Avatar
swifttech
Light Poster
27 posts since Jan 2012
Reputation Points: 0 [?]
Q&As Helped to Solve: 4 [?]
Skill Endorsements: 0 [?]
 
0
 

try telnet from the exchange server itself . like 127.0.0.1 25 . see if that works. do you have any software or windows firewalls turned on? if you want we could do a quick join.me and i can take a look.

Member Avatar
troverman
Junior Poster in Training
80 posts since Feb 2008
Reputation Points: 5 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

swifttech,

I can't even telnet from the exchange server itself. how do you use join me? is it like teamviewer?

Member Avatar
swifttech
Light Poster
27 posts since Jan 2012
Reputation Points: 0 [?]
Q&As Helped to Solve: 4 [?]
Skill Endorsements: 0 [?]
 
0
 

just go to http://join.me > click share > and give me the 9 digit number. once i connect you'll see me and i'll click to request control , then you click yes :)

Member Avatar
troverman
Junior Poster in Training
80 posts since Feb 2008
Reputation Points: 5 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 
Member Avatar
swifttech
Light Poster
27 posts since Jan 2012
Reputation Points: 0 [?]
Q&As Helped to Solve: 4 [?]
Skill Endorsements: 0 [?]
 
0
 

I was able to connect remotely and fix this for troverman. the issue was settings on the virtual smtp adapter. basically we needed to added the local subnet of pcs that are allowed communication and that fixed it! troverman please mark this as solved when you can. glad i could help with this.

Member Avatar
skilly
Posting Whiz in Training
270 posts since Mar 2010
Reputation Points: 23 [?]
Q&As Helped to Solve: 22 [?]
Skill Endorsements: 0 [?]
 
0
 

hmmm....i would also like to add telnet is usually port 23.SMTP is port 25.
i guess this information was sorted out in Exchange.(since it was a LAN issue)?

Question Answered as of 2 Years Ago by swifttech and skilly
Member Avatar
troverman
Junior Poster in Training
80 posts since Feb 2008
Reputation Points: 5 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Swifttech was great...logged on remotely and was willing to give up a significant amount of time in figuring this out for us. Successfully telneted to port 25!

Thanks!

chris_vanzyl
Newbie Poster
2 posts since Jul 2012
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
Unverified Member
 
0
 

virtual smtp adapte

Hi i have allmost a simliar problem we have mails on linux server and our exchangen 2010 download from linux box it work perfect!! but now it give error connection is forcefully rejected named.local:25 just a sample we use 3rd party app to forward from linux server to exchange 2010

chris_vanzyl
Newbie Poster
2 posts since Jul 2012
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
Unverified Member
 
0
 

Hi i have allmost a simliar problem we have mails on linux server and our exchangen 2010 download from linux box it work perfect!! but now it give error connection is forcefully rejected named.local:25 just a sample we use 3rd party app to forward from linux server to exchange 2010

You
This question has already been solved: Start a new discussion instead
Post:
Start New Discussion
Tags Related to this Article