1,105,456 Community Members

Xcopy got access denied error even full control rights

Member Avatar
tembel
Newbie Poster
1 post since Feb 2013
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Hi,

I installed Windows 8. I have write a personal script (.bat file) which worked with Windows 7 perfect. The problem on Windows 8 is:

My script executes this command:

xcopy "D:\X" "D:\E" /S /E /I /Q /H /K /O /X

xcopy is Windows's copy command.
"D:\X" is source directory
"D:\E" is destination direcotory
/S /E /I /Q /H /K /O /X are other parameters.

I got "access denied" error.

I check the properties of the directories "D:\X" and "D:\E". On the "security" tab of properties, "Authenticaed Users", "SYSTEM", "Administrators" ve "Users (computerName/Users)" all got "Full control" enabled.

I got "access denied" error even when I log on as admin. The .bat file works just when I run it as administator.

But all other users need to run this .bat file without password. It just executes something simple. Copy a file to another directory.

I will be happy if you can help me.

Thanks in advance..

Member Avatar
gerbil
Industrious Poster
4,624 posts since May 2005
Reputation Points: 190 [?]
Q&As Helped to Solve: 338 [?]
Skill Endorsements: 5 [?]
 
0
 

.

You
This article has been dead for over three months: Start a new discussion instead
Post:
Start New Discussion
View similar articles that have also been tagged: