1.11M Members

Vista's System Restore Points are set to delete after 136 years !

 
0
 

In Vista, SystemRestore is set to delete restore points after roughly 136years ... yeah, let that sink...

Normally Windows uses up to 15 percent of a drive’s available space to save restore points. In XP, the option to change this figure was configurable from the System Restore tab of the System Properties dialog box. But sadly this option is no longer offered in Vista.

But you can do so as follows :
Open regedit and go to
HKLM\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\
SystemRestore\Cfg Double-click the DiskPercent.
The default is f (in hexadecimal) which is 15 in decimal. For making it say 10% type 'a'

Now again, how frequently you'd like to have your SystemRestore points auto-created can also b configured as follows :
Open regedit and go to
HKLM\SOFTWARE\Microsoft\WindowsNT\CurrentVersion
\SystemRestore

You can change the value RPGlobalInterval from its default setting of 86,400 seconds (24 hours) to, say, 43200 (a8c0) if u want it created every 12 hrs.

As and how your new restore points get created, the older ones get deleted due to the availble space contstraint.

Otherwise by default, in Vista, SystemRestore is set to delete restore points after roughly 4,294,967,295 seconds or 136 years, which was a mere 90 days in XP ! The idea apparantly, is to delete them only when absolutely necessary due to space constraint!!! But err...136 years !!!

But unless u want ur grand-children to see ur restore points :icon_lol: you can change this interval too. Change the value of RPLifeInterval in the same key; a setting of 7,776,000 seconds (or 76a700 in hexadecimal) is equivalent to 90 days.

To create System Restore Points on the fly, try System Restore Point Creator. Using this utility, you can create System Restore Points in One click. Works on Vista ! To change the frequency of the System Restore Points formation, without using the Registry Editor, you can download CSRF Utility.

 
0
 

I need some help..I joined a domain and since it has locked or disabled the local user account (administrator has been disabled) I cannot log onto that pc.. Any ideas on what to do?
I upgraded from vista home...should have stayed with xp!

Thanks for any replies!!

You
This article has been dead for over six months: Start a new discussion instead
Post:
Start New Discussion
Tags Related to this Article