1.11M Members

Cannot Share External Hard Drive on Windows Network

 
0
 

I know this question has been posed before, but I haven't seen a solution yet. I have a home network connected via a 2Wire wireless router. I have a desktop PC running XP Home, a laptop runing XP Home and a laptop running Vista Home Premium. I have a Western Digitial external, USB attached, 500GB hard drive connected to the desktop. I use this for backups primarily, but want to use it as a network share.

I know the workgroup is working properly as I can see all computers and the external hard drive from all computers on the network. I have shared the hard drive and also tried just sharing a folder on the hard drive. I have tested this with and without my Norton firewalls activated. In all cases I can see the drive/folder, but cannot access it. I always get a message saying I may not have permissions to access it followed by a message about there not being enough storage to process the command. I consider the latter to be extraneous.

On the other hand if I share the dekstop internal C drive I can access that just fine from all computers. I can also access the XP shared docs folder. So it doesn't appear to be a network or firewall issue. What is the problem?

If I try to circumvent the whole problem by connecting a network attached storage device, will I have the same problem? I have been searching for answers for two or three weeks and I have never found an answer. Can anyone help?

 
0
 

If I try to circumvent the whole problem by connecting a network attached storage device, will I have the same problem? I have been searching for answers for two or three weeks and I have never found an answer. Can anyone help?

No you will not have the same problem with a NAS because it is a stand alone unit with its own network parameters. Therefore, the problems that you are having are probably having to do with USB 2.0 and the ability to see that device correctly, will not likely be the case with a NAS. I had a similar issue on several of my workstations where they could not write to the USB drive on another computer, etc. and it was because of buffering issues and the speed of the USB 2.0 cable. the NAS unit fixed the problem.

Furthermore, have you tried using Windows Explorer and typing in the IP address of the computer that the drive is connected to? There may be a NetBIOS issue not allowing the drive to resolve correctly. This is probably not the issue, but I've seen stranger things.

Now if you do not want a NAS, this is a shoting from the hip response, how about mapping a network drive on the computer that it is shared from to the USB drive. Forget about this solution, I'm telling you I 've never had good luck with USB drives for anything other than just plain storage from the workstation itself. Get a NAS, you'll be happier.

 
0
 

Hi all, I faced the same problem and solved the problem by googling around and after I this page: http://support.microsoft.com/default.aspx?scid=kb;en-us;177078
Follow the below instruction and restart computer.
1. Click Start, and then click Run.
2. Type regedit, and then click OK.
3. Navigate to the following key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters
4. In the right pane, double-click the IRPStackSize value.
NOTE: If the IRPStackSize value does not already exist, use the following procedure to create it:
a) In the Parameters folder of the registry, right-click the right pane.
b) Point to New, and then click DWord Value.
c) Type IRPStackSize.
IMPORTANT: Type "IRPStackSize" exactly as it is displayed because the value name is case-sensitive.
5. Change the Base to decimal.
6. In the Value Data box, type a value that is larger than the value that is listed.
If you created the IRPStackSize value using the procedure described in step 4, the default value is 15. It is recommended that you increase the value by 3. Therefore, if the previous value was 11, type 14, and then click OK.
7. Close the Registry Editor.
8. Restart the computer.

Actually for me the solution worked only after changed the decimal value to 21.
good luck guys.

You
This article has been dead for over six months: Start a new discussion instead
Post:
Start New Discussion
Tags Related to this Article