1,105,391 Community Members

XP/Vista Wireless LAN, Computers no longer see each other

Member Avatar
Jonnie_Cellmate
Newbie Poster
23 posts since Sep 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Hello all. I've got a Vista laptop and an XP desktop connected to a wireless ADSL router (Comtrend). Previously, I was able to view both computers over the network, share files and play LAN games. As of this afternoon, it appears the LAN network has crapped the bed.

Both computers can still connect to the internet via the wireless router, however, they no longer see each other on the network and I'm unable to play Serious Sam 2 over the LAN anymore (bummer!).

Some things to note:
- Desktop is XP Pro running service patch 3
- Laptop is Vista Home running service patch 1
- Can ping the router from either machine
- SOMETIMES able to ping laptop from desktop and vice verse...sometimes NOT (weird?!)
- Vista machine is running Private Network (as is suggested by other resources)

Anyway, I've attempted to research solutions on the web for the past few hours, but haven't had any luck. Hope y'all can guide me through this network weirdness. Thanks in advance for any help or direction.

Cheers!

Member Avatar
aeinstein
Team Member - aka kaynine
643 posts since May 2002
Reputation Points: 79 [?]
Q&As Helped to Solve: 8 [?]
Skill Endorsements: 0 [?]
Team Colleague
 
0
 

Have you double checked to see that the home network is still setup on each machine? That they're part of the same workgroup and all?

Member Avatar
Jonnie_Cellmate
Newbie Poster
23 posts since Sep 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Have you double checked to see that the home network is still setup on each machine? That they're part of the same workgroup and all?

Hi aeinstein. I confirmed that both machines are in the same workgroup (WORKGROUP). Can you specify what to look for to ensure "the home network is still setup on each machine"? The Vista computer has Network Discovery and File Sharing options turned on in Network & Sharing Center. Not sure how to confirm on the XP computer. Are there services that I can check are running (or not running)? Both computers can see themselves when viewing network, but cannot see each other anymore.

Additional information that leads me to suspect the issue is with the XP machine: a friend brought his computer over and I was able to play a LAN game using my Vista laptop, but my XP desktop could not find the LAN game we had setup. Also tried to setup the LAN game using my XP desktop and neither my Vista machine or my friend's XP machine were able to find the game.

Thanks!

Member Avatar
aeinstein
Team Member - aka kaynine
643 posts since May 2002
Reputation Points: 79 [?]
Q&As Helped to Solve: 8 [?]
Skill Endorsements: 0 [?]
Team Colleague
 
0
 

It sounds like the home network is setup, since both machines are in the same named workgroup. Let's check to see if there's anything blatantly awry with your configuration on the XP machine. Please pull up a console window (click Start, then Run, input "cmd" & hit enter), type in "ipconfig/all" and hit enter. Then left click on the little "C:\" icon in the upper left hand corner of the window, click Edit and then Select All. With everything selected do a ctrl-c to copy everything. With that in the clipboard go ahead and open up some text file, such as Notepad, and click into the body of the document and do a ctrl-v to paste the contents of the clipboard into this document. This is just a holder in case there's a mess up in posting the info here. When you post that same info here please remember to use the code tags. ttyl :)

PS: It wouldn't hurt to do the same thing with the Vista machine, but I've only had a Vista machine for a few weeks a couple of years ago, so I'm not familiar with how things need to be setup on that. The basics should be the same though.

Member Avatar
Jonnie_Cellmate
Newbie Poster
23 posts since Sep 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Thanks aeinstein. I'll post both the XP and Vista ipconfig info asap. Though I'm not sure what code tags I should use. Please advise.

Member Avatar
zoellerman
Newbie Poster
1 post since Sep 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Have you tried START RUN and then typing \\network name to see if you can connect to the other machine. To find the network name of your machines click START RUN type cmd to get the command prompt and type net view

Member Avatar
zeroth
Nearly a Posting Virtuoso
1,220 posts since Mar 2005
Reputation Points: 171 [?]
Q&As Helped to Solve: 41 [?]
Skill Endorsements: 0 [?]
 
2
 

I've got a Vista laptop and an XP desktop connected to a wireless ADSL router (Comtrend). Previously, I was able to view both computers over the network, share files and play LAN games. Both computers can still connect to the internet via the wireless router, however, they no longer see each other on the network

Guys, I've had an XP computer lose connection before and drive me crazy. Here's something to try. Goto Start, Run, and enter regedit. Being VERY careful about changing anything, go down thru the hierarchy HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/Lsa

There's an entry here named restrictanonymous - each time I've had a problem with an XP machine losing connection with the network, I've found this key set as value 1. It should be set at 0 (zero). When I've set it back, it instantly restores communication.

Worth trying. Be aware that this solution will grant access to any shared files on the network. If yours is a home network where you don't care who can see shared files, good enough. Interestingly, I have come to believe this key is set to 1 by software like Norton's when it wants to restrict access...therefore, any new computers that I purchase, I set up without Norton's and immediately get the Norton's removal tool and get rid of it forever...I hope.

zeroth

Member Avatar
LabASSistant
Junior Poster
130 posts since Sep 2008
Reputation Points: 32 [?]
Q&As Helped to Solve: 6 [?]
Skill Endorsements: 0 [?]
 
3
 

that works!

Member Avatar
ici
Light Poster
29 posts since Sep 2008
Reputation Points: 10 [?]
Q&As Helped to Solve: 2 [?]
Skill Endorsements: 0 [?]
 
3
 

thanks very much for that elegant solution, I have been having this problem for ages and you just solved it!!

Member Avatar
Catalana
Posting Whiz in Training
214 posts since Mar 2005
Reputation Points: 31 [?]
Q&As Helped to Solve: 5 [?]
Skill Endorsements: 0 [?]
 
1
 

Goto Start, Run, and enter regedit. Being VERY careful about changing anything

that's an important warning!!

Member Avatar
Jonnie_Cellmate
Newbie Poster
23 posts since Sep 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Guys, I've had an XP computer lose connection before and drive me crazy. Here's something to try. Goto Start, Run, and enter regedit. Being VERY careful about changing anything, go down thru the hierarchy HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/Lsa

There's an entry here named restrictanonymous - each time I've had a problem with an XP machine losing connection with the network, I've found this key set as value 1. It should be set at 0 (zero). When I've set it back, it instantly restores communication.

zeroth

Ok, I set the restrictanonymous value (which was set to 1) on my XP machine to 0 but still no luck.

Then I started poking around the Network and Sharing Center on my Vista laptop and now I feel the problem could lay there: it appears that the computer (Vista) is trying to connect to another network, possibly a neighbor's wireless router. In the pictures at the top of Network and Sharing Center, the network link between my computer and "Internet" is showing as WLAN_AD (my wireless network) then switches to "Identifying...", then "Multiple Networks". This keeps changing over and over, appearing to try to resolve the network connection. Although, I'm clearly already connected to my WLAN_AD wireless network and have access to the internet!

Additionally, now when I view my network on the Vista laptop I can actually see my XP machine but I can't access it: Error code 0x80070035 "The network path was not found". And on top of that, my Vista laptop isn't seeing itself anymore. It seems like every day this goofy situation with my network changes, or gets worse...you decide!!!

Anyway, is there anyway to make Vista stop trying to identify and/or connect to the other unknown network? Or am I barking up the wrong tree? What I would really like to do is delete all my existing network settings and start over fresh...any suggestions?

Thanks to all for you replies...hopefully we can figure this mess out together.

Member Avatar
Jonnie_Cellmate
Newbie Poster
23 posts since Sep 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Ok, well it appears I'm out of luck here, I guess. Last-ditch effort...any ideas on how I can reset all my network settings to default so I can start over from scratch?

Thanks.

Member Avatar
aeinstein
Team Member - aka kaynine
643 posts since May 2002
Reputation Points: 79 [?]
Q&As Helped to Solve: 8 [?]
Skill Endorsements: 0 [?]
Team Colleague
 
0
 

Hi Jonnie_Cellmate,

Sorry I've been away for a bit, but to answer your earlier question you would place the return from the ipconfig/all command between code tags: [ then the word CODE then ] (ipconfig/all contents) [ then / then Code then ]

It will look like something like this when you do a Preview Post:

Windows IP Configuration

        Host Name . . . . . . . . . . . . : (deleted)
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Hybrid
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No
        DNS Suffix Search List. . . . . . : .

Ethernet adapter Wireless Network Connection:

        Connection-specific DNS Suffix  . : .
        Description . . . . . . . . . . . : Intel(R) PRO/Wireless 3945ABG Networ
k Connection
        Physical Address. . . . . . . . . : 00-13-02-5C-12-80
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 10.128.0.79
        Subnet Mask . . . . . . . . . . . : 255.255.0.0
        Default Gateway . . . . . . . . . : 10.128.255.254
        DHCP Server . . . . . . . . . . . : 198.41.0.4
        DNS Servers . . . . . . . . . . . : 198.41.0.4
        Lease Obtained. . . . . . . . . . : Monday, October 13, 2008 3:59:36 PM
        Lease Expires . . . . . . . . . . : Monday, October 13, 2008 4:09:36 PM

Ethernet adapter Local Area Connection:

        Media State . . . . . . . . . . . : Media disconnected
        Description . . . . . . . . . . . : Intel(R) PRO/100 VE Network Connecti
on
        Physical Address. . . . . . . . . : 00-16-D4-35-A6-6F

Please take care to delete your directory path (C:\Documents and Settings\...etc), and I also delete the hostname.

I'll post back later after I get a chance to go over what you just posted, but I'll likely ask to see that info anyway.

TTYL & GL

Member Avatar
aeinstein
Team Member - aka kaynine
643 posts since May 2002
Reputation Points: 79 [?]
Q&As Helped to Solve: 8 [?]
Skill Endorsements: 0 [?]
Team Colleague
 
0
 

With your connection to the internet disconnected, but your router still up and running, temporarily disable an software firewalls, virus scanning and any other transmission security software you're running on both machines, and then see if the can communicate as a stand alone home LAN. Remember to reactivate your software before connecting back to your ISP! And yes, please go ahead and post the ipconfig/all info too.

Member Avatar
Jonnie_Cellmate
Newbie Poster
23 posts since Sep 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

With your connection to the internet disconnected, but your router still up and running, temporarily disable an software firewalls, virus scanning and any other transmission security software you're running on both machines, and then see if the can communicate as a stand alone home LAN. Remember to reactivate your software before connecting back to your ISP! And yes, please go ahead and post the ipconfig/all info too.

Hi aeinstein. I followed your instructions quoted above and the Vista laptop and XP desktop still cannot see each other on the network. I'm able to ping both computers from one another, however, not always. For example, when I ping the XP machine from the Vista laptop the ping fails at first. It will eventually work if I ping the Vista laptop from the XP machine first, which works fine. I'm not sure if this is relevant to the situation, but it's almost as if the Vista laptop doesn't see the XP machine until the XP machine sees it first. Anyway, I'm posting ipconfig/all info for both machines below. Thanks so much for your assistance!

VISTA LAPTOP

Windows IP Configuration

   Host Name . . . . . . . . . . . . : (deleted)
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Wireless LAN adapter Wireless Network Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek 8185 Extensible 802.11b/g Wireles
s Device
   Physical Address. . . . . . . . . : 00-C0-A8-F3-84-86
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::8c01:29e1:409c:15c2%9(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.136(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1
   DNS Servers . . . . . . . . . . . : 80.58.61.250
                                       80.58.61.254
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : NVIDIA nForce Networking Controller
   Physical Address. . . . . . . . . : 00-03-25-48-CC-89
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 6:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : isatap.{F452FB05-0CC2-4AA4-95BD-CA6B7F087
D0D}
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 7:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : isatap.{F473CF67-350E-4469-B621-37B94383D
C69}
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 9:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 02-00-54-55-4E-01
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

XP DESKTOP

Windows IP Configuration

        Host Name . . . . . . . . . . . . : (deleted)
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Unknown
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

        Media State . . . . . . . . . . . : Media disconnected
        Description . . . . . . . . . . . : NVIDIA nForce Networking Controller
        Physical Address. . . . . . . . . : 00-01-29-D6-01-50

Ethernet adapter Wireless Network Connection:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : 802.11g USB Adapter
        Physical Address. . . . . . . . . : 00-03-C9-4E-F4-2A
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 192.168.1.34
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.1.1
        DHCP Server . . . . . . . . . . . : 192.168.1.1
        DNS Servers . . . . . . . . . . . : 80.58.61.250
                                            80.58.61.254
        Lease Obtained. . . . . . . . . . : Sunday, October 26, 2008 5:16:08 PM
        Lease Expires . . . . . . . . . . : Monday, October 27, 2008 5:16:08 PM
Member Avatar
jbennet
Moderator
17,127 posts since Apr 2005
Reputation Points: 1,618 [?]
Q&As Helped to Solve: 736 [?]
Skill Endorsements: 38 [?]
Team Colleague
Featured
 
0
 

Under network and sharing centre make sure the network type is set to home and that discovery is enabled

Member Avatar
Jonnie_Cellmate
Newbie Poster
23 posts since Sep 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Under network and sharing centre make sure the network type is set to home and that discovery is enabled

Network discovery is enabled and the network type is set to private (as opposed to public). I don't see anything that refers to a network type of "home".

Member Avatar
jbennet
Moderator
17,127 posts since Apr 2005
Reputation Points: 1,618 [?]
Q&As Helped to Solve: 736 [?]
Skill Endorsements: 38 [?]
Team Colleague
Featured
 
0
 

Private is fine, if you choose home/work instead of public internet when it pops up, it chooses private. There is no functional difference between home and work locations on the home editions.

Member Avatar
RLHennig
Junior Poster in Training
56 posts since Nov 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

DHCP is disabled on your notebook. That may be an issue. Try turning it on (should be an option on the settings for your wireless NIC).

Member Avatar
Jonnie_Cellmate
Newbie Poster
23 posts since Sep 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

DHCP is disabled on your notebook. That may be an issue. Try turning it on (should be an option on the settings for your wireless NIC).

Well, I enabled dhcp and still no luck. I'm so at my wits end here! I understand that a secure OS is important, but why does Microsoft have to make it so darn difficult for XP and Vista to play nice together?!!!

You
This article has been dead for over three months: Start a new discussion instead
Post:
Start New Discussion
Tags Related to this Article