1,105,409 Community Members

Need Help Connecting a Belkin Router to BT Home Hub

Member Avatar
spammyyammy
Newbie Poster
20 posts since Aug 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 1 [?]
Skill Endorsements: 0 [?]
 
0
 

Currently I have a BT Home Hub 2.0 downstairs which is connected via Ethernet upstairs to a Belkin G Plus Mimo Router. However, when I connect to the router from my pc, it cannot connect to the internet nor see the BT Home Hub.

I have changed the IP settings on the Belkin router however I can still cannot connect to the Hub. I have also tried using crossover cables, normal cables and different network cards.

The default IP for the Home Hub is: 192.168.1.254 with a subnet 255.255.255.0.
I have changed the IP to the Belkin router to: 192.168.1.253 and kept a subnet of 255.255.255.0 and turned off DHCP Server. I have then connect the two with an Ethernet cable in the router's lan ports.

Does anyone know how I can setup the Belkin so my pc can see the BT Home Hub and connect to the internet.

Thanks.

Member Avatar
rch1231
Veteran Poster
1,187 posts since Sep 2009
Reputation Points: 131 [?]
Q&As Helped to Solve: 194 [?]
Skill Endorsements: 13 [?]
 
0
 

Hello,

The problem is due to the routers being on the same subnet (i.e. 192.168.1.X) You have one of two choices:
1. Turn off the router capabilities of the Belkin and make it a switch (or gateway) and the the Home Hub handle the routing and DHCP.

2. Set the Belkin to 192.168.0.1 ( or 2.1 or 3.1 etc.)with netmask 255.255.255.0 and let it get a wan ip from the Home Hub and things will route from one subnet to the other.

Member Avatar
spammyyammy
Newbie Poster
20 posts since Aug 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 1 [?]
Skill Endorsements: 0 [?]
 
0
 

Hello,

I have tried using the Belkin by disabling the DHCP and setting the IP to 192.168.2.1 (Hub's IP is 192.168.1.254). This still wouldn't assign my computer an IP.

Im not sure how to turn off the routers capabilites - I thought this just referred to turning off the DHCP?

Member Avatar
rch1231
Veteran Poster
1,187 posts since Sep 2009
Reputation Points: 131 [?]
Q&As Helped to Solve: 194 [?]
Skill Endorsements: 13 [?]
 
1
 

Not quite.
DHCP is the service that provides systems with an IP address, Gateway and DNS if they ask for it.

A router controls a block of IP addresses and the flow in and out of the subnet to the WAN (or internet). Where a hub or switch (sometimes referred to as gateway mode on routers ) is simply a box that connects several ports together without supplying any services DHCP or Routing (Network address translation in this case). TO put the router in gateway mode you have to turn off both DHCP and routing.

It took me a while to get a handle of how network routing and subnets work and really just took somebody taking the time to explain what is going on.

You have three settings to deal with:
IP Address 192.168.1.100
Netmask 255.255.255.0
Gateway 192.168.1.254

These tell me that the computers address is 192.168.1.100. The subnetmask tells me that I can get to any IP address from 192.168.1.1 to 192.168.1.255 locally on my local network. That if I want to get to an IP outside that range (like google.com at 72.14.213.99) I have to send the traffic through the gateway which will send it along its way and add the routing information for packets to come back to me along the reverse route.

When you had your Belkin LAN and WAN ports in the same subnet it never sent the packets out the wan port because that port was supposed to be on its local subnet and was not supposed to need the gateway (WAN port) to get to it.

If you are not trying to connect computers on the home router and the Belkin together for file or printer sharing then let them both run as routers and put them on different subnets (Home on 192.168.1.X and Belkin on 192.168.2.X ) and turn DHCP ON on both of them. The home router gets an IP address for its WAN from your ISP (Internet Service Provider) and will give 192.168.1.XXX address to the computers connected to it. Plug the WAN port from the Belkin into one of the ports on the home router and the Belkin will get a 192.168.1.XXX address for its WAN port and give 192.168.2.XXX addresses to computers you connect to it and everything will flow.

IF you want file and printer sharing between then turn the belkin into a dumb switch or go but a hub for half the price.

I hope I was able to explain it so this makes sense to you it took a few re-writes. LOL If I did not do a good job explaining ask away and I will see if I can do a better job.

Member Avatar
spammyyammy
Newbie Poster
20 posts since Aug 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 1 [?]
Skill Endorsements: 0 [?]
 
0
 

Hello,

Thanks for the great explanation, it fully described the problem well.

First I tried the first solution that would not enable file sharing. I gave the Belkin it's default IP of 192.168.2.1 and kept the BT Home Hub at 192.168.1.254 - both are on a different subnet. I then made sure DHCP was enabled on both and I connected the Ethernet the WAN port and to the Hub's lan port.

When I connected to the Belkin, it only assigned me an IP being 192.168.2.X. When I checked, I could see that it was not connecting to the hub.

So I went into my Belkin Home Page to look at the settings and I noticed this:

WAN MAC address
00:11:50:FE:36:30
Connection Type
Dynamic
Subnet mask
0.0.0.0
Wan IP
0.0.0.0
Default gateway
0.0.0.0
DNS Address
0.0.0.0

If I read your previous comment correctly the gateway should be 192.168.1.254? I also believe these settings mean that the hub isnt correctly connected to the Belkin. I have checked the ports I plugged the Ethernet into on the Belkin in the "Connection to Modem" port and into a LAN on the HUB.


When I try disabling the NAT and DHCP, I have to assign an IP manually as it will still not connect to the Hub. I have tried connecting to both the WAN and the LAN port on the Belkin with no luck.

Thanks for the last reply, I appreciated the in-depth explanation

Cheers

Member Avatar
rch1231
Veteran Poster
1,187 posts since Sep 2009
Reputation Points: 131 [?]
Q&As Helped to Solve: 194 [?]
Skill Endorsements: 13 [?]
 
0
 

Release and renew the Belkin WAN port or unplug it for 30 sec and plug it back in. Based on the settings you sent it is not getting an address from the hub. If you have to try the following address:

IP 192.168.1.200
NM 255.255.255.0
GW 192.168.1.254

DNS1 192.168.1.254
DNS2 4.2.2.2

Member Avatar
spammyyammy
Newbie Poster
20 posts since Aug 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 1 [?]
Skill Endorsements: 0 [?]
 
0
 

After I changed the DNS settings the router's internet light now lights up and says it is connected on the router's settings page. However my computer can still not connect to the internet as it cannot ping the Home Hub and on the network device it says IPv4 - No Internet Access.

The Ethernet cable is connect to the WAN port on the router.

The settings that the router currently has are:
IP - 192.168.2.253
DHCP - Enabled
SubnetMask - 255.255.255.0
Wan IP - 192.168.1.100
Default Gateway - 192.168.1.254
DNS Address - 192.168.1.254
NAT - Enabled.

My pc's connection says
IP - 192.168.2.2
Subnet Mask - 255.255.255.0
Default Gateway - 192.168.2.253
DHCP Server - 192.168.2.253
DNS Servers - 192.168.1.254, 4.2.2.2


I'm pretty sure I've made a silly mistake here somewhere!

Cheers mate.

Member Avatar
rch1231
Veteran Poster
1,187 posts since Sep 2009
Reputation Points: 131 [?]
Q&As Helped to Solve: 194 [?]
Skill Endorsements: 13 [?]
 
0
 

Hello,

Sorry did not respond sooner been down with the flu...
looks correct so lets start with the basics and find the problem.

1. Check all of the cables and make sure you have a link light at both ends.
2. From your computer ping your local port to make sure it is responding correctly.

ping 192.168.2.2

3. If that works ok then try to ping the router/gateway

ping 192.168.2.253

4. If that works ping the wan port on the router

ping 192.168.1.100

and keep going till something fails.

Member Avatar
spammyyammy
Newbie Poster
20 posts since Aug 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 1 [?]
Skill Endorsements: 0 [?]
 
0
 

Hey,

No worries mate, I hope your feeling better :)

I have checked the wires and they all connected and the lights are lit.

Whilst pinging, I can ping the local port, the router, the WAN port but not the home hub, 192.168.1.254.

Cheers

Member Avatar
rch1231
Veteran Poster
1,187 posts since Sep 2009
Reputation Points: 131 [?]
Q&As Helped to Solve: 194 [?]
Skill Endorsements: 13 [?]
 
0
 

Hello,

I am feeling much better thank you for asking...

Quick question. Do you have anything plugged in to the home router or connecting to it via wireless? IF so may be an IP conflict which is why I was suggesting 192.168.1.200 as the IP for the Belkin. Normally your DHCP addresses start at .100 and go up from there for 50 or 100 addresses. If you manually set the Belkin to .100 then try changing it.

If not then the next two questions are what are the results from traceroute

traceroute 4.2.2.2

and see how far it gets from your computer. Next If I remember correctly the belkin has options in the menus for ping and traceroute or name server resolution. Can you ping the home hub from any of those?

Member Avatar
spammyyammy
Newbie Poster
20 posts since Aug 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 1 [?]
Skill Endorsements: 0 [?]
 
0
 

Ok, I changed the WAN port on the Belkin to 192.168.1.200.

I then tried trace routing the 4.2.2.2 however, it quickly finds my pc's local IP 192.168.2.2 but then it cannot find 192.168.1.200.

I do not have an option on my Belkin to ping/traceroute.

Cheers

Member Avatar
DOBBIN THE MULE
Newbie Poster
1 post since Jan 2011
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
1
 

Re: Need Help Connecting a Belkin Router to BT Home Hub.

PIGGY-BACKING NETWORK ROUTERS.

Ought your PC's network ipv4 protocol manual settings primary DNS server be set to 192.168.2.253? Same as it's default gateway and DHCP server? Then secondary DNS server 192.168.1.254 and add on the advanced page 4.2.2.2?

Or, as you are connecting through a BELKIN router, taking the clue from the IP address which I presume was assigned by DHCP to your PC by the Belkin:

PC default gateway 192.168.2.1, DHCP server 192.168.2.1, DNS primary server 192.168.2.1, secondary DNS server 192.168.1.254 and add on the advanced page 4.2.2.2.

You could also try adding these and ALL the numbers you referred to to the extra gateway and DNS server boxes in your PC's network advanced settings.

I had to work with a similar set-up, (two Netgear wireless modem routers piggy- backed on each other), in a House In Multiple Occupation for three years setting other residents' computers up to use the network wirelessly. Basically I found that if you put all the numbers into the network connections' property boxes for IPv4 MANUALLY, it works. Also each router was set to a DIFFERENT channel. The routers also had DIFFERENT SSID names but the workgroup names in each computer needed to be the same if they wanted to see each other properly and share files. Each computer's adapters all each had to have different IP addresses. We also had to add in the DNS server numbers from the primary router which I think were the ISP's server numbers in order to get Internet access and not merely connect to the routers or each other.

When restarting after downages for any reason eg power loss, ISP server or telephone network problems, everything had to be started in the proper sequence and allowed to complete it's own start up process. Controlling computer first, then the main router, then the secondary router, and then our own computers. Disconnecting and reconnecting the software wireless connection or logging off and logging back on was also sometimes helpful when other problems arose e.g those caused by the three day leases on our connections.

I had a small Windows 95 desktop computer in a room in the basement connected by ethernet cable to a powerline adapter in the room. This connected via the mains wiring to another powerline adapter. Then by a short ethernet cable to the basement router. Then from the basement router ?LAN socket via a long (I believe straight not crossover) ethernet cable up to a main router LAN socket in the ground floor office. Then wirelessly from the router in the office to a usb wireless network adapter on the wall in another room connected by a usb extension lead to my main Windows Me computer in that room on the ground floor! It worked! and I was able to transfer and back up some files from the smaller hard drive to the bigger one.

You would need to make sure that the routers were set up so that they do not conflict.

If you put ALL the relevant numbers in on a laptop's network settings, you can roam the house.

You probably WON'T see the HomeHub if you are connected wirelessly through the Belkin but you might be able to see it in a scan for wireless connections within range. I don't think this matters much as all you are really interested in is getting through the Belkin to the Internet. It's the Belkin that you need to connect to and through.

Oh, and you need to check your internet connection and firewall settings to allow the routers and your other devices access to the internet and to each others' devices if you are sharing files etc.

Or why not just get a longer ethernet cable? or powerline adapters? or modem line or phone line? Wouldn't it be cheaper and simpler? You didn't say what else you have connected to either of your routers or how you are connecting to the Belkin or what operating system you are using.

Sorry this is a bit higgledy-piggledy. It's my first post on a computer topic. :) I hope this is of some use to you. There's probably more than one way of doing this. Most of the Router providers and manufacturers have a lot of general wireless network help pages on their web sites e.g:

Netgear - Improving Wireless Range: Choosing the Right Equipment. http://kb.netgear.com/app/answers/detail/a_id/198

Netgear - Routers as an Access Point. http://kb.netgear.com/app/answers/detail/a_id/965

I expect Belkin has something useful, more pertinent to your own equipment.

DOBBIN THE MULE. Saturday 22nd January 2011.

You
This article has been dead for over three months: Start a new discussion instead
Post:
Start New Discussion
Tags Related to this Article