1,105,416 Community Members

XP Network can't share files or printer

Member Avatar
homestar_44
Newbie Poster
2 posts since Dec 2005
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I have just set up a network between my laptop with XP Home SP1 as the host and my desktop with XP Pro SP2 as the client. ICS with dial-up works but file and printer sharing do not. On the client in My Network Places when I try to view workgroup computers I get the error message "Maplestory(workgroup name) is not accessible. You might not have permission to use this network resource. Contact the administrator of this server and find out if you have access permissions. The list of servers for this workgroup is not currently available." On the host in the view workgroup computers I can see both computers and can access the hosts files, but when I try to access the clients computer I get the error message "\\Dh656g1s is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permission. The network path was not found." I only have one account on each computer and they each are the administrator. I have turned off the Windows firewall on the client but my host does not have one that I can find. I have Norton on each but have disabled those firewalls. The client has a static IP address 192.168 and the gateway is the IP address of the host. I don't know if this has anything to do with filesharing but I'll put it in. Also, I don't have the Use simple file sharing option in the My Computer>Tools>View on the client. If you need anything else please say. Any help would be much appreciated.

Member Avatar
techniner
Posting Pro
521 posts since May 2005
Reputation Points: 2 [?]
Q&As Helped to Solve: 20 [?]
Skill Endorsements: 0 [?]
 
0
 

Rather then type this all out have a look here:

http://support.microsoft.com/default.aspx?scid=kb;en-us;304040

Member Avatar
homestar_44
Newbie Poster
2 posts since Dec 2005
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

thank you techniner, but i have gone through all the microsoft helps and been through a ton of forums. i just can't find why its not working.

Member Avatar
techniner
Posting Pro
521 posts since May 2005
Reputation Points: 2 [?]
Q&As Helped to Solve: 20 [?]
Skill Endorsements: 0 [?]
 
0
 

Then it has to be permissions issue.

Member Avatar
dustyrose444
Newbie Poster
1 post since Mar 2007
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I had a similar problem. Worked on it for two weeks. Was tearing my hair out. Finally fixed it. I'm not a computer whiz but this is what seems to have done the trick.

I had the computer without the router setting wrong ...
only one computer can have server setting enabled
go to network places
view network connections
right click on the various connections go to advanced tab and make sure the computer/s without the router don't have
"allow other network users to connect throught this computer's internet connection" checked

Then I reset tcp/ip stack and winsock with the following command (go to start, run then enter the command). I did this on the computer with the router but I don't see why it would hurt anything to do it on the other computer/s if it doesn't fix the problem.

run command to enter for the winsock:
netsh winsock reset

run command to enter for the tcp stack:
netsh int ip reset c:\resetlog.txt

Now I can see each computer in the workgroup and share files and printers between them. Got all those error messages .... network path not found ... may not have permission etc. This fixed it all. Hopefully it will help others.

Member Avatar
DimaYasny
Godmode enabled
1,773 posts since Jan 2007
Reputation Points: 171 [?]
Q&As Helped to Solve: 91 [?]
Skill Endorsements: 4 [?]
Team Colleague
Featured
 
0
 

if it's a winsock problem, you should take the advice above. otherwise, simply make sure that
all computers are in the same workgroup,
all computers have the same users protected by the same passwords
to speed things up, use static LAN IPs, and enter those into the hosts file.

Member Avatar
jbennet
Moderator
17,127 posts since Apr 2005
Reputation Points: 1,618 [?]
Q&As Helped to Solve: 736 [?]
Skill Endorsements: 38 [?]
Team Colleague
Featured
 
0
 

its easier to use share level instead of user level security as XP home does not support the creation of user level shares and its client is crippled

Member Avatar
wise_guy
Newbie Poster
1 post since Oct 2007
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I have found a universal solution for those who are using two more than two pcs with xp home or xp professional or any windows OS, and are not able to share files over lan, for printer sharing on lan, i am working on another solution, which i will will post later.
For this solution to work on your lan, these are the requirements :
1)you are able to ping all the pc's/nodes successfully.
2)you are able to ping each pc/node with their computer name as well and its successfull
3)you are able to see all the computers in the VIEW WORKGROUP COMPUTERS option, in the explorer but not able to see their shares.
4) you have put all the pc's under same workgroup.

Now let me give you the best most successfull method, without installing any software and also without using windows as well. Microsoft is a good OS but not as good as DOS..hahaha.
yes DOS will come to your help at these times.
The famous NET USE command will be used to mount/connect to any share on the lan on any pc which is on the same workgroup.
First, choose any directory you want to share and give its some name for the share.I am not going into these elementary things,i hope you know it how to enable-share any file or a directory over lan,or ask your administrator.
The go to any pc and type this command:
NET USE
----------
Once you type this command you will be able to see all the computers with their names listed in this service.
Then according to this example:
NET USE h: \\smartpc\pc_h
Command successfull
------------------
I will explain this command, its pretty simple.
Here NET USE is the normal command, H: means the shared directory will have a local drive named H:, make sure you dont have H: already assigned to your pc to any peripheral or on the HDD, \\smartpc means the computer name which was actually on my lan, and \\smartpc\pc_h where pc_h is for the H: drive partition on my other pc, i acutally shared the hole drive on that pc.
After this, you can go to My Computer on the pc where you executed the NET USE command, you will be surprised to see a new icon which will show the pc name and the shared resource, and use it just like any other local folder.
No more explanations, try other stuff on your own.
I own a website call www.bookprofit.com and currently a technical analyst in stock market, earlier i was a sysadmin in Linux, now doing a fulltime business in stocks.

take care
mohit thapar
(from india)

Member Avatar
rajwebsolutions
Newbie Poster
5 posts since May 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

its easier to use share level instead of user level security as XP home does not support the creation of user level shares and its client is crippled

hello everyone
i have a big problem. my system give error "check the spelling of the name .otherwise there might be a problem with your network. to try to identity and resolve network problems.

Member Avatar
rajwebsolutions
Newbie Poster
5 posts since May 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

give me solutions.thanks in advance.

Member Avatar
rizwan_ahmad73
Newbie Poster
3 posts since Sep 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

please check your ip address 192.168.1.1 and second machine ip address will be 192.168.1.2

and workgroup name will be same on both machines

i hope your problem will be solve

you can check communication with ping command

Member Avatar
helmikuu
Newbie Poster
4 posts since Mar 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

give me solutions.thanks in advance.

try to check the workgroup or the domain name of the system, pls check this link for the solution.
http://www.pcfixed.co.cc/2010/03/cannot-share-files-on-network.html

syedzameer.r
Newbie Poster
1 post since Jun 2012
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
Unverified Member
 
0
 

Hi

I have just set up a network between two desktop computers in one computer windows 7 and other windows xp 3
i can access internet in both the systems but cant access priner and files and folders its a broadband connection i given the ip address 192.168.1.2 for windows 7 system and 192.168.1.3 for xp system whan i ping from windows 7 system i can esly ping to xp system but whan i tried from xp system im not able to do i given data and printer sharing to both the system and setup small network also please help me

thakng u

Member Avatar
JorgeM
IT Addict
6,416 posts since Dec 2011
Reputation Points: 581 [?]
Q&As Helped to Solve: 963 [?]
Skill Endorsements: 172 [?]
Moderator
Featured
Sponsor
 
0
 

hello,

First, on your next post, you may want to start a new post rather than asking a question in someone's else thread, espectially one that is inactive.

OK, so in your case, the IP settings on both comptuers are most likely correct, but you may want to double check the IP, subnet mask, and default gateway configuration (ipconfig from a command prompt on both systems).

Most likely the reason why you cannot access or ping is because of the local firewall settings on each computer. This should be your focus at the moment. Go to the control panel on each system and launch the firewall applet. Ensure that your configure the firewall settings to allow ICMP (for Ping) and File and Print Sharing.

Next, to share files and printers, you need to go to the resource on the computer, right click, properties, and share the resource.

You
This article has been dead for over three months: Start a new discussion instead
Post:
Start New Discussion
Tags Related to this Article