1.11M Members

PXE Boot Linux

 
0
 

Ok, im trying to PXE boot a thin client under Linux. Ive been using the following HOWTO:

tftpd cannot do PXE installs due to the lack of the tsize option, so we use tftpd-hpa instead:

sudo apt-get install dnsmasq tftpd-hpa tftp-hpa openbsd-inetd xinetd bootp dhcp3-server

sudo mkdir /var/lib/tftpboot 
cd /var/lib/tftpboot 
sudo wget http://archive.ubuntu.com/ubuntu/dists/natty/main/installer-i386/current/images/netboot/netboot.tar.gz
sudo tar -xvzf netboot.tar.gz -C /var/lib/tftpboot/
sudo chown -R nobody:nogroup /var/lib/tftpboot

In /etc/dnsmasq.conf, add the following (replace values as needed): 

dhcp-range=lower,upper,12h
enable-tftp
tftp-root=/var/lib/tftpboot
dhcp-boot=pxelinux.0,servername,serverip
dhcp-option=3,gatewayip
dhcp-option=6,dnsserverip

In /etc/bootptab, add the following (replace values as needed): 

client:\
ha="macaddress":\
ip=clientip:\
gw=gatewayip:\
sm=subnetmask:\
td=/var/lib/tftpboot: hd=/: bf=pxelinux.0

In /etc/default/tftpd-hpa, add the following:

RUN_DAEMON="yes"
OPTIONS="-l -s /var/lib/tftpboot"

Add the following to /etc/xinetd.d/tftp (replace values as needed):

 service tftp
 {
 disable = no
 socket_type = dgram
 wait = yes
 user = root
 server = /usr/sbin/in.tftpd
 server_args = -v -s /var/lib/tftpboot
 only_from = networkip
 interface = serverip
 }

Reboot the server.

BUT IT DOESNT WORK!

Anyone got a better one?

 
0
 

Ill give that a shot, cheers!

 
0
 

Gave up setting it myself and installed the LTSP Server role using the Ubuntu Alternate CD. Worked out of the box.

Not quite what I wanted though. I wanted it doing the processing on the client side still (fatter client) as opposed to VDI, but will do for now....

Just needed to get a number of older machines up to use as web kiosks for a pet project.

Isn't it about time forums rewarded their contributors?

Earn rewards points for helping others. Gain kudos. Cash out. Get better answers yourself.

It's as simple as contributing editorial or replying to discussions labeled or OP Kudos

You
This article has been dead for over six months: Start a new discussion instead
Post:
Start New Discussion
View similar articles that have also been tagged: