1.11M Members

Sound Blaster Live 5.1 ( VISTA )

 
1
 

I just upgraded to vista and now my sound card needs driver but creative labs dont support the card anymore. does anyone know how or what i can do to make it work for vista?:@ thx for ur time in advance

 
0
 

should have waited.

 
0
 

lol....i got tired of waiting, but its on a seperate drive. i still have my original os on my default drive. the problems we are having is the same as when we all concerted to xp way back when, that is why i did a clean install on a seperate drive.

 
0
 

Without knowing the specific board that you are referring to I can only suggest that you google and see if anyone offers newer drivers. Often there will be someone with alternative drivers.

 
0
 

ty 4 the info.. nothing like a real response.

 
0
 

heres your drivers, vista is there. Enjoy

http://us.creative.com/support/downloads/welcome.asp?bEOSLAgree=yes&action=next&sOSName=&region=1&MainCategory=1&Product_Name=Live%21+5%2E1&Product_ID=50&modelnumber=

thx for the effort, but they dont have any supporting drivers for vista. they dont support this device anymore was hoping some one would've rewrote a driver.


thanks for trying

 
0
 

Hi, I had the same problem, couldn't find any vista drivers for my sound blaster 5.1 anywhere on the creative website. just when this was starting to get frustrating I noticed that one of the 13 updates that vista had automatically downloaded was a the driver for my sound blaster 5.1!!, so my advice would be to download all the microsoft updates for vista and you should be good to go. It's worth a shot it worked for me!!.

 
0
 

if microsoft offers the drive now it should work. but i have now move on to a different sound card. thx for the info.

 
0
 

Unfortunately I had the same problem. I have Sound Blaster 5.1 sound card. I bought the pc just 2 weeks ago and now the site says Creative no longer supports it. You can download a driver from Microsoft's site, but it supports only stereo. Not 5.1 channel!

 
1
 

i have the solution
simply use your xp driver for vista
to do this right click on driver's setup go properties-> compatibility
and check the box Run this program in compatibility mode for Windows Xp service Pack 2
then click ok
now you are able to install it your creative sound card on vista
install it and enjoy
for any problem
mail me at
punjabi_vj@yahoo.com

 
0
 

Sorry Faisal, that didnt work for me...It was one of the things I'd already tried out. It does install the XP driver under vista, but I wasnt able to get 5.1 audio..the output came as only 2.1.

Finally after getting a reply from Creative that development of the particular driver wasnt on the anvil anytime soon, I returned the 5.1 card, and got an Audigy 7.1...It does send 5.1 output to my 5.1 speakers.... ;)

Thanks for posting anyway!

i have the solution
simply use your xp driver for vista
to do this right click on driver's setup go properties-> compatibility
and check the box Run this program in compatibility mode for Windows Xp service Pack 2
then click ok
now you are able to install it your creative sound card on vista
install it and enjoy
for any problem
mail me at
punjabi_vj@yahoo.com

 
0
 

just check your product brand website , and request them the updated driver .
definitely they will update it if the valid customer request for it

You
This article has been dead for over six months: Start a new discussion instead
Post:
Start New Discussion
Tags Related to this Article