1,105,456 Community Members

PC won't turn on

Member Avatar
hiho33106
Newbie Poster
3 posts since Aug 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I have a Dell Dimension E521 that won't turn on when the power button is pushed. There is an amber light that is on the AUX Power LED on the MOBO that is lit. I pulled the Power supply unit strip going to the MOBO and did a paperclip jumper on the green wire and ground and the PSU fan came on. Research tells me that the PSU is OK with this self diagnostic test. Plug everything back in and still nothing. Should I replace the PSU and hope that this was the problem? Money is a little tight right now with the economy,but need to get PC working for the kids and school starting in less than a month. Any advise would greatly appreciated at this point. thanks

Member Avatar
finito
Nearly a Posting Virtuoso
1,264 posts since May 2010
Reputation Points: 46 [?]
Q&As Helped to Solve: 140 [?]
Skill Endorsements: 0 [?]
 
0
 

Welcome to the forums. NTMU.

I need you to strip the machine down to just the Processor and Motherboard.

Take out the RAM, PCI cards, Keyboard, mouse, USB peripherals, etc

Anything that isn't the Motherboard, Processor, or the PSU goes.

Once you are down to the Bare minimum, Boot your machine you want to hear a few beeps 5 or 6 evenly spaced tones.

If you hear this congratulations your machine is alive.

Now switch off and add RAM, to the machine and boot again. Now you want to hear one single beep.

Please post results be as descriptive as possible. Tell me the beeps and sounds you hear or smells.

Even if you get this far your PSU may still be faulty but we will get to that later.

Member Avatar
hiho33106
Newbie Poster
3 posts since Aug 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

thanks finito. I will try tonight when I get home and let you know the results

Member Avatar
hiho33106
Newbie Poster
3 posts since Aug 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

well finito stripped machine down to bare essentials, hit on/off switch and still nothing.... I think it's dead! Anything else that I can try or suggestions would be appreciated. Thanks

Member Avatar
PaulDest
Newbie Poster
8 posts since Aug 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Power switch unit or motherboard - those two are weaker ones.
Can you borrow a psu from a friend to check your computer?

Member Avatar
finito
Nearly a Posting Virtuoso
1,264 posts since May 2010
Reputation Points: 46 [?]
Q&As Helped to Solve: 140 [?]
Skill Endorsements: 0 [?]
 
0
 

As PaulDest said, Either try and change the PSU or Try this one in another machine to see if the PSU is fine.

You
This article has been dead for over three months: Start a new discussion instead
Post:
Start New Discussion
View similar articles that have also been tagged: