1,105,340 Community Members

computer will not boot with external hard drive connected.

Member Avatar
twolf1621
Newbie Poster
3 posts since Feb 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I just purchased a Seagate 750 gig external hard drive. My computer (running Windows XP home edition) will not boot past the screen where the devices are recognized as long as the Seagate is physically connected. I have to disconnect either the power cord or USB cord to the Seagate and reboot. Once the computer has booted, I can reconnect the Seagate cable and everything works great once the system recognizes the external drive. PLEASE...any suggestions?

Member Avatar
techniner
Posting Pro
521 posts since May 2005
Reputation Points: 2 [?]
Q&As Helped to Solve: 20 [?]
Skill Endorsements: 0 [?]
 
0
 

Boot into your BIOS and change the boot Priority.

Make sure the USB boot Device is *after* your primary hard drive.

Member Avatar
twolf1621
Newbie Poster
3 posts since Feb 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I tried entering SETUP with the external hard drive connected, but it still will not advance past recognizing the Pri Master, Sec Master & Sec Slave. The system just locks up at this screen.

Member Avatar
dmcaarlson
Junior Poster
135 posts since Jun 2007
Reputation Points: 0 [?]
Q&As Helped to Solve: 17 [?]
Skill Endorsements: 0 [?]
 
0
 

Disconnect the external drive and reboot. Enter the BIOS setup and navigate to the setup priority (or setup order) screen.

While some BIOS's will tell the difference, some versions think a USB drive is a CD and will attempt to boot from it if CD is first in boot order (sometimes a manufacturer will leave it first after the machine setup). Make sure the hard drive is first in boot order, save, then try again.

Member Avatar
Cooke14
Newbie Poster
1 post since Nov 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I have the same problem mine is a lacie 750gb and I have I changed the boot order so that everything else would boot before the external would boot but still it won't go past the inital gateway screen( computer is a gateway)

Member Avatar
saykomatrixx
Newbie Poster
8 posts since Nov 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 2 [?]
Skill Endorsements: 0 [?]
 
0
 

Also at BIOS enable Usb Legacy Support.

Member Avatar
laz305
Newbie Poster
1 post since Jun 2009
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I am all of a sudden having this problem on XP with my WD it has been working fine for months and now PC won't boot up with it connected. Any ideas plz?

Member Avatar
dmcaarlson
Junior Poster
135 posts since Jun 2007
Reputation Points: 0 [?]
Q&As Helped to Solve: 17 [?]
Skill Endorsements: 0 [?]
 
0
 

I am all of a sudden having this problem on XP with my WD it has been working fine for months and now PC won't boot up with it connected. Any ideas plz?

This isn't an answer so much as an observation -- recently I've seen a number of XP systems with 5+ year old hardware have trouble booting with USB devices such as printers / scanners / external hard drives powered up. In the case of printers, we are suspecting issues with power negotiation on older USB ports with new devices. These all seemed to come about after Vista drivers were issued for these devices, which makes me wonder about the testing on all versions of XP (perhaps only one version rather than all). I would like to think an update to the driver for a WD device wouldn't have that issue, but it is possible. Might be worth checking to see if WD has a driver update in response to a MS patch, as well -- this can cause similar symptoms.

Member Avatar
wwalter82
Newbie Poster
2 posts since Jun 2009
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

If this is a new HD purchased directly from retailer in the case already, i wouldn't recommend opening yourself (opening can void the warranty) unless you know what you are doing, but if the BIOS setting don't work, the HD itself has a jumper on it to set for master, slave drive, or cable select. You may be able to change this so it is set to slave and not being recognized as the primary drive and trying to boot windows from this drive, which it won't find not being installed on there, and will cause a blank screen, freeze or an indefinite hang in the system as the computer is looking for windows. This not being any help to those who have had theirs working before.

Member Avatar
REAL Chicken
Newbie Poster
1 post since Sep 2009
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Had the same problem, searched the Internet and found a million people with the same problem and a million helpful people and their "solutions" to the problem, of which some did just not work, and some were downright dangerous to the health of my PC. But at last I found a solution that works, and it's simple (thank you to saykomatrixx):

First (of course) you check your BIOS to see that USB-devices are below (after) internal HD:s in the boot sequence.
My BIOS did not, however, have this option, only Disk drives, HD:s, Network, and Floppy(?!), but here's the beauty:
Find (in BIOS) the "USB Legacy Support", make sure it is set to "Enabled", and voilà, it should work like a charm to start-up with the external HD:s connected and on.

I did get a small surprise during next start-up when Windows started to install drivers for my sound card, and later I had to change some settings in my sound card to get my microphone to work again, as the driver install had changed some settings there, but otherwise everything is just hunky dory.

Good luck.

PS
I don't really know what the "USB Legacy Support" is/does (perhaps a more educated member could tell us?) but as my already was in "Auto" which is a sort of semi-on (software controlled is my guess), the difference can't be that huge from before I switched it fully on.
DS

Member Avatar
CTarma
Newbie Poster
1 post since Dec 2009
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

As previously stated, the probable cause is that a partition within the external HDD is being recognized as a CD drive.

As long as CD/DVD drive is ahead of the internal HDD in the BIOS and you have an external HDD that has a CD partition, your machine will try to boot from the external HDD.

Most vendors now have a firmware update, as well as, a software update which will allow you to disable the CD partition with the external HDD.

Ref- http://www.wdc.com/wdproducts/updates/?family=wdsmartware

Good luck!

Member Avatar
mjdodd
Practically a Master Poster
635 posts since Sep 2007
Reputation Points: 27 [?]
Q&As Helped to Solve: 55 [?]
Skill Endorsements: 0 [?]
 
0
 

for info:legacy suport is an attempt by Ms ,to ensure that devices (such as printers/modems keyboard screen but not usb etc from aboiut prehistiric times) still work with modern windows etc. it is a system that tries to detect such devices andthen loads appropriate drivers ....well a good try anyway!!!
But it does not always work as is MS comme d'habitude (as usual!)
LOL
M

Member Avatar
pnkmcneil
Newbie Poster
3 posts since Apr 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I have the same problem.

Checked USB Legacy Support and found it already "Enabled".
Checked Boot Device Priority sequence and made sure to have HDD #1, CD-Rom #2, etc.
Checked Hard Disk Drives to Master, Slave, and Disabled.
Still have same problem. CPU will not boot with PnP external hard drive connected.

Tried the external hard drive on Notebook and it booted, so external drive seems OK.

Any other ideas or CMOS settings to double check?

Member Avatar
Johnsmith1
Newbie Poster
24 posts since Mar 2010
Reputation Points: -2 [?]
Q&As Helped to Solve: 2 [?]
Skill Endorsements: 0 [?]
 
0
 

Hi,Checked Hard Disk Drives to Master, Slave, and Disabled. Make sure the USB boot Device is your primary hard drive.

Member Avatar
pnkmcneil
Newbie Poster
3 posts since Apr 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Hi,Checked Hard Disk Drives to Master, Slave, and Disabled. Make sure the USB boot Device is your primary hard drive.

I want the CPU to boot up on its primary hard drive. It will only boot without the usb external hard drive disconnected. The usb external hard drive is only a slave drive to store data. When the usb external hard drive is connected, the cpu hard drive boot up freezes at the Dell splash screen. When disconnected, no problem.

Member Avatar
MikeInFL
Newbie Poster
1 post since May 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I had same problem. Nothing worked. Then I tried solution from Real Chicken:

"First (of course) you check your BIOS to see that USB-devices are below (after) internal HD:s in the boot sequence."

Works! XP boots ok with ext usb hard drives connected, and they show up ok now!

Thanks Real Chicken- you saved me a lot of trouble!

Member Avatar
computersx
Newbie Poster
7 posts since Jun 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 1 [?]
Skill Endorsements: 0 [?]
 
0
 

I unplug internal hard drive and restart again, it work!

Member Avatar
pnkmcneil
Newbie Poster
3 posts since Apr 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I unplug internal hard drive and restart again, it work!

That is what I have been doing all along. This is very inconvenient to say the least. There must be some setting in BIOS that I have missed, but I cannot see it.

Member Avatar
pip22
Newbie Poster
22 posts since Sep 2005
Reputation Points: 0 [?]
Q&As Helped to Solve: 2 [?]
Skill Endorsements: 0 [?]
 
0
 

"Find (in BIOS) the "USB Legacy Support", make sure it is set to "Enabled"

That's rather curious advice because the official fix from Seagate & Western Digital, (and the advice from most people who've fixed this problem) is to set "Legacy USB Support" to DISABLED. You're saying exactly the opposite!

Member Avatar
mjdodd
Practically a Master Poster
635 posts since Sep 2007
Reputation Points: 27 [?]
Q&As Helped to Solve: 55 [?]
Skill Endorsements: 0 [?]
 
0
 

It seems to me that there is some confusion although perhaps this is now solved. For any computer to bootup it must be able to find a 'boot' system. Normally this is on the primary hard drive and on the first partition (unless deliberatley put else where! This tells the OS where ,to find the required operating system on the hard drive. So the bios has to refer to the first boot device as the primary one!
Now if the bios has other options like booting from USB external etc as the machine starts it loooks for ,all sorts of devices such as keyboards hard drives USB etc. if it finds a USB with a boot systm on it and also finds a hard drive with a boot systelmm on it I ask (but do not need an answer!) which is it going to boot from. My experience with booting from USB is that disabling the hard diriveboot lets the USB do it and conversely enablinjg th hard drive and not adding the USB until after bootingis actually more usable!

The other alternative and perhaps a better one is to add a system like partition manager with its OWN boot menu choice. Then you can use either

Hope this clears the air.
m

You
This article has been dead for over three months: Start a new discussion instead
Post:
Start New Discussion
Tags Related to this Article