1,105,286 Community Members

USB ports don't work

Member Avatar
kranzberry
Newbie Poster
1 post since Apr 2006
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
-1
 

NOTHING I have hooked up to a USB port works, the computer doesn't recognize anything in a USB port. The devices work when plugged into a different computer, so it's not the peripherals. The optical mouse, for example, has power ( the light comes on), but nothing moves. Any suggestions?

Member Avatar
TKS
Posting Pro in Training
474 posts since Jan 2004
Reputation Points: 74 [?]
Q&As Helped to Solve: 18 [?]
Skill Endorsements: 0 [?]
 
0
 

Check the BIOS to see if USB connections are enabled there. If not, enable them and you should be set. If you have problems getting into BIOS, post the model number and brand of your motherboard here...or if you have a Dell/HP/Gateway etc, post the model number here and I'll help you get into BIOS...

Member Avatar
wezza91
Newbie Poster
2 posts since Apr 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Hi, ive got the exact same problem as Kranzberry. this also means that there is no way to use either my mouse or keyboard.
I have a Dell Dimension 9150
it would be great for any help thx

Member Avatar
jbennet
Moderator
17,127 posts since Apr 2005
Reputation Points: 1,618 [?]
Q&As Helped to Solve: 736 [?]
Skill Endorsements: 38 [?]
Team Colleague
Featured
 
0
 

is it vista?

usb mice are screwed up in vista

Member Avatar
wezza91
Newbie Poster
2 posts since Apr 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

no i running on xp

ohyeah
Light Poster
48 posts since Aug 2005
Reputation Points: 0 [?]
Q&As Helped to Solve: 2 [?]
Skill Endorsements: 0 [?]
Unverified Member
 
0
 

my usb ports dont work there enabled in bios I checked I dont know what to do its driving me crazy

Member Avatar
jbennet
Moderator
17,127 posts since Apr 2005
Reputation Points: 1,618 [?]
Q&As Helped to Solve: 736 [?]
Skill Endorsements: 38 [?]
Team Colleague
Featured
 
0
 

maybe the usb ports hardware is at fault.

Member Avatar
rmusumhi
Newbie Poster
1 post since Jul 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I wanted to set the USB port but I can't select the LegacyUSB Suport or USB Mass Storage. Any help.

Member Avatar
jds3220
Newbie Poster
1 post since Oct 2007
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

my mice suddenly stop response in the middel of work in vista .

Member Avatar
vizard_ichigo
Newbie Poster
9 posts since Aug 2008
Reputation Points: 1 [?]
Q&As Helped to Solve: 1 [?]
Skill Endorsements: 0 [?]
 
0
 

try checking the power option settings of your computer? had a similar problem before on my laptop computer and I tried a lot of things but nothing worked until I called support, the tech had me check my computer's power settings and found out that it is set to turn off or suspend the power on my USB ports if left for sometime, similar to what it does to the monitor I think, he had me change a few things and it worked well after that. Check if you have the same option in your computer, I don't recall the steps and the computer I have right now does not permit to go to control panel, if you want step by step instructions, try calling this number 1-877-7878749, I forgot their name but they might be of help.

Member Avatar
ramannanda9
Newbie Poster
2 posts since Aug 2007
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

try this
1. go to bios and enable the usb device
2. if that does not work force update the escd in bios by changing the bios interrupt assignment from auto to manual it then reassigns the interrupt port numbers.
3. also you may need to refer to your motherboard manual and change the usb power jumpers on your motherboard.
4. try diabling/ uninstalling the usb device driver by going to the device manager and
then reinstall the device.

thats about it if you still cant solve the problem goto ramannanda9dotblogspotdotdotcom
i have given the solution to that problem.

the dot is . :) hope this helps

Member Avatar
calwms
Newbie Poster
1 post since Aug 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Check the BIOS to see if USB connections are enabled there. If not, enable them and you should be set. If you have problems getting into BIOS, post the model number and brand of your motherboard here...or if you have a Dell/HP/Gateway etc, post the model number here and I'll help you get into BIOS...

The model number of the laptop in question is (PSAF-U-0NQ015 Toshiba satellite laptop

Member Avatar
BlackFetus
Junior Poster
104 posts since Aug 2010
Reputation Points: 2 [?]
Q&As Helped to Solve: 16 [?]
Skill Endorsements: 0 [?]
 
0
 

..hi there guyz!..try to follow this steps!..(1) try to check in BIOS settings if your USB has been enabled..or (2)try to check if you install your USB drivers in your motherboard properly..or (3) try to check your registry editor, go to RUN, type REGEDIT, follow the key names, HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\USBSTOR..in USBSTOR, if the START modifies no. 3 then your USB ports are enabled but if it is no. 4 then your USB ports are disabled, to enable it just, right click START, click MODIFY, then encode no. 4 in the VALUE DATA then OK, close REGEDIT..restart your pc..i hope it helps!..^_^..

Member Avatar
anwarma
Newbie Poster
1 post since Feb 2011
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Hello guys,

On my pc all usb ports no longer work on the hp dx5150s (slimline).

I have checked all the USB devices and they work on other PC's. I have made sure all USB ports are enabled on the BIOS.

If you know how to fix this issue, i will be more than appreciative.

Thanks!

AA

Member Avatar
cypher1
Light Poster
41 posts since Aug 2009
Reputation Points: 0 [?]
Q&As Helped to Solve: 3 [?]
Skill Endorsements: 0 [?]
 
0
 

Hi check device manager(my computer/right click manager/device manager to see if there is an exclamation marks beside the USB ports,it may be a driver problem.

Member Avatar
benmar
Posting Whiz
311 posts since Aug 2010
Reputation Points: -5 [?]
Q&As Helped to Solve: 41 [?]
Skill Endorsements: 0 [?]
 
-1
 

that case maybe your usb port is dead try update your usb port driver if not,, do a repair to your Operating system.....

29limited
Newbie Poster
1 post since Feb 2013
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
Unverified Member
 
0
 

What if I can't perform any of the above suggestions because I can't even get to the start button? My keyboard, nor my mouse work at all so I have no navigation at all. My monitor is just a black screen. When I push one of the buttons on it, the message says "analog input in power save mode. Touch any key on keyboard or move mouse to exit". Except I can't do that because the keyboard and mouse are plugges into the USB ports, which don't work.

Member Avatar
Andy456
Newbie Poster
20 posts since Feb 2013
Reputation Points: 0 [?]
Q&As Helped to Solve: 1 [?]
Skill Endorsements: 0 [?]
 
0
 

For this right click on the "My computer" and select the "Manage" and then a box will appear on the screen , select the "Device manager" from the list and then make the enable "Serial buss controller".

Member Avatar
Waspire
Newbie Poster
1 post since Feb 2014
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

actually i deleted the usb in the control panel and let it reinstall. worked much better after that.

Abhinav714
Newbie Poster
1 post since Feb 2014
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
Unverified Member
 
0
 

I have ASUS motherboard and all the USB ports of my CPU are dead. What to do? I tried the device manager and reinstalled the USB ports though nothing happens.

You
Post:
Start New Discussion
Tags Related to this Article