1,105,320 Community Members

BadImageFormatException error

Member Avatar
tahir_77
Newbie Poster
3 posts since Nov 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I have VS 2008 on Win 7 Professional 64bit system and database is Oracle 11g r2 installed on the same machine.

In Data Source Configuration Wizard --> New Connection
Data Source: Oracle Database (Oracle Client)
When I click Test Connection after entering Service name, username, and password I get the following error:

Attempt to load Oracle client libraries threw BadImageFormatException.
This problem will occur when running in 64 bit mode with the 32 bit Oracle client components installed.


-- I have no oracle client installed because there is no need in this case, I have the same setup on my laptop Win 7 32bit Oracle 11g r2 32bit and everything is working fine.

Please let let me know if you guys have solution for this issue.

Member Avatar
debasisdas
Posting Genius
6,542 posts since Feb 2007
Reputation Points: 580 [?]
Q&As Helped to Solve: 476 [?]
Skill Endorsements: 25 [?]
Featured
 
0
 

Is it 32 bit or 64bit Oracle 11g r2 installed on the machine ?

Member Avatar
tahir_77
Newbie Poster
3 posts since Nov 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

64bit Oracle 11g r2

Is it 32 bit or 64bit Oracle 11g r2 installed on the machine ?

Attachments error.PNG 125.06KB
You
This article has been dead for over three months: Start a new discussion instead
Post:
Start New Discussion
View similar articles that have also been tagged: