1,105,399 Community Members

Why app_offline.htm is created automatically? Whats the mystery?

Member Avatar
mania_comp
Light Poster
44 posts since Jul 2009
Reputation Points: -2 [?]
Q&As Helped to Solve: 1 [?]
Skill Endorsements: 0 [?]
 
0
 

This application is currently offline. To enable the application, remove the app_offline.htm file from the application root directory.

By removing that file, it works

but why does itgets created automatically?

Member Avatar
sknake
Senior Poster
3,957 posts since Feb 2009
Reputation Points: 1,620 [?]
Q&As Helped to Solve: 747 [?]
Skill Endorsements: 25 [?]
Featured
 
0
 

It doesn't as far as I know. Are you deploying it with your application or is something creating it?

Member Avatar
mania_comp
Light Poster
44 posts since Jul 2009
Reputation Points: -2 [?]
Q&As Helped to Solve: 1 [?]
Skill Endorsements: 0 [?]
 
0
 

I am using VS 2008. I am developing a website in it. So while creating pages and running them to test it works fine but on running my website ..sometimes ..it says
"This application is currently offline. To enable the application, remove the app_offline.htm file from the application root directory"

So when i browse my project , I see app_offline.htm page. I just delete it and all goes well then...
It happens very rarely to someone or may not happen also... its very rare.. but ya it does get created..

In your case its possible that you havnt came across such situation...but ya I have..so it puzzles me:)
so I am asking here
any help??:)

Member Avatar
daniel_b
Newbie Poster
1 post since Jan 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I get this same problem ( though using VS2010 beta 2) every now and again (twice this week) something creates the app_offline.htm file in the root dir of the site I'm working on.

Ok its easy fixed, just delete the file. However where is this file coming from, what's creating it? I know I'm not.? :S

Member Avatar
mutiarts
Newbie Poster
2 posts since Feb 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Is there any setting to disable the 'automatically create the app_offline.htm'?
what a bother...

Member Avatar
apegram
LINQ!
550 posts since Jan 2010
Reputation Points: 302 [?]
Q&As Helped to Solve: 137 [?]
Skill Endorsements: 10 [?]
Team Colleague
 
0
 

This is the first I've heard of this, but stackoverflow says it happens when you use the publish utility within Visual Studio. I have no idea if that's true or not.

http://stackoverflow.com/questions/2148125/why-does-app-offline-htm-keep-appearing-in-my-web-project

From a link off that link, there's also this blurb

"SQL Server 2005 express edition does not support multiple processes. Only single process can access database at a time. So when a database is accessed through visual studio, ASP.net runtime cannot access the database. This will result into the internal server error. To prevent this, VS 2005 places app_offline.htm file in the application's root directory. The file contain above message. This causes ASP.net to put the application in offline mode. Please note the accessing database means opening any component of the database (I.e. table, view, stored procedure etc.) into the design window. When design window is closed, VS 2005 removes app_offline.htm file making the application in onliner mode again."

http://www.codeproject.com/KB/aspnet/app_offline.aspx

So it could also be that files are getting moved to the server while a design window is open against SQL Server 2005 Express. And, who really knows, there could be multiple things that trigger the creation of that file. I've never seen it, though.

Member Avatar
mutiarts
Newbie Poster
2 posts since Feb 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

is that so?? i see it now...
so there is no way to avoid it happens then..
fyi, i have deleted it many times, n when i saw my recycle bin, there r HUNDREDS file of app_offline.htm in there! :D
btw thanks 4 da info!

Member Avatar
chennadi
Newbie Poster
1 post since Mar 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Hi Guys,
I too get the same problem. But when i restore my system it is getting created. I deleted it then i didn't get again.

Vijay Reddy Chennadi
www.chennadi.blogspot.com

Member Avatar
tarwara
Newbie Poster
15 posts since Jul 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I got the problem and tried to find on web but could not find the exact solution. It does not happen every time ! Please do rep if anybody have!

Member Avatar
somrita
Newbie Poster
10 posts since Jul 2011
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I got app_online.htm problem after deploying my website.I removed from websites folder of visual studio file.The problem got solved.:icon_smile:

Member Avatar
anaschavadi
Newbie Poster
2 posts since Oct 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

if you r usingSQL Server express edition does not support multiple processes. Only single process can access database at a time. So when a database is accessed through visual studio, ASP.net runtime cannot access the database. This will result into the internal server error. To prevent this, VS 2005 places app_offline.htm file in the application's root directory. The file contain above message. This causes ASP.net to put the application in offline mode. Please note the accessing database means opening any component of the database (I.e. table, view, stored procedure etc.) into the design window. When design window is closed, VS 2005 removes app_offline.htm file making the application in onliner mode again.

anandd
Newbie Poster
1 post since Jan 2013
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
Unverified Member
 
0
 

This application is currently offline. To enable the application, remove the app_offline.htm file from the application root directory.
pls rectify my error .. i can't find this error

You
This article has been dead for over three months: Start a new discussion instead
Post:
Start New Discussion
Tags Related to this Article