1,105,225 Community Members

Anyone tell me whats wrong with this code?

Member Avatar
Cheesecake87
Newbie Poster
11 posts since May 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Anyone tell me why this Coldfusion code aint working ?
I built the system on the Coldfusion 9 developer server locally then uploaded it to a Coldfusion 8 hosted server and I get this strange error.

Error can be seen here: http://75.126.153.165/$sitepreview/ka-radio.co.uk

Code where error is highlighed can be seen here: http://pastebin.com/gGLQmaPD

Database design can be seen here: http://imageshack.us/photo/my-images/194/databasedesign.png/

Hmm :/ is there something different about how coldfusion 9 and 8 work with times .. its not even a variable with time in it.

I also tried this code on a locally hosted railo server and it worked fine.

Member Avatar
arrgh
Posting Pro in Training
408 posts since Dec 2008
Reputation Points: 22 [?]
Q&As Helped to Solve: 50 [?]
Skill Endorsements: 0 [?]
 
0
 

its not even a variable with time in it.
...
<cfset ET = timeformat(EndTime, 'H')>

Then why are you using timeFormat on it? :) If EndTime is null, its probably returning an empty string, hence the error when you try and perform subtraction. Make sure it's a number and problem solved.

<cfset ET = "">
   <cfset thisFails = ET - 1>
You
This article has been dead for over three months: Start a new discussion instead
Post:
Start New Discussion
Tags Related to this Article