1.11M Members

Fatal error: Maximum execution time of 300 seconds exceeded in C:\xampp\phpmyadmin\li

 
0
 

I have data.sql file and there is 151262 insert statement in SQL file. but while i try to IMPORT it in MYSQL database this give me following error.


Fatal error: Maximum execution time of 300 seconds exceeded in C:\xampp\phpmyadmin\libraries\import\sql.php on line 111


Pls give some solution for this Problem.


-keval

 
0
 

I think this is the PHP timeout of phpMyAdmin. So you can either change the php.ini and increase the timeout, or import the file directly into MySQL throught the command line.

 
0
 

But i don't know how to change php.ini pls can u tell me stem for that.

 
0
 

Hello,

151262 rows are too much, they can hardly be inserted by means of insert statements and php because of too much time consuming. Instead, bulk insert should be done with MySQL LOAD DATA INFILE.

-- tesu

 
0
 

@tesuji: Does LOAD DATA INFILE support sql dumps too ?

 
0
 

I don't believe that files generated for processing with fast LOAD DATA INFILE to read them back into tables be compatible with mysqldump. However, mysqldump is able to generate complete insert-statements too. But I would never mix it.

There are many options one can set for speeding-up bulk-insert, for example delayed-insert (most important), disable-keys, no-locks.

-- tesu

You
This article has been dead for over six months: Start a new discussion instead
Post:
Start New Discussion
Tags Related to this Article