1,105,534 Community Members

XAMPP - Apache service not working!

Member Avatar
Smoking Bros
Newbie Poster
22 posts since Aug 2009
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Hello everyone! I got a series of C++ tutorials and a series of Blender tutorials and 1 tutorial on how to get free Windows Vista look on your Windows XP on YouTube.. So I thought I would so some PHP tutorials too... And as always I wanted to check if everything was working before I started doing my tutorial.. So, I downloaded XAMPP 1.7.2, and it installed successfully without any errors, and MySQL works fine, but when I hit the 'Start' button to start Apache it says "Running" in like 10 secs, and then it stops running again.. And in the short time it is running when I try to hit "Admin" is cannot open the web-browser, and Apache service stops.. And the little text field in the XAMPP Control Panel Application says:

Busy...
Apache started

When I hit the "Start" button.. So I figured that I would like to go look at the error log at:

C:/xampp/apache/logs/error.txt/

And in there when I hit the "Start" button nothing happens.. But when after like 10 secs when it stops by itself, I get this addition to the log:

[Fri Sep 18 10:45:14 2009] [notice] Digest: generating secret for digest authentication ...
[Fri Sep 18 10:45:14 2009] [notice] Digest: done
[Fri Sep 18 10:45:16 2009] [notice] Apache/2.2.12 (Win32) DAV/2 mod_ssl/2.2.12 OpenSSL/0.9.8k mod_autoindex_color PHP/5.3.0 mod_perl/2.0.4 Perl/v5.10.0 configured -- resuming normal operations
[Fri Sep 18 10:45:16 2009] [notice] Server built: Jul 22 2009 11:35:54
[Fri Sep 18 10:45:16 2009] [crit] (22)Invalid argument: Parent: Failed to create the child process.
[Fri Sep 18 10:45:16 2009] [crit] master_main: create child process failed. Exiting.
[Fri Sep 18 10:45:46 2009] [notice] Parent: Forcing termination of child process 36

PLEASE help me, as I really would like to get those PHP tutorials started!

Member Avatar
Smoking Bros
Newbie Poster
22 posts since Aug 2009
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Come on guys! I really need some help on this!!

Member Avatar
digital-ether
Nearly a Posting Virtuoso
1,264 posts since Sep 2005
Reputation Points: 399 [?]
Q&As Helped to Solve: 102 [?]
Skill Endorsements: 11 [?]
Team Colleague
 
0
 

You'll probably get better help with this posting at the xampp forum.
http://www.apachefriends.org/f/viewforum.php?f=16

This has little to do with PHP programming so it would be hard to answer your question. It is more to do with the apache server and specifically xampp.

Member Avatar
network18
Practically a Master Poster
643 posts since Sep 2009
Reputation Points: 15 [?]
Q&As Helped to Solve: 78 [?]
Skill Endorsements: 0 [?]
 
0
 

If we hav any other web server running apart from apache(installed through XAMPP in ur case) the apache wont work.
First check for any other server installed.

Member Avatar
cwarn23
Occupation: Genius
3,028 posts since Sep 2007
Reputation Points: 387 [?]
Q&As Helped to Solve: 281 [?]
Skill Endorsements: 15 [?]
Team Colleague
Featured
 
0
 

MySQL works fine, but when I hit the 'Start' button to start Apache it says "Running" in like 10 secs, and then it stops running again.. And in the short time it is running when I try to hit "Admin" is cannot open the web-browser, and Apache service stops..

I have this problem a lot with XAMPP. The usual procedures is first to press Ctrl+Alt+Delete to go into the task manager. Then end task to the process named apache.exe and httpd. After that try reopening your control panel and single click the apache load button. Then wait for 20 seconds then if not loaded double click on the load apache button instead of single click. Normally that works for me.

Member Avatar
EtanaChesna
Newbie Poster
1 post since Sep 2009
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I had the same issue but resolved it.

I had a previous version of Perl installed and had Environment Variables set. Apache crashed because the path to perl was using my old paths. I removed the paths through the System Properties Advanced Tab under Environment variables.

This may not be your issue but I thought I'd share my resolution.

The following link had some helpful information as well:

http://www.netshinesoftware.com/component/option,com_myblog/Itemid,65/show,Apache-wont-start-on-XAMPP.html/

Member Avatar
digital-ether
Nearly a Posting Virtuoso
1,264 posts since Sep 2005
Reputation Points: 399 [?]
Q&As Helped to Solve: 102 [?]
Skill Endorsements: 11 [?]
Team Colleague
 
0
 

Something else to watch out for is Skype. If you have skype turned on, it may be taking up port 80 so you won't be able to start Apache.

Member Avatar
dougbarrett
Newbie Poster
8 posts since Sep 2009
Reputation Points: 0 [?]
Q&As Helped to Solve: 1 [?]
Skill Endorsements: 0 [?]
 
1
 

Something else to watch out for is Skype. If you have skype turned on, it may be taking up port 80 so you won't be able to start Apache.

The same thing happened to me! When I realized Apache wasn't working, I realized Skype uses port 80 as well so shutting down skype and starting apache worked fine.

Look here for help on changing the Skype port:

http://forum.skype.com/lofiversion/index.php/t31024.html

Member Avatar
Mishrab
Newbie Poster
1 post since May 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
1
 

Hi, this post is old, but nevertheless, for someone coming in here:
If you are running Windows watch out for IIS web publishing which will be running. Hit Ctrl+Shift+Esc and go to services - check out W3SVC - World Wide Web Publishing Service, click on it and go on to stop the service. Remove the startup if possible to stop having this problem, permanently. Hope this helps.

Member Avatar
MoralesD
Newbie Poster
1 post since Jun 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I am glad you posted that comment even though this thread is kind of old!
I just did what you suggested and now Apache is running!
Thanks Mishrab! God bless you!

AMD707
Newbie Poster
1 post since Aug 2009
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
Unverified Member
 
0
 

Control Panel->Administrative Tools->Services->IIS Admin->right click->stop
XAMPP Control Panel->Stop MySql
XAMPP Control Panel->Start Apache
XAMPP Control Panel->Start MySql
I hope it helps

cynoboy
Newbie Poster
1 post since May 2012
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
Unverified Member
 
0
 

The problem was Skype, once you quit skype and restart Apache, IT WORKS normally..

Member Avatar
dualzNZ
Junior Poster in Training
56 posts since Jan 2012
Reputation Points: 18 [?]
Q&As Helped to Solve: 1 [?]
Skill Endorsements: 0 [?]
 
0
 

i had this problem also so i reconfigured xampp to run on port 8080 so there is no mix up with skype and varous applications that use 80.
localhost:8080/

rigueworld
Newbie Poster
1 post since Aug 2012
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
Unverified Member
 
0
 

Thanks Mishrab It worked for me.....

Member Avatar
sotya
Newbie Poster
1 post since Sep 2012
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

skype is full of shit! why must they use port 80 and stopping our beloved web server :)

chetansabahay
Newbie Poster
1 post since Oct 2012
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
Unverified Member
 
-1
 

just go to skype and in Skype Options > Connections > now uncheck the checkbox called User 80 port for incoming call and save it. more info chetansabhaya@gmail.com

Member Avatar
akash_jj
Newbie Poster
1 post since Nov 2012
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
-1
 

remove yor skype...den it will works

You
This article has been dead for over three months: Start a new discussion instead
Post:
Start New Discussion
Tags Related to this Article