1.11M Members

FFMPEG permission problems IIS 7

 
0
 

I seem to be having a major problem with FFMPEG on my local test server everything seems to work fine the videos encode and everything. I moved all of this onto my new Windows 2008 Web Server, which uses IIS 7 and everything works I get no errors or anything but the exec command will not run ffmpeg.

I have tried all the solutions that people have suggested with changing the permissions and the permission for cmd.exe but nothing seems to make it work. I know the code works as it has all been tested.

If anyone can shed any light on this I would be very grateful, the only other solution I can currently think of is getting a linux server.

 
0
 

Are you sure exec() is enabled? In php.ini file you can set a list of functions to disable.
Besides: +1 for linux ;p

 
0
 

Yeah I am pretty sure that it is enabled as the disable_functions = "". If I am looking to go the linux root what would you recommend as I kind of want to be guaranteed that it will work. As honestly so far I am just fed up with Window's IIS security permissions and all of that.

 
0
 

Then try to run system() instead of exec() you will get ffmpeg output, so you can see what is going wrong, maybe is just the path or the permission with directories.

You can use Debian, Ubuntu or CentOS (or whatever you like), here there is the Ubuntu server guide for 11.10: https://help.ubuntu.com/11.10/serverguide/C/index.html

Bye.

 
0
 

Then try to run system() instead of exec() you will get ffmpeg output, so you can see what is going wrong, maybe is just the path or the permission with directories.

You can use Debian, Ubuntu or CentOS (or whatever you like), here there is the Ubuntu server guide for 11.10: https://help.ubuntu.com/11.10/serverguide/C/index.html

Bye.

Okay thanks for the reply I am going to have a go at using the system() function instead of exec() to see what is going on, but from what I have heard so far the permissions set up on IIS is awful.

You
This article has been dead for over six months: Start a new discussion instead
Post:
Start New Discussion
View similar articles that have also been tagged: