1,105,332 Community Members

Apache Not running on XAMPP Control Panel v3.2.1

Member Avatar
Mannava
Newbie Poster
6 posts since Oct 2013
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

5:18:22 PM [Apache] Problem detected!
5:18:22 PM [Apache] Port 80 in use by "Unable to open process" with PID 4!
5:18:22 PM [Apache] Apache WILL NOT start without the configured ports free!
5:18:22 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:18:22 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:18:22 PM [Apache] Problem detected!
5:18:22 PM [Apache] Port 443 in use by "Unable to open process" with PID 4!
5:18:22 PM [Apache] Apache WILL NOT start without the configured ports free!
5:18:22 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:18:22 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:18:22 PM [Apache] Attempting to start Apache app...
5:18:22 PM [Apache] Status change detected: running
5:18:22 PM [Apache] Status change detected: stopped
5:18:22 PM [Apache] Error: Apache shutdown unexpectedly.
5:18:22 PM [Apache] This may be due to a blocked port, missing dependencies,
5:18:22 PM [Apache] improper privileges, a crash, or a shutdown by another method.
5:18:22 PM [Apache] Press the Logs button to view error logs and check
5:18:22 PM [Apache] the Windows Event Viewer for more clues
5:18:22 PM [Apache] If you need more help, copy and post this
5:18:22 PM [Apache] entire log window on the forums

Can anyone guide/solve for this error

Member Avatar
minitauros
Practically a Master Poster
606 posts since Apr 2011
Reputation Points: 67 [?]
Q&As Helped to Solve: 105 [?]
Skill Endorsements: 6 [?]
 
0
 

Are you sure nothing else is running on those ports? I usually get this kind of problems when I'm running Skype or League of Legends (which uses Punkbuster, which operates on the same port) while starting Apache.

(Looks like a port problem, check this line: 5:18:22 PM [Apache] Port 443 in use by "Unable to open process" with PID 4!. In Windows 8 (and 7?) you can check which process has PID 4 by pressing CTRL + ALT + DEL, going to "Details" and finding the process with PID 4)

Member Avatar
Mannava
Newbie Poster
6 posts since Oct 2013
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I haven't installed skype or else any messenger in system. But still I am getting this error.

Member Avatar
minitauros
Practically a Master Poster
606 posts since Apr 2011
Reputation Points: 67 [?]
Q&As Helped to Solve: 105 [?]
Skill Endorsements: 6 [?]
 
0
 

Did you check which process is the one with PID 4?

Member Avatar
Mannava
Newbie Poster
6 posts since Oct 2013
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Yes it is the same. I shall write the complete error kindly check.

Error:

1:06:52 PM  [Apache]    Problem detected!
1:06:52 PM  [Apache]    Port 80 in use by "Unable to open process" with PID 4!
1:06:52 PM  [Apache]    Apache WILL NOT start without the configured ports free!
1:06:52 PM  [Apache]    You need to uninstall/disable/reconfigure the blocking application
1:06:52 PM  [Apache]    or reconfigure Apache and the Control Panel to listen on a different port
1:06:52 PM  [Apache]    Problem detected!
1:06:52 PM  [Apache]    Port 443 in use by "Unable to open process" with PID 4!
1:06:52 PM  [Apache]    Apache WILL NOT start without the configured ports free!
1:06:52 PM  [Apache]    You need to uninstall/disable/reconfigure the blocking application
1:06:52 PM  [Apache]    or reconfigure Apache and the Control Panel to listen on a different port
1:06:52 PM  [mysql]     XAMPP MySQL is already running on port 3306
1:06:52 PM  [main]  The Tomcat module is disabled
1:06:52 PM  [main]  Starting Check-Timer
1:06:52 PM  [main]  Control Panel Ready
1:07:05 PM  [filezilla]     Attempting to start FileZilla app...
1:07:05 PM  [filezilla]     Status change detected: running
1:20:54 PM  [Apache]    Status change detected: running
1:21:03 PM  [Apache]    Status change detected: stopped
1:21:03 PM  [Apache]    Error: Apache shutdown unexpectedly.
1:21:03 PM  [Apache]    This may be due to a blocked port, missing dependencies, 
1:21:03 PM  [Apache]    improper privileges, a crash, or a shutdown by another method.
1:21:03 PM  [Apache]    Press the Logs button to view error logs and check
1:21:03 PM  [Apache]    the Windows Event Viewer for more clues
1:21:03 PM  [Apache]    If you need more help, copy and post this
1:21:03 PM  [Apache]    entire log window on the forums
Member Avatar
minitauros
Practically a Master Poster
606 posts since Apr 2011
Reputation Points: 67 [?]
Q&As Helped to Solve: 105 [?]
Skill Endorsements: 6 [?]
 
0
 
1:06:52 PM [Apache] Problem detected!
1:06:52 PM [Apache] Port 80 in use by "Unable to open process" with PID 4!
1:06:52 PM [Apache] Apache WILL NOT start without the configured ports free!
1:06:52 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
1:06:52 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port

This means that the process with Process ID 4 is operating on a port Apache is configured to use. You can either reconfigure Apache to use another port (but god I wouldn't know how :p), or press ctrl + alt + delete, go to the "Details" tab and check which process has Process ID 4, and halt that process (this is in windows 7/8).

I have no idea why Apache is emitting this error, though:

1:21:03 PM [Apache] Error: Apache shutdown unexpectedly.
1:21:03 PM [Apache] This may be due to a blocked port, missing dependencies,
1:21:03 PM [Apache] improper privileges, a crash, or a shutdown by another method.
1:21:03 PM [Apache] Press the Logs button to view error logs and check
1:21:03 PM [Apache] the Windows Event Viewer for more clues
1:21:03 PM [Apache] If you need more help, copy and post this
1:21:03 PM [Apache] entire log window on the forums
Member Avatar
Mannava
Newbie Poster
6 posts since Oct 2013
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I cant end that particular process as it is using the system as user name and pid is 4. the description for that username process ius NT Kernal & System.
If we end the process then it would be restart as it is NT Kernel and System.

Member Avatar
minitauros
Practically a Master Poster
606 posts since Apr 2011
Reputation Points: 67 [?]
Q&As Helped to Solve: 105 [?]
Skill Endorsements: 6 [?]
 
1
 

I don't think it will give you any more info, but have you checked the "Netstat" window of XAMPP? (It's on the right side in the control panel and might give you some more information).

Also, I have no idea if it might work, but if (in your XAMPP control panel) you click the "Config" button for your Apache server, you can open "httpd.conf". In that file, there's a line that says "Listen 80" (for me). Maybe you could change the port to something other than 80 and see if that works. I know it's not the 443 port that you're changing, while that IS the one that is causing you troubles, but I can't find where the 443 port is coming from myself, so I wouldn't know where to look to change it.

For the rest I don't think I can help you :(.

Member Avatar
Mannava
Newbie Poster
6 posts since Oct 2013
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Thanks for your help, tried implement the same. Like I had changed the port numbers which are not existing 8088 and 444. but it is the same. I am getting an error: appache shutdown unexpectedly. This may be due to a blocked port, missing dependencies, improper privileges, or a shutdown by another method.

Member Avatar
minitauros
Practically a Master Poster
606 posts since Apr 2011
Reputation Points: 67 [?]
Q&As Helped to Solve: 105 [?]
Skill Endorsements: 6 [?]
 
0
 

Have you tried reinstalling XAMPP? Maybe in another folder? Run it with admin privileges?

Member Avatar
Mannava
Newbie Poster
6 posts since Oct 2013
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Yes I had reintalled the XAMPP again. And also tried to install in differ folder and drive. Everything running with the admin privilages.

Member Avatar
minitauros
Practically a Master Poster
606 posts since Apr 2011
Reputation Points: 67 [?]
Q&As Helped to Solve: 105 [?]
Skill Endorsements: 6 [?]
 
0
 

Sorry man then I have no idea what else you could do :\ . I hope someone else can help..

Member Avatar
chayassongi
Newbie Poster
4 posts since Nov 2012
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I had faced this problem in win7. Now i run it as administrator, now it is working.... :D

Member Avatar
Jennifer_3
Newbie Poster
1 post since Dec 2013
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I fixed this in Windows 7 by stopping the Web Deployment Agent Service.

Member Avatar
purevouge
Newbie Poster
1 post since Dec 2013
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

this post slove it form me
"sql server reporting" part

http://www.sitepoint.com/unblock-port-80-on-windows-run-apache/

Member Avatar
danthecardman
Newbie Poster
1 post since Jan 2014
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I have solved this issue (at least for me). And i used a few ideas in this forum and eventually fixed the issue. So I'm posting to try to help out Mannava (and anyone else).
...
So Purevouge provided a link:
Click Here

in the link using Windows 7 you open a CMD prompt and type in command: net stop was /y
....

Well I got an ACCESS IS DENIED message.. but the description message of what was denied lead me right to the solution...
"World Wide Web Publishing Service"

...
So then I went and checked out which Windows Service might be running fitting that message...
So open up the Run Dialog Box (press keys Win+R)
.. then type: services.msc

I then scrolled down to:
World Wide Web Publishing Service
Double clicked on it and clicked STOP

And Voila my XAMPP with Apache is now running.

Member Avatar
Mr.Assim0
Newbie Poster
1 post since Jan 2014
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Web Deployment Agent Service is not in my services.msc

Im experiencing Microsoft-HTTPAPI/2.0 problem in my windows 8.1 :(

Member Avatar
Babić
Newbie Poster
1 post since Jan 2014
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Stopping World Wide Web Publishing Service solved my problem.

Thanks

Member Avatar
Jared_2
Newbie Poster
1 post since Feb 2014
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

THANK YOU SO MUCH!!! All the sudden XAMPP stopped working and I uninstalled and re-installed MULTIPLE TIMES. On my Windows 8.1 Machine, PID 4 was "System." I used the Apache Config httpd.config, as you said, and just changed "80" to "120" and saved. Works great! I so appreciate it!

Member Avatar
stokie-rich
Junior Poster in Training
60 posts since Nov 2013
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

hi guys im having the same problem, im new to this so i dont know really how to resolve this problem

You
Post:
Start New Discussion
Tags Related to this Article