1,105,375 Community Members

WMV and Flash Vimeo on same page

Member Avatar
powersstuff
Newbie Poster
22 posts since Jan 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

http://www.creativedesignresolutions.com/projects/highway/bridges/i-35-corridor-widening-construction-project-1,-us77/39.html?headerbar=0

Please see my issue on above page that I need to fix.
I've got a Vimeo video and a wmv video on this page with two buttons: one for flash, one for wmv player. The issue is that when the wmv button is clicked the video tries to load full screen within the pop-up box, and it is taking too long to load. On some browsers' versions it doesn't ever fully load. The flash player works with no problem. How can I get the wmv player working? Here's what I copied:

<div id="flash_box">

<iframe src="http://player.vimeo.com/video/16395534?byline=0&amp;loop=1" width="800" height="450" frameborder="0"></iframe>
</div>

<div id="wmv_box">

<!--<embed type="application/x-mplayer2" pluginspage="http://www.microsoft.com/Windows/MediaPlayer/" name="mediaplayer1" showcontrols="true" ShowStatusBar="true" EnableContextMenu="false" autostart="true" width="600" height="360" loop="false" src="http://www.creativedesignresolutions.com/videos/Edmond.wmv" />-->

<!--<OBJECT ID="MediaPlayer" WIDTH="600" HEIGHT="360" CLASSID="CLSID:22D6F312-B0F6-11D0-94AB-0080C74C7E95"
STANDBY="Loading Windows Media Player components..." TYPE="application/x-oleobject">
<PARAM NAME="FileName" VALUE="http://www.creativedesignresolutions.com/videos/Edmond.wmv">
<PARAM name="autostart" VALUE="true">
<PARAM name="ShowControls" VALUE="true">
<param name="ShowStatusBar" value="false">
<PARAM name="ShowDisplay" VALUE="false">
<EMBED TYPE="application/x-mplayer2" SRC="http://www.creativedesignresolutions.com/videos/Edmond.wmv" NAME="MediaPlayer"
WIDTH="600" HEIGHT="360" ShowControls="1" ShowStatusBar="0" ShowDisplay="0" autostart="1"> </EMBED>
</OBJECT>-->



<object ID="Player" classid="CLSID:6BF52A52-394A-11d3-B153-00C04F79FAA6" type="application/x-oleobject" 
							width="600" height="360" hspace="0" vspace="2" standby="Loading...." VIEWASTEXT>
         <param name="url" value="http://www.creativedesignresolutions.com/videos/Edmond.wmv">  
         <param name="AutoStart" value="false">

         <param name="ShowTracker" value="true">
         <param name="ShowControls" value="true">
         <param name="ShowGotoBar" value="false">
         <param name="ShowStatusBar" value="false">
         <param name="AutoSize" value="false">
         <param name="AnimationAtStart" value="false">
         <param name="AutoRewind" value="false">
         <param name="Balance" value="0">
         <param name="EnableFullScreenControls" value="0">
         <param name="BufferingTime" value="5">
         <param name="Enabled" value="true">
         <param name="enableContextMenu" value="true">
         <param name="uiMode" value="full" >

         <param name="EnableTracker" value="false">
         <param name="InvokeURLs" value="true">
         <param name="VideoBorderWidth" value="0">

         <param name="VideoBorderColor" value="0">
         <param name="Volume" value="100">
         <param name="WindowlessVideo" value="false">
   <embed id="Player1" type="application/x-mplayer2" width="600"  vspace="2" height="360" src="http://www.creativedesignresolutions.com/videos/Edmond.wmv" pluginspage = "http://www.microsoft.com/windows/mediaplayer/" AutoStart="false" ShowTracker="true"  ShowControls="true" 
							ShowGotoBar="false" ShowDisplay="false" ShowStatusBar="false" AutoSize="false"  AudioStream="-1" AnimationAtStart="false" 
							AllowScan="true" Balance="0" BufferingTime="5" ClickToPlay="true" CursorType="0" CurrentMarker="0" DisplayMode="0" 
							DisplaySize="0" Enabled="true" EnableContextMenu="1" EnableFullScreenControls="1" EnablePositionControls="true" 
							EnableTracker="true" InvokeURLs="false" Mute="false" PlayCount="1" SendPlayStateChangeEvents="true" ShowCaptioning="false" 
							ShowAudioControls="true" ShowPositionControls="true" TransparentAtStart="true" VideoBorderWidth="0" VideoBorderColor="0" 
							Volume="100" WindowlessVideo="false"></embed></object>	

</div>
logoonlinepros
Junior Poster
108 posts since Nov 2010
Reputation Points: -6 [?]
Q&As Helped to Solve: 9 [?]
Skill Endorsements: 0 [?]
Banned
 
0
 

Good post its helpful for me also.

Member Avatar
ciint
Newbie Poster
18 posts since Jul 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 5 [?]
Skill Endorsements: 0 [?]
 
0
 

This website may help you to play flash and WMV file in your website.Follow The steps according to your need. http://www.beansoftware.com/ASP.NET-Tutorials/Media-Player.aspx

Member Avatar
powersstuff
Newbie Poster
22 posts since Jan 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Thanks for your suggestion, but as to using the asp.net I think that would be good for the wmv file to detect the browser (IE or FF), but as I read the article I didn't think it would apply for both wmv and flash on the SAME page. As it turned out, the more ways I tried it the more difficult it became. The closest I think would work was to have one play in a new window.

Question Answered as of 3 Years Ago by ciint and logoonlinepros
You
This question has already been solved: Start a new discussion instead
Post:
Start New Discussion
View similar articles that have also been tagged: