This site is not being rendered right in my current browser, Opera. The rounded corners appear a bit off. Just thought I'd mention this, I have the latest Opera version available, my OS is Ubuntu.

See you :)

Do a print screen then attach the bitmap so we can see what you mean.

Ok there you go, see attachment.

Where's the attachment?

You most likely haven't installed the Microsoft Core Fonts.

Agreed.

I use Opera too and don't have that problem. Site renders good for me.
I'm using Windows though.

Yes installing the Microsoft Core Fonts did the job. Here's a quick how to for other people that may be experiencing this in Ubuntu 8.10.
Non-Terminal:
Go to Applications > Add/Remove...
and Search for microsoft core fonts (make sure All Available Applications is selected next to the search box)
Check the box and click Apply Changes

Terminal:
Open the Terminal: Applications > Accessories > Terminal
Type in: sudo apt-get install msttcorefonts
After this you will be prompted your password and the installing will begin.

After installing the fonts you will have to logout for them to be applied.

commented: Thanks for the Ubuntu tip! +15

So how can I make that happen on a Windows computer? I don't like rounded corners. :icon_cheesygrin:

Don't be so square!:icon_mrgreen:

:icon_lol: :icon_cheesygrin: :icon_mrgreen:

You're a Noid. The avatar gives it away.

I have two Noids. Does that make them a paranoid?

Go to Applications > Add/Remove...
and Search for microsoft core fonts (make sure All Available Applications is selected next to the search box)
Check the box and click Apply Changes

By default it wont be available because its not OpenSource. You will get it however if you have additional repositories checked (its one of universe, multiverse or restricted). Most users will have done this though as you need theses repos enabled to get the flash plugin and java.

Also make sure the combo box in add/remove says "all available software" and not just "supported software" or "open software"