0

The only issue with code tags that I know about is that I have to manually refresh the window after saving a post that contains code. If I don't do that, the text of the code is there, its just not in code tags. When I edit the post I see the code tags and the text, but after Save the code doesn't appear to be in code tags. this was very confusing to me until I realized I had to press the Refresh button on my browser.

0

code tags work a lot better and easier if you just put ~~~ at the top of the code and again at the end. No need to manually indent the code. Requiring posters to manually indent all the code 4 spaces is just crazy, IMHO.

0

Requiring posters to manually indent all the code 4 spaces is just crazy, IMHO.

When pasting code, all you need to do is highlight it and either click the Code button or hit the Tab key on your keyboard. And if manually typing code into the editor, it preserves your indentation level like a real IDE would. It's actually EASIER for me to intent code than manually add [code] above and below a post because it's just hitting one key, once, versus twelve keys (for open/close code tags)

0

Is there a way to stop urls parsing automatically?

Also - noticed the editor now works as a blank textbox in HTC (Yipee!) but it doesn't post when I reply to article. Sorry, bit off topic.

0

When pasting code, all you need to do is highlight it and either click the Code button or hit the Tab key on your keyboard. And if manually typing code into the editor, it preserves your indentation level like a real IDE would. It's actually EASIER for me to intent code than manually add [code] above and below a post because it's just hitting one key, once, versus twelve keys (for open/close code tags)

But I've always found it easier to hit the CODE indicator and paste the CODE between the [CODE][/CODE] marks, rather than pasting the code and going back to highlight the code. Same with Bold, Italic, etc. I would like to see clicking a command placing empty indicators into the message like before.

And to prevent the "Huh?", I mean when I click Italic with nothing highlighted, two stars are placed in the message field and the cursor placed between them. Same with Bold, Code, Inline, etc.

And Quotes just seem to be a pain in general. Isn't there any way to quote without copy/paste -- like before the change? If not, is it on the todo list?

0

Yes, if you do not want ot change the Code action to ~~~ (which by the way is tough to do with Finnish keyboard as ~ is Alt Gr-Dead key-space) at least make the menu to require selection before clicking... and in that case Code only dublicates the Tab key.

Edited by pyTony

1

Is there a way to stop urls parsing automatically?

I saw this one coming. ;) My answer from before isn't valid anymore because both the live editor and back-end parser are converting HTML into straight text rather than parsing it. However, the automatic linkification of a URL only applies if you include the protocol at the beginning, so http://www.google.com will be linkified while www.google.com will not. This is a convenient quirk of the heuristic being used to match a URL.

If that's not enough, I can hack in an exclusion character such that something like ^http://www.google.com would disable linkification and the exclusion character (a leading caret in this example) wouldn't show up in your post. But I suspect that's not necessary as just trimming off the protocol should be sufficient. :)

And Quotes just seem to be a pain in general. Isn't there any way to quote without copy/paste -- like before the change?

Quotes aren't line based, they're paragraph based. Maybe they seem to be a pain because the quote button prefers to place a quote starter on each line. However, you can just plop down a quote starter at the beginning of each paragraph (ie. block of text without a blank line at the end) and it'll be properly quoted.

Edited by deceptikon: asdf

Votes + Comments
great ^ it is then :)
0

Oh nevermind. I gotcha. I forgot that I set it up to automatically parse URLs on purpose.

0

Kudos to Formatting Help link. No however editor is very slow for me, at least one character behind my typing, which throw me of balance as I type with 10 fingers and look the result from screen (I restarted Firefox to make sure it was not memory issue).

0

Hmm, it works pretty good for me. Not a really noticable lag. I'm on an iMac with a LOT of ram.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.