I was trying to edit a post that I made earlier, and the "Edit Post" link brought up the text edit mode, but did not have any "Save" or "Submit". Only "Cancel". Also, the "Edit Post" button was still active. When I clicked it the second time it just "refreshed" the text box. Is this a bug or a feature?
I'm using Linux and Google Chrome 25.

Update: I see now that Firefox doesn't even show the "Edit Post" link, which is probably what Chrome should have done. (Because it's been a while since I posted it?)

Attached ScreenShot:
daniweb-edit-bug

i think you can edit for 3 hours after the original posted time.

as for the display bug i can't help you, i did do some edits today though. Using windows 7 and chrome. Worked fine for me.

Do you still see the Edit Post button in Chrome? It's possible that you loaded the page just under the 30 min threshold (I see the post was 24 mins old at the time, according to your screenshot) and clicked to edit the post just after the 30 min threshold.

ah so its 30 min not 3 hours? was it 3 hours before the big update you did a while back or was i just plain wrong? haha

No, it's always been 30 minutes.

was it 3 hours before the big update you did a while back or was i just plain wrong?

Nope. If memory serves me it may have once been 15 minutes, but was never more than 30.

No worries :)

What you said makes sense, I'll have to try it when I get home.

try and try until u get it

The edit post is gone. I'm pretty sure it's exactly what you said Dani. I was just in the wrong place at the wrong time. Early enough to see an "Edit Post" link, but too late to use it by the time I clicked it. Anyway, thanks.

Member Avatar
diafol

I'm sure this happened to me before my mod powers. How annoying that all your hard work is just lost. Would it be possible to give the poster the option to save edited post as a new post if time since creation > 30mins?

Huh? I think you're misunderstanding what happened.