0

This is the message I get while trying to answer in a thread. Only, there is no clue of what I could do to prove that I'm actually a human, so that the robot would be satisfied. Can you help me ?

(qupzilla/linux)

edit: with firefox, it works. Only it's the first time I get this error in qupzilla. What can I do ?

Edited by Gribouillis

3
Contributors
8
Replies
47
Views
11 Months
Discussion Span
Last Post by Gribouillis
1

OK, I grabbed the Windows Portable version, ran it, Dazah login and now this reply.
That's as clean as I can make this. If this posts, it worked on W10.

Votes + Comments
Thanks for your help
0

Solved: it started to work again when I configured qupzilla to send the Referer headers to the server !

Edited by Gribouillis

0

Grib, I think that's it. Mind you my run at this was just to check out the browser and log it for more tests on some very very old machine.

Since these are 2 sites, the referer is, without me thinking too hard here, "it."

I do have questions. Was this a change from stock settings? And while I can guess why we would block this, why did you change the referrer setting?

0

Without referer headers, we think you're a bot. Glad you were able to get it working on your own. For those web developers out there, do you agree that having valid referer headers is one part of testing for not status?

0

@rproffitt I was only playing with the browser settings in order to solve an unrelated issue. I unchecked the referer headers just to see if it would change anything, also I like the idea of sending less information to servers. I'm only interested in getting information from websites, not in sending them information about me or my browsing habits.

0

The thing is that if we are unable to detect that a post was initiated from the daniweb.com domain, then we assume it's a bot.

0

@Grib. So it's clear why it broke and why you did what you did.

How about this? I think you can turn it back off once you get logged in. So you can slice that cake anyway you want now.

1

Hm, no, I can not turn it off once I'm logged in. I'll keep my referer headers on :)

Votes + Comments
Got it. I'll let you test this. Thanks for asking since I learned a thing or two.
This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.