0

I have a 500 mHz iMac. The CD drive used to work perfectly. Now, it will read and mount cd-roms and audio cd's, but whenever a blank disc is inserted, regardless of brand, it makes a grinding noise several times, then ejcts the disc. No error messages or dialog boxes of any kind appear and the disc is spinning in the drive. Any one have the foggiest idea how to fix? Oh and it does this whether the machine is cold or hot, and in OS X 10.2.8 or in OS 9...

3
Contributors
4
Replies
5
Views
13 Years
Discussion Span
Last Post by kingcool
0

Can you please post the entry for your CD drive from the ATA section of Apple System Profiler (/Applications/Utilities/Apple System Profiler)?

0

Disc Burning Fully supported
Unit Number 1
ATA Device Type atapi
Device Revision AH36
Product Identification CD-RW CW-7121
Vendor Identification MATSHITA

0

Hello,

Yep. You should be able to insert a blank disk and have the Finder ask you what to do with it. Have you changed types of media? Meaning, did you used to use Verbatim brand CD-ROMS, and now are starting with TDK? Sometimes, the types of disks used will make the things behave funny.

Also, run Software Update to make sure you have the latest software. It is possible too that an upgrade broke it.

I am not sure if OS 9 Supported blank CD-ROMS on the desktop. Never tried it.

Christian

0

Well, I still don't have any answers from anyone on this. I know I should be able to burn discs and it doesn't matter what brand of blanks i use I get the same thing. If anyone has had this same problem and fixed it, pleqase lemme know what to try apart form replacing\repairing the whole shebang...Thanks to you all...

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.