0

I recently received a 1.8 GHz iMac G5 and already have a 933 MHz G4 Quicksilver w/ one master and one slave HD. I have two issues. One, I'd like to use the faster iMac and access the files and larger drives on my Quicksilver. Unfortunately in Target Disk mode, firewire only sees the Master drive on the G4. Both machines have one ethernet port, and on the G4 that is connected to my cable modem. What's the best way to configure these two without opening a can of worms with my broadband? Both are running Tiger.

Second, I'd like to create an extended desk top with my two monitors, using my larger Samsung as my main display. I assume I'm going to need a second video card in the iMac. While the Quicksilver was easily accessible for do-it-yourself upgrades, the iMac does not appear to be. Can I do it myself?

3
Contributors
8
Replies
9
Views
8 Years
Discussion Span
Last Post by John A
1

Your first problem is easily overcome by simply turning on filesharing for Firewire in the Mac OS X System Preferences (instead of using Target Disk Mode). Your iMac should then be able to see the drives as part of your network.

As for your second question, this is probably possible, but it's a little trickier. The good news is, your iMac should already have a video out port, called a mini-VGA port. Apple sells mini-VGA to VGA adapters, which means you can connect any VGA monitor or projector, and mirror the iMac's display on the external display.

However, I assume you want an extended display. iMacs can only support mirrored displays by default, but with a little firmware hack (which will certainly void any warranty you might have for it), it is possible:
http://www.macworld.com/article/39969/2004/10/imacscreenspanning.html

Hope that answered your question.

Votes + Comments
Now that is some darn useful information.
0

Almost there!

Thanx for the firmware info on the extended desktop. Just what the Doctor ordered, Though the Finder bar is across the top of the wrong monitor, I can live with that for now. I just had no use for a mirror setup.

Next issue; THE NETWORK. Detailed tech info has been buried so deep in knowledge bases and discussion boards that I've resorted to trial, error and intuition to get these two beasts talking. I already had all file sharing on, tinkered with network settings and here's where I stand.

I still have them connected with firewire. On my older Quicksilver, I can click on the master drive and open the the window showing the column format. On the far left, the top four icons are Network, my master drive, my slave drive in that order. I click on Network and the second column opens with 3 aliases: Library, Servers, Tim's PowerMac G5 (my iMac).

I click on the last icon and a third column opens revealing a boxed Network icon. I click connect, choose my iMac drive from a menu and Voila! My iMac appears on my Quicksilver with the other icons.

But on the iMac all is the same until I get to the boxed network icon to select Tim's Power Mac G4. It tells me the original item cannot be found. I click on Fix Alias. It opens a new window to choose the item I want the alias to open. No similar references to my G4 here and I'm stumped. Help.

0

Okay, first of all, make sure your networking settings are okay. I highly recommend using static IP addresses for both machines to make the whole setup easier.

Go to System Preferences and choose Networking. For the Quicksilver, here's my recommended settings (make sure you set this for the Firewire interface, not your Ethernet):
Configure IPv4: Manually
IP Address: 192.168.1.1
Subnet Mask: 255.255.255.0
Router: (blank)
DNS Servers: (blank)
Search Domains: (blank)

Now go to your iMac, and use these similar settings:
Configure IPv4: Manually
IP Address: 192.168.1.2
Subnet Mask: 255.255.255.0
Router: (blank)
DNS Servers: (blank)
Search Domains: (blank)

Apply your configurations. On your iMac, click anywhere on your desktop, and from the menu choose Go->Connect to Server... (command-K), which will bring up a dialog box. Enter 192.168.1.1 for the server address, and you should be able connect to your Quicksilver.

One final note, regarding the menu bar on the wrong screen: have you tried going into System Preferences->Display->Arrangement and dragging the little menu bar in the diagram across to the other screen? I've obviously never tried the firmware hack, but I'm curious to know if that works.

0

Thanx, but no go, I'm afraid. On the Quicksilver Network Pref. pane, I get a constant and annoying pop up telling me my settings have been changed by another application (my broadband?). I click okay. It disappears and immediately pops back up and will not allow any other function. Not even quitting System Preferences.

I did figure out that by holding my mouse over the Show menu I could make that pop up disappear and change it from ethernet to firewire if I clicked fast enough. I got so far as to change the set up to manual on IPv4, but as soon as I clicked to enter the IP address, it immediately reverted to the DHCP mode and that accursed popup sprung back.

On the iMac I have gotten to connect to server by Command K and a network icon appears in the window with Tim's Power Mac G4.local named, but I click Connect and...nothing. I'm ready to throw in the towel at this point. I guess I can't get there from here. I just don't get how I can use my G5 as a server for my Quicksilver but not the other way around. Maybe the system is designed to force me to open an iDisc account.

As to the Finder Menu bar on the monitors, it can't be changed. Only the arrangement of the screens (i.e. left or right). It may have to do with the iMac being monitor and CPU in one, and by God that's going to be your navigation screen.

1

Thanx, but no go, I'm afraid. On the Quicksilver Network Pref. pane, I get a constant and annoying pop up telling me my settings have been changed by another application (my broadband?). I click okay. It disappears and immediately pops back up and will not allow any other function. Not even quitting System Preferences.

Ugh, I was just getting that error message myself on my iMac the other day. It appears to be a bug with Apple's latest software update. The quickest workaround is to go to System Preferences->Security and then check "Require password to unlock each secure system preference". That should do the trick.

If not, see this thread. I haven't tried it yet, but it appears to fix the problem:
http://forums.macrumors.com/showthread.php?t=576199

0

Damn! I'm always ALMOST there! Latest is I fixed the Preferences Pane problem (it returned but not until I set the addresses). However, the iMac would still sit there with the Connect button glowing blue and unresponsive. Finally opened the Network Utilities just for grins. I confirmed the addresses and sent pings to the Quicksilver, which were answered with no error. Also did the same from G4 to G5. All seems well. They CAN BOTH see each other. Then I opened Terminal, selected the Secure Shell server setting and up popped the G4 address. I selected it, hit Connect and the G4 Terminal login window appeared. I logged in apparently successfully and...that's as far as it went. I appreciate your suggestions on this and will try your latest. I'm just a dumb graphic designer who is obsessed with problem solving, but I just KNOW this can be done. I'm starting to get so deep into obscure lines of code that I wonder if my left brain's up to it. I also remember reading about problems with an unresponsive Connect button having to do with a missing or corrupted BSD package. I did after all update the iMac's OS from Panther to Tiger.

1

Your Quicksilver doesn't have its firewall enabled, does it? Also, you may want to try a different protocol just to see if that will work. Try enabling Windows File Sharing, then on the iMac in the Connect to Server... box enter 'smb://192.168.1.1'.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.