Start New Discussion within our Microsoft Windows Community

Every time I uncheck the boxes for the proxy server in my internet options settings it keeps being reset. I even restart the computer. Can I do this in safe mode? I am having trouble accessing certain sites in IE and Mozilla browsers too.

(Posted with a public account)

I had the same problem. In Windows XP SP3, Control Panel > Internet Options (to open Internet Properties dialog), Connections tab, LAN settings. In "Local Area Network (LAN) Settings" dialog, section "Proxy server" had a check for "Use a proxy server for your LAN (These settings will not apply to dial-up or VPN connections).".

Clicking Advanced showed me my proxy settings, which I wanted to disable, but whenever I uncheck the box in the "Local Area Network (LAN) Settings", or delete the info in the Proxy Settings dialog for HTTP and its Port, the "Use a proxy server..." box would be checked after closing and re-opening the "Local Area Network (LAN) Settings" dialog, and the data in Proxy Settings dialog would be back.

Solution: In the Proxy Settings dialog, delete not only HTTP and its Port, but the contents of the Exceptions text area. My Exceptions text area said something like ";;*.local". Click OK. An "Invalid Proxy Server" dialog appears. Click Yes to turn off proxy connection, and it finally stayed off.

(Similar problem of proxy turning back on could be due to malware or registry changes / network policy. See stackexchange for more info on those.)

Thanks so much bbman!! :D I've been fighting with this for weeks, although I cant help but wonder what prog set this in the first place...

I tried your method bbman but it keeps coming back even if follow the steps. I just want my internet connection back and nothing works. I don't have the money to but a new laptop. My laptop is a Windows 7 Dell Inspiron 15R. If anyone can help it'd be great.

I found the culprit was hot spot shield, uninstalled and all is well..


I am currently experiencing this same problem, however, if you download Firefox (which uses separate internet settings), it can bypass this so you can at least use your internet.

In your Firefox browser, go to Options> Advanced tab> Settings...> Here, select "No proxy" and it should work just fine :) If not, just choose "Auto-detect".

Hope this helps!

Hey all, I have finally fixed the issue for me.

The original issue was that I was unable to uncheck the Proxy server settings. After unchecking it, I would exit the menu and it would recheck itself. I have attached a picture of the problem.

My fix was quite simple:

1) Safemode with Networking - restart your computer, and tap F8 repeatedly as soon as it starts back up, until a menu pops up with a bunch of options. Choose "safemode with networking". (My assumption is that this works because it starts your computer up with only the essential drivers, meaning the program that is causing your proxy setting to continue to check itself isn't even running when we start our computer up like this)

2) Internet Settings - Go back to the Proxy settings box, click "Advanced", delete everything on that window, click "OK", a Proxy error window will pop up. Click "OK", then uncheck the troublesome box, and make sure you check the box at the top of the window that says "Automatically detect settings" and voila! It should be fixed!

thank you it work!!!
Attachments Proxy_Settings_Image.PNG 36.47 KB

I have a simple solution that worked for me. open your IE as an Administrator, Goto tools>Internet Options>Connections Tab, Click on LAN settings and Uncheck proxy as well as "Automatically Detect Settings". Restart your browser.. It should work..

I remember buying my Mozilla product a few years back and the staff are smiling and they don't keep you waiting for long. I think the customer service are slipping away.

Identical, apart from brand name, post to one made by jameswarner account - and equally inappropriate - suggest you stop doing whatever it is you are up to before your account(s) end up in trouble

Thank you, preetham 1. I had tried all other options, including uninstalling/reinstalling IE, running malware programs, and went through the living hell of having the proxy settings reappear. Until now. Until your suggestion. I owe you a cup of coffee

preetham1....You are AMAZING.   Thank you so much.  Like others, I have spent countless hours trying to disconnect the Proxy in Windows 8.1 Pro.  I think I tried every fix that is posted on the web, with no luck. I used your method and IT WORKED.  I have full access and control of my internet settings now.  AGAIN THANK YOU SO MUCH.     

I had this same problem because of a program that was apparently bundled with my download of Vuze. Look at the hidden icons in your system tray to see what's running in the background. The culprit for me was Genius Box search enhancer. Once I uninstalled that, my proxy settings automatically turned off.

Hey guys i have tired all of your ideas and none of them have worked. The proxy sever still isn't responding. Please help!!!

I have a simple solution that worked for me. open your IE as an Administrator, Goto tools>Internet Options>Connections Tab, Click on LAN settings and Uncheck proxy as well as "Automatically Detect Settings". Restart your browser.. It should work..