Hello I have a problem with customizing my menu, I created a new mvc web application. Visual studio has created a default menu but I wanna add a background image like an image with "Home" or About instead of the default one. here is my code. <body> <div class="page"> <div id="header"> <div id="title"> <h1 style="font-family:verdana;"></h1> </div> <div id="logindisplay"> <% Html.RenderPartial("LogOnUserControl"); %> </div> <div id="menucontainer" > <ul id="menu" > <li><%: Html.ActionLink("Home", "Index", "Home")%></li> <li><%: Html.ActionLink("Contact", "Index", "Contact")%></li> <li><%: Html.ActionLink("About", "About", "Home")%></li> </ul> </div> </div> <div id="main"> <asp:ContentPlaceHolder ID="MainContent" runat="server" /> <div id="footer"> </div> </div> </div> </body> the css file #menucontainer { …

Member Avatar
Member Avatar
+0 forum 1

Hello guys I have an xslt file I want to extract data from. I am new to xslt but at the moment I can perform basic operations like looping through the nodes and creating element and attributes. My problem is that I want to select a particular value from a particular node(from a list of nodes), here is an example. <PersonsList> <person> <id>1233</id> <name>john</name> </person> <person> <id>444</id> <name>peter</name> </person> <person> <id>677</id> <name>Amanda</name> </person> </PersonsList> I want to get for example the name value say amanda if it matches the id. like in C# one would say: if (id==677) select name, …

Member Avatar
Member Avatar
+0 forum 1

Hello guys, I have a problem convrting to an int in xslt. My xslt is: <xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform" xmlns:tem="http://tempuri.org/"> <xsl:output method="xml" version="1.0" encoding="UTF-8" indent="yes"/> <xsl:template match="/"> <xsl:call-template name="ConnectConsumer"/> </xsl:template> <xsl:template name="ConnectConsumer"> <tem:callRule> <xsl:for-each select="/"> <xsl:for-each select="ConsumerDetails"> <xsl:for-each select="Score"> <xsl:element name="tem:arg0"> <xsl:value-of select='format-number(Score,"#" )'/> </xsl:element> </xsl:for-each> </xsl:for-each> </xsl:for-each> </tem:callRule> </xsl:template> </xsl:stylesheet> My xml is: <ConsumerDetails> <BirthDate>1981-05-22</BirthDate> <Gender>Male</Gender> <AgeOfOldestOpenAccount>8</AgeOfOldestOpenAccount> <AgeOfYoungesttOpenAccount>2</AgeOfYoungesttOpenAccount> <TotalAccBalance24Months>50000.0</TotalAccBalance24Months> <AccountsWorthStatus3in24Months>4</AccountsWorthStatus3in24Months> <Score>849.0000</Score> <Age>31</Age> <City>MILNERTON</City> </ConsumerDetails> when I transform it does not work, it returns the following result: <?xml version="1.0" encoding="UTF-8"?> <tem:callRule xmlns:tem="http://tempuri.org/"> <tem:arg0>NaN</tem:arg0> </tem:callRule> I want the number instead of NaN

Member Avatar
Member Avatar
+0 forum 1

xslt Hello guys, I hope everyone is well. I didnt know where to post this particular problem so I just put it under general, I apologize if its the wrong place. this is one of my first few attempts to get the xml data to a specific xml format. Its not returning the format I want Heres my xslt <xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform" xmlns:fo="http://www.w3.org/1999/XSL/Format" xmlns:n1="http://www.web.xds.co.za/XDSConnectWS" xmlns:tns="http://schemas.xmlsoap.org/soap/envelope/" > <xsl:output method="xml" version="1.0" encoding="UTF-8" indent="yes"/> <xsl:template match="/"> <xsl:element name="Gender"><xsl:call-template name="ConnectGetCreditReport"/></xsl:element> </xsl:template> <xsl:template name="ConnectGetCreditReport"> <xsl:for-each select="/"> <xsl:for-each select="tns:Envelope"> <xsl:for-each select="Body"> <xsl:for-each select="n1:ConnectGetCreditReportResponse"> <xsl:for-each select="ConnectGetCreditReportResult"> <xsl:for-each select="Consumer"> <xsl:for-each select="ConsumerDetail"> <xsl:for-each select="Gender"> </xsl:for-each> </xsl:for-each> </xsl:for-each> </xsl:for-each> </xsl:for-each> …

Member Avatar
+0 forum 0

Hello guys, I just deployed my site and when I try to view through the browser I get "403 - Forbidden: Access is denied." error. this does not happen when I replace index.aspx in the wwwroot folder with index.html. I would really appreciate any advice on this thank you.

Member Avatar
Member Avatar
+0 forum 2

Internal Server Error 12 minutes ago|LINK Hello Guys, I need help deploying my little website I am designing. I have my index.html file in the wwwroot folder and my web.config file is there too. the contents of the web.config file are: <?xml version="1.0" encoding="UTF-8"?> <configuration> <system.webServer> <defaultDocument> <files> <add value="index.html" /> </files> </defaultDocument> </system.webServer> </configuration> when I go to my url it retuens: 500 - Internal server error. There is a problem with the resource you are looking for, and it cannot be displayed. My html file is a simple one btw its just hello world <html> <head><title>My First Web …

Member Avatar
Member Avatar
+0 forum 1

Hello Guys, I hope you are all doing fine. I have a Linq to SQL problem. My entity class is as follows; [CODE]using System; using System.Data.Linq; using System.Data.Linq.Mapping; namespace SilverlightGrid.Web.TableMappings { [Table(Name = "Travel_Meal")] public class Travel_MealDetails { [Column(IsPrimaryKey = true)] public Guid MealID { get; set; } [Column(Name = "Meal_Desc")] public String MealType { get; set; } } }[/CODE] It works fine but I get an error when I query data like so: [CODE] public List<Travel_MealDetails> getMeals() { Settings db3 = new Settings(); // DataClasses1DataContext db = new DataClasses1DataContext("NucleusConnectionString"); DataContext db2 = new DataContext(db3.DBConnect); Table<Travel_MealDetails> meals = db2.GetTable<Travel_MealDetails>(); var …

Member Avatar
Member Avatar
+0 forum 1

Hello people,I hope everyone is well. I am having problems with my connection string. It seems its not detected at all. I am designing a Silverligtht app with a Linq to SQL connection for the data. Here is my code.[CODE] ConnectionStringSettings settings = ConfigurationManager.ConnectionStrings["DataConnect"]; string connection = settings.ConnectionString; DataContext dataContext = new DataContext(connection);[/CODE] and code in web.config file: [CODE] <configuration> <configSections> </configSections> <connectionStrings> <add name="NucleusConnectionString" connectionString="Data Source=ServerName;Initial Catalog=Nucleus;Integrated Security=True" providerName="System.Data.SqlClient" /> <add name="TravelPlannerProject.Web.Properties.Settings.DataConnect" connectionString="Data Source=ServerName;Initial Catalog=Nucleus;Integrated Security=True" providerName="System.Data.SqlClient" /> </connectionStrings> <system.web> <compilation debug="true" targetFramework="4.0" /> </system.web> <system.serviceModel> <behaviors> <serviceBehaviors> <behavior name=""> <serviceMetadata httpGetEnabled="true" /> <serviceDebug includeExceptionDetailInFaults="false" /> </behavior> </serviceBehaviors> </behaviors> …

Member Avatar
Member Avatar
+0 forum 4

Does anyone know if silverlight supports making a menubar like in windows forms?

Member Avatar
+0 forum 0

Hello people,I hope everyone is well. I am having problems with my connection string. It seems its not detected at all. I am designing a Silverligtht app with a Linq to SQL connection for the data. Here is my code.[CODE] ConnectionStringSettings settings = ConfigurationManager.ConnectionStrings["DataConnect"]; string connection = settings.ConnectionString; DataContext dataContext = new DataContext(connection);[/CODE] and code in web.config file: [CODE] <configuration> <configSections> </configSections> <connectionStrings> <add name="NucleusConnectionString" connectionString="Data Source=ServerName;Initial Catalog=Nucleus;Integrated Security=True" providerName="System.Data.SqlClient" /> <add name="TravelPlannerProject.Web.Properties.Settings.DataConnect" connectionString="Data Source=ServerName;Initial Catalog=Nucleus;Integrated Security=True" providerName="System.Data.SqlClient" /> </connectionStrings> <system.web> <compilation debug="true" targetFramework="4.0" /> </system.web> <system.serviceModel> <behaviors> <serviceBehaviors> <behavior name=""> <serviceMetadata httpGetEnabled="true" /> <serviceDebug includeExceptionDetailInFaults="false" /> </behavior> </serviceBehaviors> </behaviors> …

Member Avatar
+0 forum 0

Hello people, I hope everyone is well. I have just started learning silverlight and retrieving data through Linq to SQL. I have a problem with retrieving certain coulums from the table. I can retrieve through an object that retrieves all the columns but I don't want this. i managed to get a string of the columns I want but I cant reference the method from the client.....TIA. Here is my code: [CODE] public class Service1 : IService1 { public List<Contact> getNames() { DataClassesDataContext db = new DataClassesDataContext(); var names = from persons in db.Contacts where persons.FirstName == "Gerhard" select persons; …

Member Avatar
Member Avatar
+0 forum 7

Hey guys does anyone have links to free silverlight 5 eBooks??? I would really appreciate any help.

Member Avatar
Member Avatar
-1 forum 1

Hello I am new to actionscript and i didnt know which forum to post in and may someone plz guide me to the right on. I want to play a simple animation in actionscript 2 and I keep getting an error Here is my code: [code=php] import flash.events*; stop(); dude.stop(); go.addListener(onMouseUp.CLICK,startplaying); function startplaying(event:onMouseUp):void{ play(); dude.play(); } [/code] where go is my button and dude is my movie, i would appreciate any help TIA

Member Avatar
+0 forum 0

hello i am having a little problem, I cant convert a double to one decimal place: here is my code [code=c]for(int i=0; i<marklist.size();i++) { double result=floor((marklist.at(i) /maxmark)); cout<< result<<endl; } [/code] I want result to be one decimal place

Member Avatar
Member Avatar
+0 forum 6

Hello Im new to qt and I have a problem, I am trying to connect a radio button to a signal and a slot that have different number of arguments,I know this is not possible, is the any way to get around it? [code=c]here is my code: void myclass::createbutton() { QRadiobutton* radio= new QRadiobutton("word") connect(radio, Signal(clicked),this,SLOT(checkedA(QRadiobutton))) } void myclass::checkedA(QRadiobutton* radio) { useranswers.push(radio); //where useranswers is a stack } [/code]

Member Avatar
+0 forum 0

Hello I am trying to learn php, I have been looking up information on google, I understand a few things but i need help, I want to get input form an html form and save it to a text file here a snippet of some code I have tried: [code=php]<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"> <html> <head> <meta content="text/html; charset=ISO-8859-1" http-equiv="content-type"/> <title>Test</title> </head> <body> <form enctype="text/plain" method="POST" name="TestForm"/> <p /> Input anything: <input type="text" name="anything" value="Default"/> <br /> <input type="submit" value="OK" name="submit"/> </form> <?php if ($submit=='OK') { $fh = fopen("form_output.txt", 'w'); fwrite($fh, $_POST['anything']); fclose($fh); } ?> </body> </html> …

Member Avatar
Member Avatar
+0 forum 7

hello I need help with loading pages that have flash applications in them, my program works for just html pages, would anyone with qt knowledge plz help. TIA. here is my code: [code=c]#include <QApplication> #include <QWebView> #include <QUrl> #include <QWebSettings> int main(int argc, char *argv[]) { QApplication a(argc, argv); //QWebSettings::globalSettings()->setAttribute(QWebSettings::PluginsEnabled, true); //QWebView *webView; //webView->settings()->setAttribute(QWebSettings::PluginsEnabled,true); QWebSettings::globalSettings()->setAttribute(QWebSettings::JavascriptEnabled,true); QWebView *view = new QWebView(); view->setStyleSheet("background-color:rgb(150,147,88); padding: 7px ; color:rgb(255,255,255)"); view->load(QUrl("file:///home/mary/eLearning/flash/Problem%20loading%20page.xhtml")); view->show(); return a.exec(); }[/code]

Member Avatar
+0 forum 0

helloz I am trying to make a program that calculates the distance between several cities and prints out the shortest distance of them all, the input will come from a textfile e.g 3 3 A 2 1 B 1 2 C 2 2 where the first two numbers are row and columns of the array respectively, A is the name of the city and the two numbers after it are the x and y co-ordinates, I have read in the data I am having trouble looping through the data. Here is what I have done so far: [code=c]#include<iostream> #include<fstream> #include<string> …

Member Avatar
Member Avatar
+0 forum 1

hello everyone I am teaching myself c++ and I was wondering if anyone could give me a site that has some c++ exercises particularly on 2d arrays and string manipulation. thank you.

Member Avatar
Member Avatar
+0 forum 2

hello I am trying to desing a simple rss feed reader, I am using curl to load the source code of a webpage and store it in a string and create an xml file, I then use xerces-c to parse the xml file, this works well but i need to update the feed, Does anyone know how i can read from curl directly to xerces-c without making an xml file? thanks in advance......:)

Member Avatar
+0 forum 0

hello I am trying to design an rss feed reader using xerces-c and im using dom parsing, I am new to this side of programming and everything I know so far is self taught. I can read an xml document that is in my computer but I can't access external ones, so i need a way to connect to the url. thanks in advance.......

Member Avatar
Member Avatar
+0 forum 6

The End.