richosr

Thanks for that, I thought I was going crazy and spent hours trying to figure out why.

I need to make a few changes now that I have changed hosts.

regards

Steve

richosr Newbie Poster

Can anyone tell me why echo intVal($_REQUEST["CustID"]) where $_REQUEST["CustID"] value is 62013300111,

produces 62013300111 on one php Server but on another it produces 2147483647.

I cannot find any logical reason.

regards

Steve

richosr

Many thanks for the speedy reply.

Much appreciated.

Steve

richosr Newbie Poster

Hi,

I want to select all records from a table where the DateAdded field's date and time (Default value Timestamp field) is more than say 3 hrs ago.

eg: something like

SELECT tbldata.* FROM tbldata WHERE (tbldata.DateAdded <= now()-3);

I can get it working with days difference but do not seem to be able to get the hours difference.

If anyone can guide me along the right lines it would be appreciated.

regards

Steve

richosr Newbie Poster

Hi,

I have an issue sending HTML mail with Yahoo Business Hosting.

I developed a web site for a friend to raise quotes for their cleaning company. I tested everything on my two of my hosts and everything works fine, I have created similar mail scripts for other people and they all work fine on other hosts.

When I use this script on Yahoo Business, it sends the mail correctly with the exception of the body of the email which is blank.

This is my send mail code ( The HTML is created as a string earlier on the page as $emailbody.

 $from = $siteEmail;
 $to = $_SESSION['cEmail']; 
 $subject = "Your Quotation from Eco Janitorial Ref: ".$_SESSION['RefID']."."; 
 $message = $emailBody;
 $headers = 'MIME-Version: 1.0' . "\r\n";
 $headers .= 'Content-type: text/html; charset=iso-8859-1' . "\n\n";
 $headers .= "From:" . $from ;

 mail($to,$subject,$message,$headers);

 $from = $siteEmailFrom;
 $to = $siteEmail; 
 $subject = "Copy of Quotation raised on Eco Janitorial Ref: ".$_SESSION['RefID']."."; 
 $message = $emailBody."<br/><br/>(Taxes Included in above quote [&#36;".number_format($row["Tax"],2)."])";
 $headers = 'MIME-Version: 1.0' . "\r\n";
 $headers .= 'Content-type: text/html; charset=iso-8859-1' . "\n\n";
 $headers .= "From:" . $from;

 mail($to,$subject,$message,$headers);

Does anyone know why this would not work on Yahoo, but does everywhere else please?

thanks

Steve

richosr

[QUOTE=richosr;1550364]The Tag option seems to be the solution. Thanks for that.[/QUOTE]

For some reason assigning a tag to each frmD(n) doesn't work, so have used your second option, a hidden, disabled,locked label, and that does work, so thanks again.

richosr

[QUOTE=BitBlt;1550123]Not sure what you mean by "form name". The Name attribute for every child form of the same type will be the same.

One possibility if you're looking for a way to identify the forms is to use the frmD(Index).Tag property and populate it with something useful when you instantiate it. Or, if you're using .Tag for something else, you can always create a hidden textbox control and use that for the same purpose.[/QUOTE]

The Tag option seems to be the solution. Thanks for that.

richosr Newbie Poster

Hi,

I have a dilema, I have an MDI app and I open new forms as
[CODE]
In modBas.bas:

Public frmD(50) As frmDocument

MDI Form Load (frmMain):

Static lDocumentCount As Long
lDocumentCount = lDocumentCount + 1
Set frmD(1) = New frmDocument
frmD(1).Width = 320 * Screen.TwipsPerPixelX
frmD(1).Caption = "Page - Home (" & lDocumentCount & ")"
frmD(1).Show
lDocumentCount = lDocumentCount + 1
Set frmD(2) = New frmDocument
frmD(2).Width = 320 * Screen.TwipsPerPixelX
frmD(2).Caption = "Page - About (" & lDocumentCount & ")"
frmD(2).Show

[/CODE]

I can refer to each form as
[CODE]frmD(Index).SetFocus[/CODE]
[CODE]frmD(Index).Show[/CODE]
etc. no problem.

However I cannot read this name from the form, when I read the name:
[CODE]strFrmName = ActiveForm.Name[/CODE]

I simply get frmDocument (the template document name)

How can I read the frmD(Index) name of the Active Document?

Tried everything I can think of, help much appreaciated.

Steve

[I]"If all you own is a hammer, every problem starts looking like a nail."[/I]

richosr Newbie Poster

Hi,

Please can anyone tell me how to extract the audio track in an mpg or mpeg to an mp3 in vb6?

thanks

Steve

[I][QUOTE]do unto others as you would have them do to you, but they probably won't![/QUOTE][/I]