1,105,594 Community Members

Ubuntu 9.04, Nvidia GeForce Go 7600 - screen flicker

Member Avatar
majestic0110
Nearly a Posting Virtuoso
1,310 posts since Oct 2007
Reputation Points: 187 [?]
Q&As Helped to Solve: 80 [?]
Skill Endorsements: 11 [?]
 
0
 

Hi all, I hope you are well. I am very new to Ubuntu and I am experiencing occasional screen flickers (the monitor will go black for a split second, then resume as normal). Now, I have tried googling for a solution but I have not found one yet that satisfies the issue. As you can imagine, its rather headache inducing. My system is a Toshiba satellite pro p100 PSPAE notebook. I have an nVidia Geforce go 7600 and I have installed the Nvidia server setting utility and have driver 180.44. My distro is Ubuntu 9.04 (jaunty) GNOME 2.26.1.
Things I have tried to do to rectify the flicker include : DISABLING "Force full GPU scaling". I also tried specifying a refresh rate of 60mhz resolution = 1440*900. Although everytime I apply this, the X utility reverts my preference here back to AUTO (only with the refresh rate and resolution: it remembers the disabled "Force full GPU scaling". Sorry about the long post, I am just trying to provide as much information as possible. Thanks for your time and I hope we can sort this together as it is giving my eyes some trouble!!

Member Avatar
cent25
Newbie Poster
1 post since Sep 2009
Reputation Points: 0 [?]
Q&As Helped to Solve: 1 [?]
Skill Endorsements: 0 [?]
 
0
 

I have a notebook with the same video card as you, and installed the nvidia GLX drivers some time ago. I had not noticed this occasional flicker until today, and am unsure what would have changed to cause it.

Member Avatar
majestic0110
Nearly a Posting Virtuoso
1,310 posts since Oct 2007
Reputation Points: 187 [?]
Q&As Helped to Solve: 80 [?]
Skill Endorsements: 11 [?]
 
0
 

Hi there Cent25, I have found a fix for this (at least on my machine). Press alt-F2, then when the Run Application window appears type :

gksudo nvidia-settings

This will run the Nvidia server X utility as root. Now, my monitor supports a refresh rate of 60hz, so I imagine yours does too. Go to X Server Display Configuration and set the refresh rate to 60Hz (even if it says auto, change it). Now apply this, save to x configuration file then restart and you should be ok! I really hope this helps, I know how irritating this flicker is.

Member Avatar
blud
Linux Reject
706 posts since Apr 2004
Reputation Points: 82 [?]
Q&As Helped to Solve: 42 [?]
Skill Endorsements: 3 [?]
Moderator
 
1
 

On that note, I would recommend looking up your monitor specifications, because some support an even higher refresh rate, and over time, that is a setting that becomes very obvious.

Question Answered as of 4 Years Ago by blud and cent25
Member Avatar
regularStranger
Newbie Poster
1 post since Aug 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

So I've had this flicker problem through several Ubuntu versions, and I suspect it's more likely a problem on the Nvidea side, and I'm annoyed that it hasn't been fixed yet. My hack fix involves installing mesa-utils (sudo apt-get install mesa-utils) and then save the file...

# glxhack.sh
glxinfo > /dev/null;
sleep 10;
./glxhack;

Save the file somewhere, make it executable, and run it. Set it to run on startup. Something about the glx system (or something - I'm kind of making up stuff) goes to sleep after a certain amount of time, and when it reawakens it causes a flicker on screen. Running glxinfo repeatedly prevents it from going to sleep. I hope this solves your problem. It has always solved mine.

You
This question has already been solved: Start a new discussion instead
Post:
Start New Discussion
View similar articles that have also been tagged: