1,105,242 Community Members

XP explorer slow opening files

Member Avatar
vickerps
Newbie Poster
7 posts since Jun 2005
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Hi

Having a problem with window XP sp2

When i try to open a file e.g (text file) windows XP takes about 30 seconds to opening the file. Also if i try to right click on any file the contents menu also take about 30 second to appear.

The problem only seem to be with files; folders opening normally and if i right click on my computer or network places for example the contents menu come back straight away.

I have install microsoft antispyware on and the latest dat of mcaffe on to see if there where and viruses, trojans or spyware on my system but all results came back clean. However this machine doesn't have any internet access anyway so i expect there to none.

anyone got any ideas

Member Avatar
jingalala
Light Poster
29 posts since Jul 2005
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Are you running low on space? You could try running a disk clean up and then defragment after chkdsk. If its to do with junk or a fragmented drive, this would help. Also a general opinion is that McAfee hogs system resources. u might think of adding more RAM if ur running memory intensive programs.

Member Avatar
vickerps
Newbie Poster
7 posts since Jun 2005
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Are you running low on space? You could try running a disk clean up and then defragment after chkdsk. If its to do with junk or a fragmented drive, this would help. Also a general opinion is that McAfee hogs system resources. u might think of adding more RAM if ur running memory intensive programs.

Nope disk space is fine and system processes are fine. I wish it was that simple.

I have been investigation and it is the DCHP & DNS service in windows XP. If i disable these services the pc spring into life but as soon as i enable them it pauses like i discussed in my earlier mail. I have notice the pause is pretty the same amount of time 25 second to be exact.

Member Avatar
chrisbliss18
Posting Shark
902 posts since Aug 2005
Reputation Points: 26 [?]
Q&As Helped to Solve: 24 [?]
Skill Endorsements: 0 [?]
 
0
 

You can safely leave the DNS Client service off. This service creates problems with cached DNS issues and slows down more than it speeds up IMO.

You should be able to turn off the DHCP service if you manually configure all your network connections and you connect to the internet through a gateway that supplies your IP address (such as a router).

Member Avatar
jonathanrs
Newbie Poster
2 posts since Jun 2007
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I am experiencing the slow file access problem in Windows Explorer. I tried disabling the DHCP service, and VOILA! file access immediately went to normal (fast). However, when I turned it off, I lost my internet connection. I use a cable modem with a Linksys Router, and I thought the router supplied the IP address, etc., as chrisbliss18 mentioned. How can I configure my system so I can leave DHCP off yet still have an internet connection?
Thanks!
Jonathan Smith

Member Avatar
chrisseke
Newbie Poster
1 post since Aug 2007
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I am also experiencing the same problem, opening of files is very slow and when I disable DHCP or give myself a fixed IP, or disconncet the LAN the files open normally...

Has anyone got any idea of what this could be ?

Thanks a lot !

Member Avatar
aitortilla
Newbie Poster
1 post since Sep 2007
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I have the same problem. But I have noticed that when I deactivate my network card time to open any file fall drastically. I am searching why it occurs.

Member Avatar
tancomputerlab
Light Poster
31 posts since Dec 2006
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Seems like a pain, but I had a similar issue last year and I just formatted my hard drive and my computer's worked like new ever since (got it in 01)

Member Avatar
lmpicard
Newbie Poster
2 posts since Jan 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Thanks for the tip. I have been experiencing very slow file opening on my quad core machine running XP. Disabling the DNS client sped up much of the file openings but Office 2000 still seems slow and also slows down with repeated accesses after a reboot.

Disabling the DHCP client did nothing positive and added nothing to the speed of opening.

I still do not understand why or how the DNS client should interfere with local file opening.

Member Avatar
lmpicard
Newbie Poster
2 posts since Jan 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I discovered that if I deleted an off line network printer the Word 2000 files open briskly.

I might suggest that you delete any unnecessary printers from your local copy of Windows XP.

Turning the network card off also lowered the response time. I suspect that Word is looking for a response from all the printers within its reach and does not open until the last one times out.

Member Avatar
MWilliams
Newbie Poster
2 posts since Apr 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 1 [?]
Skill Endorsements: 0 [?]
 
0
 

I had the same problem and found this solution:
I had a file association which referenced a program on another computer on the network that no longer existed. I found some more information here: http://windowsxp.mvps.org/rcdelay.htm
I actually ended up just searching the HKEY_CLASSES_ROOT for "\\" and quickly found the offending key to delete.

Member Avatar
pepo930
Newbie Poster
8 posts since Jan 2009
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I have a problem like that 2! When try opening folders they open fast but when I try opening a program it opens after 5 minutes .When i try opening task manage he opens after 5 minutes and the CPU usage is at 5% only! Every thing is slown down by 5 minutes It's like windows doesn't reacts!

Member Avatar
Frank Wallis
Posting Whiz in Training
217 posts since Jul 2008
Reputation Points: 0 [?]
Q&As Helped to Solve: 15 [?]
Skill Endorsements: 0 [?]
 
0
 

I am experiencing the slow file access problem in Windows Explorer. I tried disabling the DHCP service, and VOILA! file access immediately went to normal (fast). However, when I turned it off, I lost my internet connection. I use a cable modem with a Linksys Router, and I thought the router supplied the IP address, etc., as chrisbliss18 mentioned. How can I configure my system so I can leave DHCP off yet still have an internet connection?
Thanks!
Jonathan Smith

jonathan,

if you want to have internet access by leaving the DHCP Service off in your computer, then you have to make your own personal network and join this computer to that network and assign it a static TCP/IP configuration which is a lengthy proceedure.

Unfortunately most of the internet services donot provide static TCP/IP configuration to there clients . If you want to have internet service then you should leave the DHCP service enabled in your computer.

I donot think this disabling of DHCP and DNS Services in your Computer will solve the problem of file opening . Neither it is a problem of low disk space in your computer or fragmentation.

If it was an issue of fragmentation and low disk space then
all the files would have taken long time to open.

Member Avatar
pedrospinto
Newbie Poster
1 post since Mar 2009
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Hi guys,

I work in a company that just migrated all its units to a new domain.

After this migration some users started to complain about how slow their computer were while opening any file, even a txt notepad.

After some investigation we discovered that the registry of the users affected contained references to servers addresses that no longer existed. After deleting the invalid keys and folders on the registry the issue was solved!

This is also valid for the rigth mouse click button slowness issue.

What causes this issue is, when opening a file the program (notepad, excel, etc) search the network for those invalid references, that can be add-on's, printers or any other. When scanning the network it takes about 25 seconds for the process to fail, thus only opening the files after this failure.

Regards

Pedro Pinto

Member Avatar
amrosalah
Newbie Poster
1 post since Mar 2009
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

if any one is having this problem still

try this
i tried it and worked for me
http://windowsxp.mvps.org/rcdelay.htm

Member Avatar
ryno83
Newbie Poster
1 post since Mar 2009
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I had the same problem and found this solution:
I had a file association which referenced a program on another computer on the network that no longer existed. I found some more information here: http://windowsxp.mvps.org/rcdelay.htm
I actually ended up just searching the HKEY_CLASSES_ROOT for "\\" and quickly found the offending key to delete.

This trick solved my slow opening files problem. I got 2 files extension on another computer in HKCR. After deleted them, my files opening was realy quick and the overall system was faster... Thank you very much !

Member Avatar
abhi_trips
Newbie Poster
1 post since Apr 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I was having the same problem and did the following couple of things that solved the problem.
1. On Windows Explorer click on Tools -> Folder Option
2. On folder options dialog click on View Tab
3. Under Advanced settings section unchecked the item "Automatically search for network folders and printers"
4. Under Folder Views section click on button "Apply to All Folders"
5. Click Apply
6. Click Ok
7. Close windows explorer and restart it

Hope it works for you guys as well !!
Cheers,
Abhishek Tripathi

Member Avatar
Diljan
Newbie Poster
2 posts since Dec 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Hi All, I have found the solution to the problem of slow browsing of local hard disk contents..Go to folder option>>>uncheck "Automaticlly search for network folders and printers". This worked for me..Thanks to All
rgrds.

Member Avatar
Diljan
Newbie Poster
2 posts since Dec 2010
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 


Yes Abishek is right...Thanks to him

Member Avatar
daniwebsantiago
Newbie Poster
2 posts since Mar 2012
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Turning off DNS Client fixed it for me! :)

You
This article has been dead for over three months: Start a new discussion instead
Post:
Start New Discussion
Tags Related to this Article