1,105,546 Community Members

External hdd doesn't show

Member Avatar
nishad_forums
Light Poster
29 posts since Jul 2011
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

hi,
i m using windows 7(64-bit). I have external hdd-100GB. But it doesn't show up in my windows. I have tried it in another pc(& in my desktop before i installed this windows) and it works fine, so it must be a problem with my windows. I have changed from IDE mode to AHCI mode to check but it's still same. It isn't working. It doesn't show up in Device manager or anywhere , windows simply doesn't catch it. I have tried different usb ports.

please help me!!!

i m in big trouble because of this.

thanks in Advance.

Member Avatar
pjhutch
Light Poster
32 posts since Nov 2005
Reputation Points: 0 [?]
Q&As Helped to Solve: 7 [?]
Skill Endorsements: 0 [?]
 
0
 

How about using Disk Manager (diskmgmt.msc) and here you can assign a drive letter to it so that you can see it in explorer.

Member Avatar
flagstar
Practically a Master Poster
615 posts since Oct 2009
Reputation Points: 111 [?]
Q&As Helped to Solve: 63 [?]
Skill Endorsements: 0 [?]
 
0
 

Are other USB devices can be detected on your computer? If yes, then of course there's a problem either the USB external cable or Windows itself...

Member Avatar
nishad_forums
Light Poster
29 posts since Jul 2011
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

How about using Disk Manager (diskmgmt.msc) and here you can assign a drive letter to it so that you can see it in explorer.

thanks for the advice but it didn't work.

Member Avatar
nishad_forums
Light Poster
29 posts since Jul 2011
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Are other USB devices can be detected on your computer? If yes, then of course there's a problem either the USB external cable or Windows itself...

Yeah, any other usb devics are working fine, no probs with them. I have checked the cable, it's fine also. I think it's the windows that's making the prob. but thanks.

Member Avatar
nishad_forums
Light Poster
29 posts since Jul 2011
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

the problem is solved. I just changed from AHCI to IDE and it detected the HDD but it isn't showing my CD-ROM. So, i actually don't know what happened.

The problem is solved but if anyone can help me understand why it happened and why it's not showing my cd-rom, It will be appreciated.

Member Avatar
flagstar
Practically a Master Poster
615 posts since Oct 2009
Reputation Points: 111 [?]
Q&As Helped to Solve: 63 [?]
Skill Endorsements: 0 [?]
 
1
 

Your cd-rom might actually use SATA cable (red thin cable) instead of IDE cable (usually white and wide cable) so if you set yours from AHCI (Sata) to IDE, most SATA hardware will not work...

Usually setting up ACHI or IDE just to detect an external HDD with USB port seems unlikely to happen because external can run in both mode without any problem.

To confirms things up, you can try with another external (if you had another one) and test it on your computer. If it can't detect yours, then that means you have a missing driver that can let external to run in AHCI mode.

Question Answered as of 2 Years Ago by flagstar and pjhutch
You
This question has already been solved: Start a new discussion instead
Post:
Start New Discussion
View similar articles that have also been tagged: