1.11M Members

Nintendo DSi not getting an IP address from wireless router.

 
0
 

My son wanted an Nintendo DSi, so he can play games with his friends.

The Nintendo can't.won't connect to the Internet.

I emailed Nintendo support. Their advice was for me to enable DHCP. I checked that and it is enabled.

Next on the list is to configure the Nintendo manually.

I have to enter an IP address, subnet mask, default gateway, primary and secondary DNS servers.

Presumably I have to dedicate an IP address to the Nintendo in the router.

How do I dedicate an IP for the Nintendo and where do I get the subnet mask, etc info.

Thanks

 
1
 

I would stick with DHCP and go through the settings to make sure the wireless radio is on.

If you want a static IP that is likely to work, you could try 192.168.1.200 with net mask 255.255.255.0

That's shooting in the dark though. The sure bet is to get some info from your router.

The problem is that no two devices on a network can have the same address. Routers with Dynamic Host Configuration Protocol enabled will assign an address to devices to be sure there are no conflicts (duplicate addresses). If you assign an address to a device(static) and DHCP has not already assigned it, most routers will just take note of that and not assign that address to another host(device). However, If DHCP assigns the address to a host (PC, Printer, DS, etc.) and it is the same address you assigned, when you power on your device, it will not be able to communicate with the router.

Some hosts need a static (unchanging) address. To accommodate static addresses and DHCP, your router will likely have a setting for the range of addresses DHCP can assign. Static addresses should be selected from outside that range.

Post here if I made mud of that.

Good Luck

 
0
 

I am going to need the idiots "step by step" instruction to make a dedicated IP address, then need step by step instructions to find the info I need, to enter into the Nintendo.

My last router was easy to use. I knew where I could dedicate IP addresses and enter mac addresses in, but this D-Link router isn't as user friendly.

 
0
 

need the idiots guide....

 
1
 

The DSi is where you would set up the ip address. I don't have one, so another member of the forum will have to help with that.

Here's the basics which I hope you know. http://www.ehow.com/how_4890413_connect-nintendo-dsi-internet.html

You may be able to set the D-link to "Static DHCP" which means that it will assign an IP automatically, but it will always assign the same one to the same device. Most routers do not have this feature though.

The best thing to do is to gather information. Do you know how to access your routers settings? Do you know how to access your DSi internet connection settings? Is security set up on your router? If so what type? Do you know your SSID? What model is you d-link?

For default router passwords: http://www.phenoelit-us.org/dpl/dpl.html

For dsi setup: http://www.youtube.com/watch?v=3LBmWNVgMZo&feature=related

 
0
 

The DSi is where you would set up the ip address. I don't have one, so another member of the forum will have to help with that.

Here's the basics which I hope you know. http://www.ehow.com/how_4890413_connect-nintendo-dsi-internet.html

You may be able to set the D-link to "Static DHCP" which means that it will assign an IP automatically, but it will always assign the same one to the same device. Most routers do not have this feature though.

The best thing to do is to gather information. Do you know how to access your routers settings? Do you know how to access your DSi internet connection settings? Is security set up on your router? If so what type? Do you know your SSID? What model is you d-link?

For default router passwords: http://www.phenoelit-us.org/dpl/dpl.html

For dsi setup: http://www.youtube.com/watch?v=3LBmWNVgMZo&feature=related

Hi. Many thanks for your reply.

I can set the DSi up, if I know what info to enter into the DSi.

My router is a D- Link DSL-2640R. I can get into the settings and have been there a few times, but I can't find where I should enter a mac address to a static IP....to pair the bits of info.

I have WEP security on my router and the DSi accepts WEP passwords.

 
0
 

Since reading the helpful reply. I found where I could enter the mac address...however when I enter the MAC address if the DSi, the router refuses to accept it. Could that be possible?

 
0
 

I get an invallid MAC address.

 
0
 

A MAC addres is different from a IP address.

In the DSi, use IPv4 Address: 192.168.1.200 and the subnet mask: 255.255.255.0

It should ask for your WEP encryption key, then you should be connected.

You should not need to make changes to your router.

 
1
 

Is your encryption compatible?

E.g my router defaults to WPA2-PSK/AES, but my PDA doesnt support that, only WPA-PSK/TKIP or WEP.

 
0
 

Hi jbennet

I am asking myself the same question about if my router is compatible with the DS. The DSi asks for a WEP key and my router is uses WEP encryption.


techsheaven
I know that the MAC address is different to the IP. On my router, I am expected to enter my MAC address in with the static IP address, which I did manage to find. My mistake was that I was not waiting for the drop down menu to refresh after I selected the DS Mac address. However, I did manage to get a IP tagged to the MAC address of the DS on the router settings. Sadly the DS could not connect to the Internet. When I try to save the static IP and gateway on the DS, the DS tells me that the info is incorrect. I tried using spaces and zero's at the 168.1 type (single digit) of entries but it made no diffrence. The DS has 3 spaces for each group of 3 numbers.

Regarding the IPv4. Is that a setting? I have looked for that but I can't seem to find any such thing on the DS.

I have now set my router back to automatic IP assigning for everything. Yesterday everything was on a static IP.


When I tell the DS to look for wireless networks. It finds my router. I choose my router, and enter the WEP key and choose save settings.

On the DS, I have set the "obtain IP automatically" to "yes. "Obtain DNS automatically" to "yes" and "MTU" to "1400". I choose "begin connection test" and the DS does it's test.

At the end of the test, I get "unable to obtain an IP address. Check your access point settings..... Error code: 052000-2".

I emailed the Nintendo support...below is a copy of their reply.

Dear Customer, thank you for your email.

The error code range 52XXX normally refers to a problem with the IP settings on your router. Below are the possible reasons why this is not being accepted, along with our recommendations to troubleshoot the problem.

There is a problem with the access point settings
We recommend that you manually enter your IP Address, Subnet Mask, Default Gateway and your Primary and Secondary DNS servers in to your console. You should be able to retrieve these items from your ISP (Internet Service Provider) if you do not know them already.
Also try enabling DHCP on your router, this allows the router to distribute IP addresses to all connected devices.
There is a problem with the wireless channel or mode being used
Try changing the channel on your router to either Channel 1 or 11, as these would not be affected by any similar devices in your area using the same channels. Your router documentation should explain how to do this.
Some routers utilise the newer wireless N standard which generally create unstable connections, we would recommend switching your router to use wireless B and G in Mixed Mode.
Your wireless encryption key (also known as WEP or WPA) is incorrect.
Try ensuring that you are using Key 1 in your WEP key list.
Check that these settings are correct by consulting your ISP or Router Manufacturer

 
0
 

Thanks for the replies so far. I appreciate the offers of advice.

 
0
 

They are not going to say there is anything wrong with the DSi settings. When they say "The error code range 52XXX normally refers to a problem with the IP settings on your router." We translate that to mean, "The settings in the router and the settings in the DSi are incompatible."

When they say "We recommend that you manually enter your IP Address, Subnet Mask, Default Gateway and your Primary and Secondary DNS servers in to your console," we translate that to, "The DSi can not reach the DHCP server.

Whent they say, "There is a problem with the wireless channel or mode being used, we think, "Someone is using a device that operates on the 2.4Ghz range - the same range as the router. You can "Try changing the channel on your router to either Channel 1 or 11," but often you will still have connection issues. Disreguard the part that says, "these would not be affected by any similar devices in your area using the same channels," it simply is not always true. Wireless N operates on the 5Ghz range. Unstable? I don't know. B and G in Mixed Mode is best for now. Use Key 1 in your WEP key list (log into the router and verify that you have the correct key - #1 on the list!

In the Setup tab, under Wireless Setup, change the SSID to something you recognize so you can be sure you are not connecting to a neighbor's router with the same defauls SSID.

Set the chanel to 1.

Set the 802.11 Mode to "Mixed 802.11G and 802.11b.

Set the transmission rate to Automatic.

Verify the 1st Key generated againsk the one you have been trying in your DSi.

Click on Apply Settings.

When it verifies that the settings were suseccful, clasoe the window and unplug your router. Wait at least 20 seconds and plug it back in.

Once the router is back up, Verify that your PC can connect to the internet.

Setup the DSi. At the Setup screen, tap Nintendo Wi-Fi Connection Settings, tap one of the Connection slots, tap Search For An Access Point, and select the SSID you just created.

You should be connected. If the test fails, let us know what code you see.

 
0
 

Although this is an old thread, the correct answer was never posted and the same issue just about drove me crazy this evening. All my searches for a correct answer came up empty, but I finally figured it out. Here's the solution:

Open your D-Link router's configuration page and...

Under Network Settings, DHCP Server Settings, UNCHECK the option “Always Broadcast”. This allows the DS, DSi, or 3DS (in DS mode) to get an IP address from the D-Link router.

 
0
 

I know this is an old post, but I would just like to answer the question.
(This worked for me, and I cannot assure that it will for everybody else)

Go to Command Prompt and type in: ipconfig/all
This will bring up a bunch of information on your internet connection. This should include the ip, subnet mask, gateway, and dsn of your router. Simply put all this into the DSi

You
This article has been dead for over six months: Start a new discussion instead
Post:
Start New Discussion
View similar articles that have also been tagged: