1.11M Members

Two NIC’s one problem!

 
0
 

Good afternoon all, I have a PC running Win. 7 I have one on board Ethernet (DHCP). Today I installed another NIC; it is configured to run Static. The Static NIC works great but the DHCP on board NIC cannot connect to the internet. Any ideas would be great, Thanks.

 
0
 

are both NICs using the same gateway? what IP is the DHCP card pulling?

 
0
 

Hello,

Depends on what subnets you are using on each NIC and which NIC you want to be the connection to the internet. The GATEWAY IP is the address the system uses to reach computers not in your subnet (the internet). You can only have one gateway, just like you can only leave your house by one door at time you can only leave your subnet via one route at a time. If you are running a private backbone then dimply do not assign a gateway address to the NIC on the private network.

 
0
 

sorry I should have included that part, the static card are convected to a couple of instruments. The other (DHCP) is to the local network. Thanks!

 
0
 

Make sure you only have one default Gateway configured. You should have only one default gateway when you have more than one NIC installed. Remove the static default gateway configuration from the NIC connected to the "instruments" network. The gateway should be defined on the DHCp enabled NIC, in this case.

If you have two gateways assigned, one gateway is favored over another, based on metrics. If the "intstruments" NIC has a higher preference, when your computer needs to communicate with a remote system, packets will flow through that NIC, rather than the other.

Aside from the gateway, review your other IP settings to ensure that your subnet mask is correct on both NICs. Also, DNS settings are generally only required on one NIC.

 
0
 

I only have the one NIC (DHCP) that has a gateway, the static gateway is blank. If I diable the static NIC the other NIC(DHCP) connects to the internet fine, turn the other one back on and nothing, although with both cards enabled I can still connect to my instuments via the static card no problem.

 
0
 

Enable both and post a "IPCONFIG /ALL" and a "ROUTE PRINT"

You
This article has been dead for over six months: Start a new discussion instead
Post:
Start New Discussion
Tags Related to this Article