1,105,242 Community Members

Mouse and keyboard failing on one computer and not the other

Member Avatar
ButterflyChaser
Newbie Poster
6 posts since Jun 2005
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

Forgive me if this post doesn't belong here, as it may be a more serious problem than just the keyboard and mouse not working.

I have two computers, one monitor, one keyboard, and one mouse shared by two computers on a kvm switch. One is a windows xp pro, and the other windows 98.

History on the windows 98 (long story even shortened like this):

- Smelt burning a while ago, found out the power supply fan died
- had my mom replace the power supply
- motherboard did not appear to be damaged (both of us were concerned it could have overheated)
- I noticed that just bumping the computer slightly would turn off the machine.
- other than that it was working fine.
- I was browsing on the internet particulary Deviant Art and Neopets to browse my "friends" galleries.
- Computer froze up completely while on Deviant Art. (had happened before, and along with the monitor going blank with the yellow light indicating no signal)
- restarted and it froze up on "Verrifying DMI Data"
- mom tweeked stuff in the bios
- after severall scandisks and scandisk freezeups later it started up windows saying it found new hardware, only that everything it found was "new hardware" including the bios, motherboard, video card, and a load of other things along with windows 98 itself.
- restarted and it read the hard drive fine. I started to back up my files.

- noticed ever since then it would still freeze up randomly even more so than it did before the power supply was replaced.

- and just now today two new things happened:

keyboard and mouse fail to work (on that computer, not the one I'm using now :P )

- After the normal beep on boot-up I hear one or two faint short beeps a few seconds appart

- no apparent errors show up on display when booting up, or it goes past them too fast to read.

- windows after going though scandisk tells me it cannot detect a mouse.

- Now I have gotten past the mouse error by plugging in a serial mouse. The serial mouse works ok , but not the ps 2 one.
- and for the record I doubt the kvm is to blame, though it could have an issue. I tried plugging the mouse into the computer without the kvm switch. Still couldn't read the mouse.

I wish I knew what to do and keep this computer running. I like it mostly for sentimential value because it has some computer games and programs on it that are not so compatable with the newer operating systems.

Or am I going to be finding myself into more trouble, perhaps the need to get a new computer soon? It'd be interesting to know what is going on with it at least.

Member Avatar
DMR
Wombat At Large
6,809 posts since Dec 2003
Reputation Points: 152 [?]
Q&As Helped to Solve: 380 [?]
Skill Endorsements: 11 [?]
Team Colleague
 
0
 

All in all, from what you've posted it does sound like the motherboard was damaged when the power supply went south.

- The BIOS beep codes you hear might help isolate the problem. Please be more precise about the number and duration of beeps you hear, and tell us the make and vesion of your BIOS (beep codes vary between BIOSes).

- Open the computer and firmly reseat all boards, cables, and connectors.

- Give us the make/model of your computer. It may have built-in, low-level diagnostic utilities which can help us troubleshoot/test your hardware components.

- Remove all uneccessary components (network card, CD-ROM drive, sound card, etc.) one by one. Boot the computer after removing each and see if there's any change in the symptoms.

- If you have more than one RAM module, boot the system with only one module at a time installed. If the system exhibits problems only when you have a specific module installed, that module is probably fried.

- Reset your BIOS: unplug the power cord from the comuter and remove the CMOS battery (small, flat, watch-type) from the motherboard. Leave the battery removed (and te computer unplugged) for at least 30 minutes or longer before reinstalling it.

Member Avatar
ButterflyChaser
Newbie Poster
6 posts since Jun 2005
Reputation Points: 0 [?]
Q&As Helped to Solve: 0 [?]
Skill Endorsements: 0 [?]
 
0
 

I'll give that advice to my mom who helped me get the computer and knows a little more than I do about it.

I did get the mouse and keyboard to work. Turned out to be a rather simple thing. :rolleyes: At some point the mouse fails to show up so I go and unplug it and plug it back in ever so often to get it to work. I accidentally switched the keyboard and mouse plug. I guess it's an easy mistake to make considering the setup of my room and where I have the computers makes reaching to the back very uncomfortable and uneasy. And a couple of the cords don't have the color coded ends.

But something did have to make it not work for me to have switched the cords to begin with, because everything was going fine until that point where I got frustrated.

The computer is still freezing up on me. Just now I had to restart it because some kind of blank error window popped up. Judging on the size of the window it was probably a GPF or a low memory error.


As for the make-up of the computer, it's a custom built AMD Duron. AuthenticAMD AMD Duron(tm)
256.0 mb ram

Award Bios (v6)

Usually starts up with a loud (very loud if I have the speakers on) medium length beep right before I see the Award Bios thing at the top and where it says suggested DRAM is 133. I don't really know what to compare it to as for length. I'll just say medium. I've never heard any super long beeps. When the keyboard and mouse failed, the additional beeps were very short and quiet. If there were two beeps they were spaced about two or three seconds between and beeped no more after that.

Though if I restart it occasionally I hear no beeps at all before it goes into its normal routine.

Motherboard brand I don't know either.
It uses VIA onboard sound which is built into the motherboard I think. (sound doesn't work without manually setting to game device, possibly because of a driver conflict) I'll have to ask my mom. I think she has the vital data and the year, make, and everything else.

I know it was made around 2001-2002. I guess it's fairly old as far as computers go. Parts are probably handme-downs from other computers or cheap misc parts. The guy who sold it to us is out of business and gone. :rolleyes:

Features it has. I can hit the del button to view settings when it boots up.

Says the cpu is about 114 degrees F
system 100 degrees F

Right before windows starts it shows briefly something about a file in the c directory and desktop. Please forgive me for not typing it exactly. It only flashes it for less than a second.

C:SETPATH/WINDOWS/COMMAND/PROGRAMFILES/EXECUTIVEPATH/DESKKEEPER

(something like that. Have no clue what it is and why it shows up even for a 30th of a second or so)

Booting up windows is sometimes is slow. It just froze up after windows loaded with applications: Zlclient, Mxtask, and Memcheck not responding upon one boot up. after closing the Ctl+alt+ delete, the freezeup stopped and the applications started running. It's not wanting to shut down or restart atm. I have to end a task to get to finish the process.

Member Avatar
DMR
Wombat At Large
6,809 posts since Dec 2003
Reputation Points: 152 [?]
Q&As Helped to Solve: 380 [?]
Skill Endorsements: 11 [?]
Team Colleague
 
0
 

Award BIOSes have relatively few beep codes, but a single longish beep is supposed to be indicative of a problem with RAM. Keep in mind though that many computers normally emit a single beep at startup (although that beep is usually of a shorter duration).

- Given that you're having random crashes, I'd check out the RAM first:

1. Open the case, fully remove all RAM modules, and examine the modules and the RAM sockets on the motherboard for damage. If all looks good, firmly reinsert the RAM, reboot, and see if the system performs any better.

2. If not, you should "stress test" the RAM with the memtest86 utility, which is freely downloadable here. Memtest is a stand-alone program which runs off of a bootable floppy or CD, meaning that Windows isn't involved in the testing processs at all (memtest is Linux-based).

I'd suggest letting memtest run for 4+ hours for the most thorough results.


- Your CPU and case temperatures are fine.

- The "SETPATH" line you see flash by is coming from the DiskKeeper (not DeskKeeper) utility. DiskKeeper adds that line to your autoexec.bat file; to see it appear on the screen at boot is normal.

You
This article has been dead for over three months: Start a new discussion instead
Post:
Start New Discussion
Tags Related to this Article