1,105,271 Community Members

OpenGL error

Member Avatar
lewashby
Posting Pro
559 posts since Oct 2009
Reputation Points: 0 [?]
Q&As Helped to Solve: 1 [?]
Skill Endorsements: 0 [?]
 
0
 

Note that I am using MinLinux. I'M trying to launch Team Fortress 2 from Valve's Steam and I'M getting the following error.

Required OpenGL extension "GL_texture_compression_s3tc" is not supported. Please install S3TC texture support.

I checked my Synaptic Package Manager and I already have the following two packages installed when I enter s3tc into the text field of the SPM.

libtxc-dxtn-s2tc-bin
&
libtxc-dxtn-s2tc0

The only one listed as not installed was libtxc-dxtn-s2tc-dev

Any ideas? Thanks.

Member Avatar
rubberman
Senior Poster
3,984 posts since Mar 2010
Reputation Points: 513 [?]
Q&As Helped to Solve: 500 [?]
Skill Endorsements: 87 [?]
 
0
 

It may be a S3TC version issue, but you should install the dev package as well, especially if you built Steam from source.

You
This article has been dead for over three months: Start a new discussion instead
Post:
Start New Discussion
Tags Related to this Article