Daniel_46 0 Newbie Poster

I'm trying to compile an old project in Borland C++ Builder 4. I have a working exe and the source files for that, therefore someone must have managed to compile it earlier. However, when I open the project, check if the project has all the necessary files in the resources and try to compile it, I keep getting the following linker error:

[Linker Error] Unresolved external '_fastcall TMapperForm::Button1Click(System::TObject*)' referenced from ...\Unit1.obj

I can see that it cannot find an object in the library but I am not sure how to resolve it, because the obj file with the same name as the main cpp file is in the same file as the other files of the project and seems fine.

I have looked through the answers provided here for similar linker errors but none of what these have suggested worked for me. I have already tried the following:
•Adding the .obj file to the Project Resources.
•Trying to add pragma lines manually such as #pragma link (Unit1.obj)
•Making sure that in Project>Options>Directories the right Include and Library paths were selected.
•Checking if all the packages have been added.

None of this seems to work. I am fairly new to C++ and C++ Builder, so I am hoping that it is something trivial.

Has anybody seen this particular error?

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.20 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.