0

Not too sure which specific router settings can fix that but I'm sure that DMR knows something about those settings.

Could you offer any assistance DMR?

0

Unfortunately, without an English version of the manual, I'm kind of stuck. Every router's built-in configuration utility uses slightly different terminology, layouts, etc., so I can't really point you to anything specific because I can't read that particular router's documentation.

I've got to go to work right now, but I'll see if I can turn up anything more when I get back home this evening.

0

Sorry, I stumbled a bit late over this thread:
I speak german. (Argh...I've blown my cover...:mrgreen:) Of course I need to know what type of router is in question and knowing what the current settings of yours are would help, too. When I know which router you are using, I can download a manual and tell you from which of your setup screens we (probably) need screenshots.
Furthermore, I can browse german user forums for similar experiences with this specific ISP's hardware. What is your ISP?

Shot in the dark:
If some websites cannot be opened, sometimes the standard settings for MTU / RWIN do not match the needs of your type of internet access. Please (try to) go to http://www.speedguide.net and select "TCP Analyzer" on the left side of the screen. C+P the report here.

0

Sorry, I stumbled a bit late over this thread:
I speak german. (Argh...I've blown my cover...:mrgreen:)

And we're oh-so-glad you did. :D
If you can shed any licht on the subject, it would be much appreciated.

0

Hi, it's great to hear that you'll be able help!
We are using a 'T-Online Sinus 154 DSL Basic SE Router' with the ISP 'T-Mobile'. The laptop is connected to the router via a LAN cable.
Let me know which settings and screensavers you require and I'll get them to you as soon as I can.
Below are the results from the 'TCP Analyzer' report:

TCP properties for IP = 84.136.232.168 ()
Browser/OS = Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; FunWebProducts; SV1; .NET CLR 1.1.4322)

TCP options string = 020405a201010402

MTU = 1482
MTU is somewhat optimized for broadband. If you're not on a PPPoE DSL connection that limits packet size, consider increasing your MTU
to 1500 for optimal throughput.

MSS = 1442
Maximum useful data in each packet = 1442, which equals MSS.

Default TCP Receive Window (RWIN) = 65535
RWIN Scaling (RFC1323) = 0 bits
Unscaled TCP Receive Window = 65535
Note: TCP 1323 Options need to be enabled for RWIN over 2^16 (65535). Windows 9x might also need the MS Vtcp386 fix.
For optimum performance, consider changing RWIN to a multiple of MSS.
Other RWIN values that might work well with your current MTU/MSS:
507584 (MSS x 44 * scale factor of 8)
253792 (MSS x 44 * scale factor of 4)
126896 (MSS x 44 * scale factor of 2)
63448 (MSS x 44)

bandwidth * delay product (Note this is not a speed test):
Your TCP Window limits you to: 2621.4 kbps (327.675 KBytes/s) @ 200ms
Your TCP Window limits you to: 1048.56 kbps (131.07 KBytes/s) @ 500ms

MTU Discovery (RFC1191) = ON

Time to live left = 121 hops
TTL value is ok.

Timestamps (RFC1323) = OFF

Selective Acknowledgements (RFC2018) = ON

IP type of service field (RFC1349) = 00000000 (0)

Danke fur ihre hilfe Xpenetrator! :cheesy:

0

Hi dangeo,
kein Problem, gern geschehen! :cheesy: The first idea for your kind of trouble is MTU (Maximum Transmission Unit). Some servers don't answer if they get too big packets, to make it incredible short. I hope DMR doesn't mind if I try to shoot the trouble right away. T-Online uses PPPOE (1492), I found reports that values as low as 1472 work best and the router's default is 1482. This means this may or may not be the problem. Since you can't access certain (not random) sites, I would bet on MTU first. We can check this pretty fast and simple:

Open another browser window/ tab on Mozilla. C+p in the URL box:
http://192.168.2.1

Now a wonder of german software engineerink should pop up in da haus and ask you for a password: If nobody changed that previously, the password is "0000" (4xZero)

On the left side of the router's homepage is the navigation frame. Click on "Netzwerk" (under "Konfiguration"). Another navigation list appears in the middle under "Netzwerkeinstellungen". Select "Internetzugang". Then get sure that the "T-Online" -button is highlighted.

Search this screen for "MTU" now (near the bottom).
If the MTU box doesn't say 1454, please post the value here first.

If it's 1454, change it to 1444 or lower (in a second attempt) and click on <Speichern> (Save), reboot the router (Left navigation frame: "Hilfsmittel") and (to be on the safe side) your computer and then try to access one of the sites that don't load.

If it was 1454 but changing it didn't help, then setting the MTU in the router was maybe the wrong end to set it and we can try to dive into the windows registry instead. Please reset it to the original value of 1454 then. I found some more things to try if everything fails. If this helps, tell me how broad your broadband is and we can try to optimize that a bit. Since I understand next to nothing of what I wrote here, I ask for correction and assistance. Good luck!

Edit: Here,s where I found the german manual (I'm afraid no english manual exists.):
http://www2.hilfe.t-online.de/dyn/c/24/28/10/2428102.html
Tell me what you want to find and I will try to guide you...

0

Hi, thanks for the detailed response! Whilst scouring the internet for answers previously I have heard that adjusting the MTU has worked for some people so you could be on to something. However when I checked the MTU it was set at 1492, so I thought it would be best to check with you first as to which values I should adjust it to.

0

However when I checked the MTU it was set at 1492, so I thought it would be best to check with you first as to which values I should adjust it to.

Well done. That means someone (do you have the T-Online Software running?) tried already to tweak the MTU in the client (Windows standard=1480, your current MTU=1482) and set the router to 1492 since the router's default is 1454 (of which I thought it could mean MTU-28 Byte Headers). This is not a bad thing. Now we should find out what the maximum MTU is on your line:

Please open a command window (Start Menu -> Run Program - type "CMD"), then type this string in that window:

ping -f -l 1440 www.t-online.de

and press <Enter>. A reply like this (sorry - german Windows here)

Ping www.t-online.de [62.153.159.92] mit 1440 Bytes Daten:

Antwort von 62.153.159.92: Bytes=1440 Zeit=63ms TTL=245
Antwort von 62.153.159.92: Bytes=1440 Zeit=63ms TTL=245
Antwort von 62.153.159.92: Bytes=1440 Zeit=61ms TTL=245
Antwort von 62.153.159.92: Bytes=1440 Zeit=60ms TTL=245

should appear. Now press the <up> cursor key on your keyboard, the line you previously typed should appear again. Press <Left> until you can change the number 1440 to 1442:

ping -f -l 1442 www.t-online.de

Repeat this and increase the number by 2 or 4 until you get a reply like this

Paket müsste fragmentiert werden, DF-Flag ist jedoch gesetzt.
Paket müsste fragmentiert werden, DF-Flag ist jedoch gesetzt.
Paket müsste fragmentiert werden, DF-Flag ist jedoch gesetzt.
Paket müsste fragmentiert werden, DF-Flag ist jedoch gesetzt.
(Packet fragmented, DF-Flag set)

or another note of failure/no answer from server. Note the last working (with reply) number. You will need it soon. This value + 28 Bytes is your maximum possible MTU size.

Downwload "Dr. TCP" here:
http://www.softpedia.com/progDownload/DrTCP-Download-32633.html
It's a simple tool to tweak the TCP stack settings in your registry. Have a look at a documentation I found here http://www.dslreports.com/faq/578 for a screenshot.

Now get sure that your network adaptor/lan card is selected on the bottom and then enter the max. MTU you just investigated* into the "MaxMTU" number box beneath the adaptor selection menu. Click "Apply" and exit, reboot Windows.

*If your MTU from the ping command test +28 is lower than 1482, take that number. If it was 1482 (1454+28), enter 1472 in Dr.TCP and try. If nothing changes, try 10 lower. Try 1492, too. Remember that a reboot is necessary after every change.

If that helped or changed something, go to the Speedguide.net Tcp Analyzer again and post a new report, but this time edit away your IP-adress....:)

0

Hi, I tyed in the command 'ping -f -l 1440 www.t-online.de ' but it returned a different message, it read:

"Pinging www.t-mobile.de [193.254.151.164] with 1440 bytes of data:

PING: transmit failed, error code 65.
PING: transmit failed, error code 65.
PING: transmit failed, error code 65.
PING: transmit failed, error code 65.

Ping statistics for 193.254.151.164:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss)." :eek:

0

I hope DMR doesn't mind if I try to shoot the trouble right away.

Not at all; please be my guest. Your knowledge of German will honestly be much more helpful than my lack thereof. :mrgreen:

0

I'll be lurking around keeping an eye on the progress; I've got email auto-notification applied to this thread....

0

SUCCESS!!! :D :D :D

I tried setting the MTU value to 1472, 1462 and 1492 but to no avail so I gave 1454 a go and there you go; it worked!

A massive 'danke shun' to Xpenetrator and thank you to everybody that has tried to help. :D

Also, Xpenetrator, I noticed below the TCP Analyzer link there was a link to TCP Optimizer; is it worth using?

0

Woo-hoo! I'm glad to hear that! :cheesy:

I tried setting the MTU value to 1472, 1462 and 1492 but to no avail so I gave 1454 a go and there you go; it worked!

Well done! So thats why the Telekom guys decided to order their hardware with such a low default setting...:)

You might consider to set the MTU in the router itself if it's used with more than this computer. Set the registry MTU to 1500 then. (I guess Windows will reset that to 1480 anyway...)

Also, Xpenetrator, I noticed below the TCP Analyzer link there was a link to TCP Optimizer; is it worth using?

Yes definitely, a lot of people use it. But it looks a bit confusing since it has an overwhelming bunch of opportunities for tweaking, which can be intimidating. But it's quite easy: Just drag the slider according to your connection bandwith, then enter 1454 in the MTU box and click "optimal settings" near the bottom right, then click "Apply changes" and reboot. This way it sets your correct RWIN automatically.

This RWIN limits your connection speed, if it's set wrong (and it is!). That's why I wanted you to go to the analyzer page again: To verify whats your MTU now and to get the recommended RWIN for that MTU. Just c+p one of the proposed numbers (not the lowest 5-digit one) into Dr. TCP, apply and reboot. Or use TCP-Optimizer. Then everything should be ok.

@DMR: Thanks for backup. :)

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.