0

Help Please!

I am trying to create a maintenance plan in sql 2005 server. I am getting an error Microsoft.SqlServer.Management.DatabaseMaintenance.TaskUIUtils..ctor()'.
(Microsoft.SqlServer.MaintenancePlanTasksUI)


I am unable to create maintenance plan. I am on sp2, and applied a critical hotfix from the microsoft website. I thought maybe it was client tools, but isn't that the microsoft management studio? How about integration services....would that have anything to do with it? I am on windows xp.

Any help is greatly appreciated. What could the error above potentially effect besides the maintenance plan? I am also backing up my database through backup exec.

2
Contributors
27
Replies
29
Views
8 Years
Discussion Span
Last Post by Ramy Mahrous
0

Is the only way to valid that integration and agent services are installed correctly or started is through the dos prompt or can it be done through the server?

I am sorry........I am new at this.

0

Integration services from Start->Microsoft SQL Server 2005->SQL Server Business Intelligence Development Studio try to create new Integration services project
To check Agent Service you'll find it in SQL Server Management Studio SQL Server Agent

0

Integration services from Start->Microsoft SQL Server 2005->SQL Server Business Intelligence Development Studio try to create new Integration services project
To check Agent Service you'll find it in SQL Server Management Studio SQL Server Agent

I did the first part...integration services the way you suggested. I was able to get in, but over on the right where it shows connections, there is a red x through the database. When I click on the connection, i get the following error..connection successfully established with the server, but error occurred during logon process(shared memory...) Help!! Please

I tried installing sp2 from remotely, should it have been done right on the server? I am desperate, in case you cannot tell.

0

OK, I don't need you to develop something with Integration service, red X because you're missing something (don't care about that right now) you didn't tell me. Does Service Agent work?
Second take a screen shot to the error, and attach it here.

0

Ok. I went into sql server management studio and the sql server agent has the green arrow and i am able to move around and do different things. The main thing that I am concerned with right now is doing the maintenance plan. I am unable to do that. The error when trying to create maintenance plan is
TITLE: Microsoft SQL Server Management Studio
------------------------------

Method not found: 'Void Microsoft.SqlServer.Management.DatabaseMaintenance.TaskUIUtils..ctor()'. (Microsoft.SqlServer.MaintenancePlanTasksUI)


And....for the error on the integration services with the red x....I was only trying to create something there to test it. My maintenance plan is not working...that's where I am hurting. However the error from the x on the integration services is:

A connection was successfully established with the server, but an error occurred during logon process. (provider shared memory provider 0-no process is on the other end of the pipe

0

Also.....when I do select @@version is shows 9.00.3050.00 and when I go to help it states the studio version is 9.00.1399.00.

0

Please tell me that when I look at the server configuration manager that the analysis services should be running as well as everything else, meaning integration, full text, analysis, server, reporting, agent and browser services should all be running.

As if you cannot already tell....I am very new to this.

Analysis services and reporting was stopped. Could that be causing my problem?

0

Yes. I have downloaded sp2 earlier today and still no change to the ssms (which is the client tools right)?

I am wondering: Could it be because I was doing remote desktop to the server?
or
When the file downloads, is it automatic to update or do I need to double click on the file and then setup occurs?

If so, will the options come up to choose what I want to apply sp2 to?

0

so i need to be actually on the server, not remote? That stinks, but if it fixes....

0

Keep me up-to-date...

ok applied the update again........and now get the following error message...

hotfix.exe is a valid file, but just not for this type of machine.

I am using windows server 2003 r2....now what

0

x86 or x64??

x64


The log from the update is telling me that the only thing not being updated is the tool/workstations because it wasn't upgraded to prereq 3042. I can try the update to sp2 again?

0

Try, be sure the SP2 is also x64

Well maybe I didn't check the type of server correctly........can you refresh my mind.

Should I be checking the main server or the sql server......i know it sounds silly, but the sql server is on a windows 2003 r2 server. Which one would you like me to check, and how?

0

The SQL Server. Contact the administrator.

Ok my processor is a x86 family model etc, so I should try downloading the other file.

I know that when I tried doing the x86 sp2 it is telling me that the hotfix worked but not for this type of machine. So now what to do?

0

So you need to install SP for x86, iff the server which SQL Server not client tools resides in is x86.
See SP2 help file for the instructions.

0

Update SP2 on the server machine

Oh my gosh!!!! I have to give you a huge thank You for everything you have done. I am able to create maintenance plans.

Like I said, and I am sure you can tell....I am new at this, but it just saved me a headache down the road.

Thank you you resolved my issue!!!!

0

I am happy more than you because your problem solved :)
Please mark it as solved, and feel free to come here again to ask, and share your knowledge :)

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.