Hi,

I am trying to get a perl script that a contractor created for me but I am having some issues with it. I am NOT a perl programmer and I know just enough about it to be dangerous. I am more of a PHP/CSS guy.

Anyway, the purpose of this script is to allow entries to a contest for creative types. It collects their info, their ages, what category they are entering and then allows a file upload (up to five depending on the category, and creates the directories etc on the fly). It keeps this stuff in a mysql database. It all seems to be working except it will not output the last part of the script ... the confirmation. It creates all the directories and renames the files correctly, stores all of this in the dB but then outputs a blank screen or time out. I have verified that perl is running correctly on the server and because it is storing the info in the dB, we can safely assume there is no problem with the dB connection.

In the error log, I am getting:

[Tue Jan 19 00:19:58 2010] upload.cgi: Name "main::filepath" used only once: possible typo at ./upload.cgi line 82.
[Tue Jan 19 00:19:58 2010] upload.cgi: Name "main::xx" used only once: possible typo at ./upload.cgi line 128.
[Tue Jan 19 00:19:58 2010] upload.cgi: Name "main::refer" used only once: possible typo at ./upload.cgi line 23.
[Tue Jan 19 00:19:58 2010] upload.cgi: Name "main::data" used only once: possible typo at ./upload.cgi line 12.
[Tue Jan 19 00:19:58 2010] upload.cgi: Name "main::q" used only once: possible typo at ./upload.cgi line 12.
[Tue Jan 19 00:19:58 2010] upload.cgi: Name "main::tmpfile" used only once: possible typo at ./upload.cgi line 42.
[Tue Jan 19 00:19:58 2010] upload.cgi: readline() on closed filehandle TEMPLATE at ./upload.cgi line 16.
[Tue Jan 19 00:19:58 2010] upload.cgi: Use of uninitialized value in concatenation (.) or string at ./upload.cgi line 24.
[Tue Jan 19 00:19:58 2010] upload.cgi: Use of uninitialized value in concatenation (.) or string at ./upload.cgi line 43.

I also sometimes, depending on what I have been trying am getting:

[Tue Jan 19 00:03:18 2010] [warn] [client 192.168.1.107] Timeout waiting for output from CGI script /var/clients/client0/web24/cgi-bin/upload.cgi, referer: http://nawentry.office/entry/entry_form.php

I do not know what else I can tell you but would really welcome some help with this as I have been at it a while now and need to get this functioning sooner than later, and as I said, this is not really my area of expertise.

Thanks for your consideration.

Dave

Anyone??

Hi,

I am trying to get a perl script that a contractor created for me but I am having some issues with it. I am NOT a perl programmer and I know just enough about it to be dangerous. I am more of a PHP/CSS guy.

Anyway, the purpose of this script is to allow entries to a contest for creative types. It collects their info, their ages, what category they are entering and then allows a file upload (up to five depending on the category, and creates the directories etc on the fly). It keeps this stuff in a mysql database. It all seems to be working except it will not output the last part of the script ... the confirmation. It creates all the directories and renames the files correctly, stores all of this in the dB but then outputs a blank screen or time out. I have verified that perl is running correctly on the server and because it is storing the info in the dB, we can safely assume there is no problem with the dB connection.

In the error log, I am getting:

[Tue Jan 19 00:19:58 2010] upload.cgi: Name "main::filepath" used only once: possible typo at ./upload.cgi line 82.
[Tue Jan 19 00:19:58 2010] upload.cgi: Name "main::xx" used only once: possible typo at ./upload.cgi line 128.
[Tue Jan 19 00:19:58 2010] upload.cgi: Name "main::refer" used only once: possible typo at ./upload.cgi line 23.
[Tue Jan 19 00:19:58 2010] upload.cgi: Name "main::data" used only once: possible typo at ./upload.cgi line 12.
[Tue Jan 19 00:19:58 2010] upload.cgi: Name "main::q" used only once: possible typo at ./upload.cgi line 12.
[Tue Jan 19 00:19:58 2010] upload.cgi: Name "main::tmpfile" used only once: possible typo at ./upload.cgi line 42.
[Tue Jan 19 00:19:58 2010] upload.cgi: readline() on closed filehandle TEMPLATE at ./upload.cgi line 16.
[Tue Jan 19 00:19:58 2010] upload.cgi: Use of uninitialized value in concatenation (.) or string at ./upload.cgi line 24.
[Tue Jan 19 00:19:58 2010] upload.cgi: Use of uninitialized value in concatenation (.) or string at ./upload.cgi line 43.

I also sometimes, depending on what I have been trying am getting:

[Tue Jan 19 00:03:18 2010] [warn] [client 192.168.1.107] Timeout waiting for output from CGI script /var/clients/client0/web24/cgi-bin/upload.cgi, referer: http://nawentry.office/entry/entry_form.php

I do not know what else I can tell you but would really welcome some help with this as I have been at it a while now and need to get this functioning sooner than later, and as I said, this is not really my area of expertise.

Thanks for your consideration.

Dave

I was just about getting to that. But I found the error and it all boiled down to one path error causing all of the problems. Wouldn't you know it ;-)

Anyway ... thanks.

Dave

This question has already been answered. Start a new discussion instead.