Start New Discussion within our Software Development Community

Why I try to run the following OpenCV program, it shows the following error :
----------------------------------------------------------------------
test_1.exe - Application Error

The application failed to initialize properly (0x80000003). Click on OK to terminate the application.
----------------------------------------------------------------------

#include "cv.h"
#include "highgui.h"

int main()
{
	IplImage *img = cvLoadImage("C:\\face.bmp");
	
	cvSetImageROI(img, cvRect(100,100, 100, 100));
	cvAddS(img, cvScalar(50), img);
	cvResetImageROI(img);
	cvShowImage("Test", img);

	cvWaitKey(0);

	return 0;
}

When i press F5(im using vs2008express), the program encounters a break point...i have attached a picture...dont know, whether, it will help or not.

http://i39.photobucket.com/albums/e179/iamcreasy/error.jpg

It is not that, only this program is producing this error, but also any kind of image manipulation funciton containing (OpenCV)program is resulting in this sitution.
Such as : cvSmooth

one last thing, it there any dedicated OpenCV forum or sth like that?

I have made a little progress.

Check the program with Dependency Walker, and found out that somwhere in related with SHLWAPI.DLL and MPR.DLL a function
WNetRestoreConnectionA in causing the error, which cannt be loaded at runtime.

http://www.dependencywalker.com/faq.html

As far has i have seen this is a common error.But, yet havn't found a solution.

Googling answers a little...it says,
"Turn off your compilers setting to assume you are programming for Win9x.
(I just lost which setting but it is not that difficult, use a #define...) "

...how to do this is VS2008 express?

this simple problem is freaking me out. :@ :@

This article has been dead for over six months. Start a new discussion instead.